Previous 1 3 4 5 6 7 Next 501 Replies Latest reply: Aug 1, 2014 5:22 PM by wickeninc Go to original post Branched to a new discussion.
  • Grant Bennet-Alder Level 9 (56,570 points)



    Every one is a page fault

    BSD process name corresponding to current thread: launchd

    BSD process name corresponding to current thread: Finder

    BSD process name corresponding to current thread: WebProcess

    BSD process name corresponding to current thread: PluginProcess

    BSD process name corresponding to current thread: Skype


    The trend in those panics is...

  trend, they are all over the map.


    The conclusion I draw from that is that your MacBook has a RAM Memory problem.


    If you were ever considering a RAM upgrade, now is the time. Otherwise, you should be running memtest or similar memory testing utility all night every night for the forseeable future.

  • dstwins Level 1 (0 points)

    Normally I would agree with you.. but two things...


    1:  I have run Memtest several times.. (especially since the ML incident).. 100% clean..

    2:  These problems have only manifested since being on ML.. Lion and below runs solid.. never a hiccup.  When I drop back to Lion, its solid.. (did that for a few days to confirm nothing's broken).. perfect.. move back to ML and its KP city.

  • Grant Bennet-Alder Level 9 (56,570 points)

    Memory problems are remarkaby difficult to pinpoint. It can takes days of running diagnostics and still not result in a conclusive finding. It may be that something about the way Mountain Lion allocates and uses memory causes the problems to surface more readily.


    If you are still skeptical, try swapping the modules with each other inside your MacBook. Sometimes this changes the symptoms. It is not a cure, just a change that may (or may not) make the problems easier to identify.

  • mrstep Level 1 (0 points)

    Alright, maybe some progress. While there are apparently issues with the AMD Radeon graphics layer (particularly when QuickLook is trying to decode images, potentially more than 1 image at a time with multiple threads hitting it), the kernel panics appear to have been caused by Little Snitch 3.0 (beta). Not sure if 2.5 would have had the same issue or not.


    It looks like what is happening is that an app that's hitting multiple QL thumb lookups and/or requesting a QL preview window was crashing - still in the QL graphics decode stack - but (my somewhat educated speculation since it's not longer panicing, just crashing) Little Snitch was intercepting the app crash in the kernel layer and choking on it. Boom, kernel panic.


    So I'm not sure why QL thumbnail calls can crash apps (maybe it's not threadsafe, maybe not when using CGD threads?), or maybe the 10.8.1 video decode layer optimized/introduced a bug with the Radeon driver interaction and having Little Snitch in place was just making it worse.


    Anyways, not touching Little Snitch until this QL/Radeon issue is resolved!

  • mrstep Level 1 (0 points)

    Or partial progress? I just hit Space to QuickLook, watched the screen go black and after yet another reboot:


    Wed Sep  5 17:22:50 2012

    panic(cpu 14 caller 0xffffff80264b7b95): Kernel trap at 0xffffff7fa81074e6, type 14=page fault, registers:

    CR0: 0x000000008001003b, CR2: 0x00000f8400000a11, CR3: 0x0000000366304003, CR4: 0x00000000000206e0

    RAX: 0x0000000000000000, RBX: 0xffffff82c72ebce0, RCX: 0xffffff82c72ebce0, RDX: 0xffffff806cae33a0

    RSP: 0xffffff82d7f73a40, RBP: 0xffffff82d7f73a50, RSI: 0xffffff82c72ebce0, RDI: 0xffffff80587cc000

    R8:  0x00000f8400000a09, R9:  0xffffff82c6a64cc8, R10: 0x000000010a7b9001, R11: 0x0000000000000001

    R12: 0xffffff80587cc000, R13: 0xffffff8296269000, R14: 0xffffff82c72ebce0, R15: 0xffffff806cae33a0

    RFL: 0x0000000000010206, RIP: 0xffffff7fa81074e6, CS:  0x0000000000000008, SS:  0x0000000000000010

    Fault CR2: 0x00000f8400000a11, Error code: 0x0000000000000000, Fault CPU: 0xe



    Backtrace (CPU 14), Frame : Return Address

    0xffffff82d7f736e0 : 0xffffff802641d5f6



    And that's the entire log for this panic!


    I'm ready to restore to a more stable version of ML... Is there an easy way to remove the 10.8.1 update? Is it possible to grab the 10.8.0 installer from Apple and use that to overwrite 10.8.1? This is just getting to be ridiculous, and I never saw a crash pre-10.8.1 anyways. Or it could be unrelated, but I'd be really happy to try rolling back. :/


    (Yes, happy may be a stretch.)

  • dstwins Level 1 (0 points)

    So if I purge the Kernel cache and let it rebuild, I get slightly better time between KP's..  But as I said.. if I drop back to Lion... (or if I use Windows 2008 R2, which is in my bootcamp for my Microsoft Corp work), its perfect.. never a KP/BSOD unless I install crap or a bad driver (which is typical), so I am less inclined to think its a faulty RAM chip and more to do with some odd interaction with ML.


    One thing I have noticed.. when I do a scan on the interwebs.. *grin*.. I do notice that a number of people are reporting KP's if they are running 16GB (or more) of RAM.. vs. when they drop back to 4 or 8GB (depending what their stock memory was, or when they purchased their kit, either the problems go away or are greatly reduced.  I am wondering if the garbage collection process in ML is faulty.

  • Jmkoury Level 1 (0 points)



    This Kernels are making my thristy... Cosmo Kramer...


    I took my mbpro to an authorized service. They tried to run the apple hardware test, not the one that comes with the snow leopard cd. This process requires them to plug a ethernet cable, restart the computer and pressing  the letter N for Network.


    I was hoping that the test shows up the faulty video card, but instead, the test couldn't load up!! Not a single component could be tested! The progress bar just got to a point and stoped at Gathering Software Data. The next step of the process is to test the logic board, then the rest of the stuff, processor, ram, graphic card, power supply, all of the components of your computer.


    The tech guy bring in another computer a ran the test (wich btw before you click the button you can read a label that states: 1-3 minutes) and the test ran perfectly fine!!


    So his conclussion was that when I upgraded my ram, ssd and set the old hdd into the superdrive spot I didn't discharged (static) myself well so I fried the logic board. I'm pretty **** sure that I followed all the step so I don't f.... up anything inside my computer. (anti-static pad, anti-static wristband, everything by the book, went in and went out in less than 20 minutes, no smoke, no dirt, no humidity)


    I tried to make him understand that my computer was running perfectly fine for about 8 months and when I installed mountain lion the problems began. I tried to tell him that there was a recall for my machine (mbpro mid 2010) regarding the video card, something he told me he didn't know but his face said that he obviously knew about it. So his assistant went into her computer and check my serial number and she told me that we have to run the test to verify if there was a problem with my card, but noting that the test could not be run, it has to be the logic board.


    The price for a new logic board is $986 plus $30 for 2 service hours.


    Next step:


    I'm running time machine at the moment and I have two options in my mind:


    1. Going back to snow leopard, when everything was working fine, forget about the 20 bucks for ML and live happily ever after...


    2. Take away the ram, installed the old one, take out my ssd :'( install the old one, reinstall the superdrive and take my mbpro to another authorized dealer and don't say a word about this.


    Any sugestions??

  • LeafsMac Level 1 (20 points)

    Sounds like it's indeed cooked.  "DIY" computer stuff always brings risks. 


    First go back to the stock setup.  If that doesn't work, revert to SL.


    Then if that doesn't work, or you want to continue using ML... and if you're in the US... call the 800 number and inquire about the flat rate repair mail order service.  Could be $350 instead of a grand.  But don't tell them you had your screwdriver out, and if you send it back, make sure it's stock with all orginal parts.

  • dstwins Level 1 (0 points)

    Ok.. I'm back to 10.7.3.. 100% rock solid (no KP's or issues).. it looks like apple has totally screwed up 10.7.4 (still KP's) and 10.8.0/1 Since they seem to have the same core kernel base as 10.7.4, especially for late 2011 people. I said it before and I'll say it again, this is certainly my last apple device/product.  So far the only thing they produce that is stable (even if they are not enterprise ready) is the iphone/pad.

  • Grant Bennet-Alder Level 9 (56,570 points)



    Shortened kernel panic logs often correlate with memory problems.

  • mrstep Level 1 (0 points)

    Thanks Grant, I'll run the hardware tests though I thought ECC was supposed to either fix or flag something like that - I'm just really aggravated. It's very reproducible (if _I_ call the QuickLook API giving it the URL to a jpeg file), but it's not always, just often enough to be completely unusable.


    I rolled back to 10.8.0 and have the same issue, but of course I'm not sure if doing so would have rolled any video driver changes back as well. Given that the panics seem to originate in the graphics drivers when decompressing an image, I'm not sure it's sytem memory - maybe the card?


    I'm totally willing to upgrade to a newer card to stop this, but Apple doesn't seem to (officially) support that, and I'm certainly not buying the same card as a replacement in the hopes that it's not a driver issue. :/


    Anyway, the latest trace under 10.8.0, just asking QuickLook for a preview again. Sweet. Not.



    Anonymous UUID:                    2E0417AC-D686-4E62-9186-16AF113426A2



    Sun Sep  9 12:51:55 2012

    panic(cpu 18 caller 0xffffff8024eb7b95): Kernel trap at 0xffffff7fa67d8325, type 13=general protection, registers:

    CR0: 0x000000008001003b, CR2: 0x000000010182f880, CR3: 0x000000014d7a4010, CR4: 0x00000000000206e0

    RAX: 0xffffff7fa6b9f5a0, RBX: 0xffffff80719c5800, RCX: 0xffffff80570d91f0, RDX: 0x0000000000000200

    RSP: 0xffffff82d5ceba80, RBP: 0xffffff82d5cebae0, RSI: 0x0003040000000e5c, RDI: 0xffffff80566a7c00

    R8:  0x0000000000001401, R9:  0xffffff8027865920, R10: 0xffffff82c4d44000, R11: 0x0000000000000000

    R12: 0xffffff80570d91f8, R13: 0xffffff80570d9000, R14: 0x0003040000000e5c, R15: 0x0000000000000000

    RFL: 0x0000000000010246, RIP: 0xffffff7fa67d8325, CS:  0x0000000000000008, SS:  0x0000000000000010

    Fault CR2: 0x000000010182f880, Error code: 0x0000000000000000, Fault CPU: 0x12



    Backtrace (CPU 18), Frame : Return Address

    0xffffff82d5ceb720 : 0xffffff8024e1d5f6

    0xffffff82d5ceb790 : 0xffffff8024eb7b95

    0xffffff82d5ceb960 : 0xffffff8024ece4ad

    0xffffff82d5ceb980 : 0xffffff7fa67d8325

    0xffffff82d5cebae0 : 0xffffff7fa67efc92

    0xffffff82d5cebb00 : 0xffffff7fa67ee7b3

    0xffffff82d5cebb40 : 0xffffff7fa67ee5e5

    0xffffff82d5cebb80 : 0xffffff7fa67ed72d

    0xffffff82d5cebba0 : 0xffffff7fa67ed7b0

    0xffffff82d5cebbd0 : 0xffffff802525f891

    0xffffff82d5cebbf0 : 0xffffff8024e92fea

    0xffffff82d5cebc30 : 0xffffff8024e20adc

    0xffffff82d5cebc60 : 0xffffff8024e10448

    0xffffff82d5cebcb0 : 0xffffff8024e20dc2

    0xffffff82d5cebce0 : 0xffffff8024e4efd1

    0xffffff82d5cebd20 : 0xffffff8024e16776

    0xffffff82d5cebd90 : 0xffffff8024e1830c

    0xffffff82d5cebdd0 : 0xffffff8024e359f0

    0xffffff82d5cebe10 : 0xffffff8025156607

    0xffffff82d5cebe80 : 0xffffff8025168a27

    0xffffff82d5cebf10 : 0xffffff8025168eb7

    0xffffff82d5cebf50 : 0xffffff8024e1b6b1

    0xffffff82d5cebf90 : 0xffffff8024eb8123

    0xffffff82d5cebfb0 : 0xffffff8024ece47c

          Kernel Extensions in backtrace:

   [7DC411F1-A646-3A4A-B160-A1492F5EC0 ED]@0xffffff7fa67ce000->0xffffff7fa6814fff

                dependency:[8C9E06A4-13D0-33F5-A377-9E36F0ECC229]@0xffffff 7fa544d000

                dependency:[E37F420A-B5CD-38ED-9441-5247583B6ACE]@0xff ffff7fa61e7000

                dependency:[5D671681-D21B-3CCA-9810-B15E648C1B27]@0 xffffff7fa61b0000



    BSD process name corresponding to current thread: SimpliFile



    Mac OS version:




    Kernel version:

    Darwin Kernel Version 12.0.0: Sun Jun 24 23:00:16 PDT 2012; root:xnu-2050.7.9~1/RELEASE_X86_64

    Kernel UUID: 8D5F8EF3-9D12-384B-8070-EF2A49C45D24

    Kernel slide:     0x0000000024c00000

    Kernel text base: 0xffffff8024e00000

    System model name: MacPro5,1 (Mac-F221BEC8)



    System uptime in nanoseconds: 1338897864542

    last loaded kext at 863890549792:          97 (addr 0xffffff7fa6e31000, size 16384)

    last unloaded kext at 368823264822:          1.8 (addr 0xffffff7fa6dc4000, size 57344)

    loaded kexts:          97          1.9.5d0          75.15          3.5.10          1.0.0d1          122          1.0.33          2.3.0f2          8.0.0          1.0.2d2          100.12.69          4.0.9f8          1.60          2.3.0b4          2.3.0f2          1.0.0          7.0.0          352.4.2          4.0.9f8          1.6.0          600.15.20          1.0.0          3.2.6          3.0          3.5.1          1.0.0d1          1.0.0d1          34          404          2.2.0          5.1.6          4.9.5          2.4.0          5.1.5          5.1.5          1.6.1          1.5          1.7          1.6          1.9          1.6          1.6          196.0.0          4.0.39          2          196.0.0          97          97          97          97          97          97          97          4.0.9f8          235.27          86.0.2          10.0.6          2.3.0f2          1.0.10d0          19.0.26          4.0.9f8          2.9.0f4          1.8.9fc9          1.6          4.0.9f8          2.3.0f2          2.3.0f2          500.15          1.0.10d0          8.0.0          8.0.0          2.2.5          3.0          3.1.3d11          1.0.0          5.2.0d16          3.2.6          2.3.4          2.3.4          1.0          165.5          165.5          5.0.0          5.1.5          5.0.0          3.5.1          1.7          1.7.1          1.7.1          2.5.0          3.5.1          4.5.5          5.0.0          2.2.0          5.1.6          1.6.1          1.8.0          1.1          220          1.0.0d1          7          344          1.8          28.18          1.6          2.7          1.4          1.0

    Model: MacPro5,1, BootROM MP51.007F.B03, 12 processors, 6-Core Intel Xeon, 2.66 GHz, 24 GB, SMC 1.39f11

    Graphics: ATI Radeon HD 5770, ATI Radeon HD 5770, PCIe, 1024 MB

    Memory Module: DIMM 1, 4 GB, DDR3 ECC, 1333 MHz, 0x857F, 0x463732353155363446393333334700000000

    Memory Module: DIMM 2, 4 GB, DDR3 ECC, 1333 MHz, 0x857F, 0x463732353155363446393333334700000000

    Memory Module: DIMM 3, 2 GB, DDR3 ECC, 1333 MHz, 0x80AD, 0x484D54313235553754465238432D48392020

    Memory Module: DIMM 4, 2 GB, DDR3 ECC, 1333 MHz, 0x80AD, 0x484D54313235553754465238432D48392020

    Memory Module: DIMM 5, 4 GB, DDR3 ECC, 1333 MHz, 0x857F, 0x463732353155363446393333334700000000

    Memory Module: DIMM 6, 4 GB, DDR3 ECC, 1333 MHz, 0x857F, 0x463732353155363446393333334700000000

    Memory Module: DIMM 7, 2 GB, DDR3 ECC, 1333 MHz, 0x80AD, 0x484D54313235553754465238432D48392020

    Memory Module: DIMM 8, 2 GB, DDR3 ECC, 1333 MHz, 0x80AD, 0x484D54313235553754465238432D48392020

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8E), Broadcom BCM43xx 1.0 (

    Bluetooth: Version 4.0.9f8 10405, 2 service, 18 devices, 1 incoming serial ports

    Network Service: Built-in Ethernet 1, Ethernet, en0

    Network Service: AirPort, AirPort, en2

    PCI Card: ATI Radeon HD 5770, sppci_displaycontroller, Slot-1

    PCI Card: pci1b4b,9123, sppci_ahci, Slot-4

    PCI Card: pci1b4b,91a4, sppci_ide, Slot-4

    Serial ATA Device: HL-DT-ST DVD-RW GH41N

    Serial ATA Device: eSATA-2 ExternalRAID, 6 TB

    Serial ATA Device: ST31500341AS, 1.5 TB

    Serial ATA Device: ST31500341AS, 1.5 TB

    Serial ATA Device: ST31500341AS, 1.5 TB

    Serial ATA Device: ST32000542AS, 2 TB

    USB Device: USB2.0 Hub, 0x05e3  (Genesys Logic, Inc.), 0x0608, 0xfa200000 / 2

    USB Device: USB2.0 Hub, 0x05e3  (Genesys Logic, Inc.), 0x0608, 0xfa230000 / 4

    USB Device: iCM20 USB 2.0 Camera, 0x060b  (Solid Year Co., Ltd.), 0x8002, 0xfa232000 / 6

    USB Device: Intuos5 touch S, 0x056a  (WACOM Co., Ltd.), 0x0026, 0xfa231000 / 5

    USB Device: WinTV HVR-980, 0x2040  (Hauppauge Computer Works, Inc.), 0x6513, 0xfa240000 / 3

    USB Device: hub_device, apple_vendor_id, 0x9132, 0xfd300000 / 3

    USB Device: Keyboard Hub, apple_vendor_id, 0x1006, 0xfd310000 / 5

    USB Device: Apple Keyboard, apple_vendor_id, 0x0220, 0xfd312000 / 6

    USB Device: Apple Cinema HD Display, apple_vendor_id, 0x9232, 0xfd320000 / 4

    USB Device: USB2.0 Hub, 0x05e3  (Genesys Logic, Inc.), 0x0660, 0xfd100000 / 2

    USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x5a100000 / 2

    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8215, 0x5a110000 / 3

    FireWire Device: built-in_hub, 800mbit_speed

  • Grant Bennet-Alder Level 9 (56,570 points)



    RE: the shortened panic report.


    If a memory issue or a second panic occurs while the first panic is being handled, you may not be able to correctly record the first panic because the second one interferes with it. This is a very unusual occurence except perhaps with memory errors in the error handler itself.


    I would write yours (in a Mac Pro) off to "stuff happens" unless it keeps coming back, and not worry about it.


    This one you posted above looks like driver issues (not graphics Hardware issues).


    8.1 update does not specifically say it addresses those kinds of issues, but it may work better. Who knows?

  • mrstep Level 1 (0 points)



    I definitely can't write it off - way too reproducible, though not in general, seems to happen with an app I'm writing that does QL thumbnails and can open the QL preview window. The irritating thing is that I can run the same app on my Air and NEVER see a problem (but then it's obviously running a different video driver...), and that I didn't see any issues on the Mac Pro until the last couple of weeks.  I rolled my own code base back to before I saw problems and still got a kernel panic when opening a QL preview window at least implying that the problem isn't any change I made recently.


    I've decided to try upgrading the graphics card anyways (waiting for the mini-to-standard PCI Express power cable to arrive) to a 660Ti since the reports seem to be that it will work under ML even if Apple isn't supporting it officially. I'm looking for better performance anyways and hoping the side effect is that the video driver doesn't have this issue. I really wish Apple would release some updated cards themselves though since the entire point of having an expandable/upgradable machine is to NOT have to use several generation old hardware.


    Maybe 10.8.2 will fix it - I know I've sent in a bunch of panic logs at this point. Kind of crazy anyways, I've always loved my Pro because it was like the Titanic. Never thought a QL preview window could sink it.

  • mrstep Level 1 (0 points)

    OK, I swapped out the Radeon 5770 for a EVGA Geforce GTX 660Ti, and - lo and behold! - I can now open a QuickLook preview without things hitting the fan. So I'm certainly going to go with there either being an issue with the 5770 card or with the driver, more likely the driver. And I really suspect Apple isn't looking into driver issues for the Mac Pros with any sort of fervor at this point - or they would have newer cards available themselves in something at least approaching a timely manner. (You know, like even 1-2 new cards a year?)


    Now I have a 3GB card, which apparently means that Apple's drivers may have shut off CUDA, and given that switching between images in the QL Preview window seems slower now than it was, I'd guess that's exactly what was being accelerated AND what was crashing. (Oh, and every chance that it was optimized further in newer drivers than it used to be?)


    Time to decide if I try to hack some driver file to tell it that it's OK to enable CUDA despite the card having more than 2GB of RAM (apparently it's hard-coded in there somewhere), or if I just leave CUDA off and opt for stability. Sort of thinking the latter, but let's be honest, it's going to be tough not to try to flip a magic switch to get back some extra performance. OR I go and exchange this card for one with 2GB. Decisions decisions.


    But anyway, I'll let you all know if I see any more issues, but I'm chalking this one up to an issue most likely in the video or CUDA handling on the 5770. And the specific case I have has a lot of CA Layers open in a window holding thumbnails of the files, and asking for a QL Preview would then choke things. Probably memory handling on the card or something, but just not something I'm thinking will actually be fixed anytime soon.

  • MBR76 Level 1 (0 points)

    Hi everyone, I seem to have the same problem. Also a MBP 2010 with ML. Constantly appearing kernel panics, obviously related to graphics hardware. Usually, I can reproduce the panics within seconds to minutes. Start an application which forces the Mac to switch to the GT 330M (like iPhoto does!), do some transitions (open/close launchpad, mission control or a fullscreen app) and the kernel panic will appear quickly.


    Now I installed gfxCardStatus and force the system to use only the (very slow) internal intel graphic processor (must use settings and set integrated for battery and line). And for several days, the system didn't crash. It seems that I can do all those things, causing the panic very quickly if the NVidia chip is used.


    All this mess started with the update to 10.8. With snow leopard, the machine was as stable as the Linux systems I used before. Regarding the fact that there are other users out there with exactly the same problem, I see two possible causes:

    - OSX 10.8 is buggy and has a problem with the NVidia GT 330M (driver or any other part of the software stack)

    - The 15" MBP 2010 hardware has a design or quality problem

    Unfortunately, in both cases the initiator is apple. So any ideas what I (or all the other with this problem) should do? There are little apple stores (and thus genius bars) in germany (and I think not only here). :-(



Previous 1 3 4 5 6 7 Next