5 Replies Latest reply: Jul 31, 2012 10:40 AM by sporting1906
sporting1906 Level 1 Level 1 (0 points)

hi guys

so..here's the thing . i can't mantain an internet connection with my iMac for more than 30 seconds. i have wireless inernet on my house and every other equipment connectd to the internet perfectly ( my cell phone , my ipod touch and 2 PCs). It goes something like this :

i open my browser (i use firefox )

i open any website , and for 30 seconds it's ok

i then try to open another page or something and it starts loading until a message saying that firefox can't find the server pops up (although the airport signal is as strong as possible )

i found a temporary solution ( but it really frustrating to this every 30 seconds) , which is to open system preferences , network setting , hit advanced , then i click Renew DHCP lease. By doing that i just get another 30 seconds of internet.

 

i tried many things that were suggested in forums such as this , including :

- set the ipv4 manually

-deleting airport and then adding it again

-shut it down time and time again and turn it back on again using the safe mode

-i even tried establishing a powerline ethernet system but the same thing happens (so the problem isn't only related to wi-fi )

-resetting the router

-open the firewall options and click "allow all incoming connections"

 

so can you guys help me or is this a hardware problem?


Mac OS X (10.5.8)
  • BDAqua Level 10 Level 10 (119,875 points)

    Hello,

     

    Make a New Location, Using network locations in Mac OS X ...

     

    http://support.apple.com/kb/HT2712

     

    10.5.x/10.6.x/10.7.x instructions...

     

    System Preferences>Network, top of window>Locations>Edit Locations, little plus icon, give it a name.

     

    System Preferences>Network, click on the little gear at the bottom next to the + & - icons, (unlock lock first if locked), choose Set Service Order.

     

    The interface that connects to the Internet should be dragged to the top of the list.

     

    Instead of joining your Network from the list, click the WiFi icon at the top, and click join other network. Fill in everything as needed.

     

    For 10.5/10.6, System Preferences>Network, unlock the lock if need be, highlight the Interface you use to connect to Internet, click on the advanced button, click on the DNS tab, click on the little plus icon, then add these numbers...

     

    208.67.222.222

    208.67.220.220

     

    Click OK.

     

    Also, turn off IPv6:

    System Preferences » Network » AirPort » TCP/IP tab » Configure IPv6

     

    Or whatever interface you connect with.

  • sporting1906 Level 1 Level 1 (0 points)

    omg .you sir , saved my life. thank you so much . i feel like i owe you money or something . here, have an internet plus sign:

     

    thank you!

  • roam Level 6 Level 6 (13,560 points)

    A plus sign is ephemeral s'1906. You can make burnt offerings to him on the next solstice.

  • BDAqua Level 10 Level 10 (119,875 points)

    Great news, thanks & good luck!

  • sporting1906 Level 1 Level 1 (0 points)

    lol you're right , everything is ephemeral ...except my internet connection...have a plus sign too, i'm feeling generous :