Previous 1 2 3 4 Next 85 Replies Latest reply: Jun 16, 2014 5:15 PM by Jon Walker Go to original post
  • Malcolm J. Rayfield Level 5 (6,960 points)

    R08 wrote:

     

    ...

     

    Thankfully like all things it's easy when you know how, this is what worked for me.

     

    Download and extract the A52Codec.component file and replace the one in your Mac's /Library/Audio/Plug-Ins/Components/ directory with it.

     

    ...

    Thank you.  That fixed AC-3 playback on my Mountain Lion.

     

    Where did you find that codec?  It has the same version number (1.8) as the codec in Perian but the file is much smaller and has a more recent date (and it works with Mountain Lion).

     

    I searched but found only versions older than Perian's.

  • Marco9774 Level 1 (0 points)

    That version worked for me also. Thank you for your support.

     

    I know it's not related but the subtitles (.srt) stop working with ML using QT7. I can only use subtitles with VLC. Is there a fix for this already or should we wait for a new perian version?

  • Malcolm J. Rayfield Level 5 (6,960 points)

    ,srt subtitles work for me with QT7 and Perian 1.2.3 in Mountain Lion.  Does the .srt file have the same name as the video file?  Is "Load External Subtitles" enabled in the "General" tab of "Perian" system preference?

  • R08 Level 1 (0 points)

    Followed the instruction here which include a link to the download.

     

    The OP's English is not too great but you can't argue with his/her results.

  • deltaguru Level 1 (0 points)

    Thanks for the fix-

     

    Roland, Switzerland

  • pd3hree Level 1 (0 points)

    Thanks so much. You can't even imagine how this helped! Worked like a charm.

  • jpdemers Level 1 (20 points)

    None of the solutions involving the A52 codec or Perian worked for me, but I did discover that DivX Player 7.2 works fine, while DivX Plus Player  8.2.2 does not.  Hope this helps anyone in a similar bind.

  • Lefkows Level 2 (175 points)

    I installed the a52 codec and followed the install instructions but could not get avi files with AC3 audio codec to play the audio with QT 10, perian 1.2.2, OS X 10.8.2. Plays fine in VLC and MPEG Streamclip but doesn't play with DiVX Player either. I really don't care that I can't play them with  QT 10 just curious about why.

  • Malcolm J. Rayfield Level 5 (6,960 points)

    Install Perian 1.2.3 then replace the A52Codec.  This should allow QuickTime Player 7 (Utilities foldr\er) to play the files.

  • JF O Level 1 (0 points)

    this one actually fixed the problem for me

     

    thanks a lot!

  • palomar3s Level 1 (0 points)

    problem fixed. thank you very much!

  • Joe Binks Level 1 (10 points)

    Install Perian 1.2.3 then replace the A52Codec.

     

    This didn't seem to work for me.. until i tried putting the A52Codec.component into ..>Library>QuickTime. (instead of the Audio>Plug-ins folder mentioned earlier)

     

    Then it worked

  • alexpush Level 1 (0 points)

    I am trying to play an Xvid/AC3 file in Mountain Lion. Both audio and video play fine in VLC Player. QT7 and MPEG Streamclip only plays video. QT 10 opens the file but doesn't play it. I need to edit this file in Final Cut, and therefore I need QT to be able to read it.

     

    I have Perian 1.2.3 installed, and pasted A52Codec.component in both places as suggested above, but still no audio.

     

    I uploaded a 10 second clip here:
    https://www.yousendit.com/download/WUJiUWV0OW5PSHcxZXNUQw

     

     

    Please let me know if you have any suggstions.

  • Malcolm J. Rayfield Level 5 (6,960 points)

    The 10 second clip plays fine (audio and video) here with QuickTime Player 7, MPEG Streamclip, and VLC.  QuickTime 10 behaves as it does on your computer, but that is normal for AC-3 files.

     

    I have Perian 1.2.3

     

    The Perian version of "A52Codec.component" in:

    /Library/Audio/Plug-Ins/Components/
    has been replaced with the special Mountain Lion version.  It is 194 KB.  The Perian version is much larger.
    The only other file in that folder is "Flip4Mac WMA Import.component"
    I do not have a "A52Codec.component" in:
    /Library/QuickTime/
    but it does contain the Perian files "AC3MovieImport.component" and "Perian.component".
    Did you remove the obsolete QuickTime Components: FFusion, Xvid Delegate, 3ivX, DivX, DivX Decoder, XviD, msmpeg4v1, msmpeg4v2, AviImporter, EX_M4S2, Casio AVI Importer, AC3 Codec, and MatroskaQT?  See:
    (Scroll down to the Installation section.)

  • jpdemers Level 1 (20 points)

    I can verify Malcom's solution: I downloaded and extracted the "Special ML version" of A52Codec.component , put it into the  /Library/Audio/Plug-Ins/Components/ directory (root library, not the user ~/Library), and QT7 played your clip with audio.

    That's with Perian 1.2.3 installed and Multi-Channel Output selected.  If this doesn't work for you, my guess would be that you've got a conflicting codec lurking in one of your libraries: /LIbrary/Audio, ~Library/Audio, or /Library/Quicktime.

Previous 1 2 3 4 Next