Previous 1 2 3 Next 176 Replies Latest reply: Feb 23, 2014 6:28 PM by jpenguin911
OneBigBear Level 1 Level 1

I recently upgraded my 2012 MacBook Pro (w/o the new display) from Lion to Mountain Lion. On the ladder, iTunes Match doesn't work. It never connects, in other words, I can't use it, thus making songs uploaded unplayable. On Lion, iTunes Match worked perfectly. I tried resetting iTunes Store Cache, program itself, turning off and on Itunes Match several times, etc, but nothing works. So now what can I do? Hopefully Apple rolls out an update this week to correct the problem. This is very irritating.


MacBook Pro, OS X Mountain Lion
Reply by Mawdsley on Aug 7, 2012 2:53 PM Helpful

Hi. Like everyone here, I've been having issues with iTunes match since upgrading to Mountain Lion on my Macbook Air (mid 2011). Worked fine on Lion.

 

Trying all the suggestions in the thread didnt resolve my issue, but what did for me was using a different wireless router. At first, I took my macbook into work, and it worked flawlessly there, despite consitantly being unable to match tracks on my home connection.

 

At home, I have a modem/wifi router connected downstairs by the phone line (that im forced to use by my isp), and I have a dedicated wifi router on the first floor that I tend to use as it has better range. Both routers are connected via ethernet. Turns out connecting to the router thats connected to the phoneline is fine, but connecting to my normal router, I have the issues with it stopping the match process and losing connection to itunes match. It was fine on my normal router before Mountain Lion however.

 

Anyway, this does tie in with some other routing issues I've been having (this time with my windows laptop connecting to work via vpn). I have dropouts on my normal router when I connect to vpn, with a similar frequency to the issues I have with itunes match. After some research, it turns out it was because I was going through two NAT routers, which was fine for day to day internet browsing but not for VPN.

 

So at the moment, im unsure if the issue is caused by my double nat setup, or just a general incompatibility with my normal router. I would like to try connecting to my normal router by ethernet to rule out one or the other, but I dont have the adaptor for my macbook air and have no real need to buy one.

Reply by eddypimenta on Aug 10, 2012 8:10 PM Helpful

I had the very same issue here. After reading some posts and hints, I took my Macbook Air late 2011 to my office and it worked fine under the local wi-fi network. Back home, I got the same issue again. Then I decided to upgrade the firmware of my D-link DIR-635. I had to check directly into the manufacturer website, as, inside the "check for firmware updates" tool there were no updates available. But, in the site, I found a newer firmware (2008 to 2010).

 

After doing that, I restored my dir-635 for the previus parameters and the problem has gone.

 

I hope my experience be useful for you all.

All replies

Previous 1 2 3 Next