Previous 1 7 8 9 10 11 12 Next 176 Replies Latest reply: Feb 23, 2014 6:28 PM by jpenguin911 Go to original post
  • pandine Level 1 Level 1

    Same issue here. iTunes 11 on Moutain Lion is connecting and disconnecting from iCloud again and again. 

     

    Solution:

    I increased the UDP idle time in my LANCOM router from 20 seconds to 60 seconds. No problem after that change.

    I think that this was the change that comes with the new firmware for some routers. And ... may be that is the reason why another DNS-Server may solve that problem, too.

  • Bjoe Level 1 Level 1

    I was able to solve the problem by speeding up my internet connection.

    The upstream of my cable connection was very slow (0.5MBit). But that was not the problem because Windows 7 using the very same connection worked out fine using iTunes match. Then I booked an upgrad ta my cable provider for 2,5MBit upstream. They've send me a new cbale modem with integrated router, because the old one doesn't support the higher speeds. After installing I've added 20 new songs to iTunes. Two of them couldn't be matched and needed to be uploaded. It works faster than before but what matters most the procedure went through till the end.

     

    I still believe Mountain Lion is the issue here, because Snow Leopard and Windows worked well, regardeless of the used internet connection.

  • pandine Level 1 Level 1

    May be we are talking about two different issues. Increasing the IDLE time for UDP solved my problem without any change to Mountain Lion. And others here have also reported that the problem was gone after updating their router firmware. I think apple may have changed something in the underlaying protocol stack or they changed the implementation of iCloud which is now deeper integrated in the system.

  • pandine Level 1 Level 1

    You said new router, right. New router - new IDLE time. The problem was not your internet connection speed. The older router or the older router's configuration was the problem. But more speed is always helpful. :-)

  • Bjoe Level 1 Level 1

    I also said old router, slow speed Windows and Snow Leopard worked fine. Mountain Lion ain't. Now we can throw dices what really happend. Either new router with better settings compensated the ML problem or it's all about a bad router setting Windows and SL can compensate.

  • thebranka Level 1 Level 1

    Same issue here, but I resolved it using a windows VM. ML is definitely the one to blame... Match runs like a charm inside a Windows XP VM (ML as guest OS) using same network, router and everything. No need to increase upload bandwidth, upgrade router firmware or doing some exotic dance around a rhianna picture on the floor. On ML Match loops and there's nothing you can do about it for now.

     

    First the spotlight indexing issue on lion (fixed with the supplemetal update) AND mountain lion, then this one... Apple reliability is starting to fall apart and it takes MONTHS to have a bug resolved. And please, remove the stupid 25k songs limit.

  • geekminer1 Level 1 Level 1

    I've been working with apple since July to try and fix this. I too have D link 655 router. I was asked by apple support to try a different network - so I did and it worked like a charm. I come home, connect to network and have same issue. Was offered a refund but declined  - I bypassed my router and came right out of cable modem - again a success. Problem is i tried upgrading my firmware in router and it tells me its latest version? Any suggestions.

  • geekminer1 Level 1 Level 1

    Got it. I tried again this AM to upgrade firmware. Success. Looks like itunes match now works like it should.

  • njdoyle Level 1 Level 1

    For what it's worth I have been having this problem for months. My (brand new) Mac Mini is plugged in to a Linksys WRT350N router running DD-WRT and that is plugged in to a SMCD3GN modem (on Rogers with no clear way to upgrade firmware). The problem persisted with the Mac plugged in to the router and with the Mac plugged in directly to the modem. I have tried both of these combinations with the modem in gateway mode and the modem in bridge mode. I could never get anything to work.

     

    Today I tried something new. On my router, I turned on QOS and set a cap on my uplink WAN bandwidth. I set the cap to 1024 kilobits/second. This is about one third of my typical uplink bandwidth with Apple. After doing this, iTunes Match has started working again and is uploading songs without failure. (albeit slowly)

     

    I can't explain why forcing my network slower made a difference but maybe it might help someone else.

  • robert pfile Level 2 Level 2

    that is very interesting. it's actually the same phenomenon you see when running bittorrent or while uploading pictures and stuff - the uplink becomes saturated with the upload traffic and so there's not enough bandwidth available for the packet acknowledgements going out for your download traffic. this makes your downloads run slow even though there's plenty of download bandwidth. when the acks are lost then the computer on the other end thinks it has to re-transmit even when you received the packets just fine.

     

    i'm going to try setting some rate limits in my router and see what happens. despite what i said above about itunes11 working right, it has gone back to not working...

  • robert pfile Level 2 Level 2

    wow - so far that is in fact working. 28 songs out of 147 successfully uploaded, no loops. i wonder if it just happened to work okay on my macbook because my wifi connection was weak and it was unable to jam up the uplink. thanks for figuring that out!

  • Mr. Luigi Level 1 Level 1

    I beg for forgiveness if this has already been posted.  The forum is so long and I have such a screaming headache from trying to solve this problem I can't bear to read anything from a computer screen.

     

    I bought my daughter a Skeeter Davis CD.  Rare item.  Cost a bundle, but all the songs were in a "normal" digital format.  Nothing unique about the CD in that regard.  Tried to burn it to her iTunes music collection on her MBP.  That worked fine.  But, then all Heck broke loose when iTunes Match tried to upload the 22 songs to the Cloud.  (Actually a couple of the songs Matched!  But, the vast majority needed to be uploaded.)  The fact that the songs needed to be uploaded was no surprise.  As I said, these are pretty rare songs.  The fact that 2/3 of them would NOT upload did surprise me.   I know this is going to shock all of you, but I have not had this uploading problem before.  From this discussion forum, now I realize it is rampant.

     

    So, I waited for about 4 hours to see if those songs would upload.  No dice.  I shut down iTunes.  Shut down her computer.  Retstarted iTunes.  ETC.  ETC. ETC.  Then I had to quit and go to work...in my case that is school, I am a teacher.  I brought my daughter's computer to school on a lark thinking that perhaps if I tried connecting to iTunes via the school's enterprise network something magical might happen.

     

    Well, something magical did happen.  The entire Skeeter Davis album uploaded in about 2 minutes!  Done.  Finished.  Complete.  No problems.

     

    I have VERY GOOD broadband service at home and am using a 4th gen. Time Capsule.  I don't know why my network at home, which otherwise behaves flawlessly, would not play nicely with Skeeter Davis and iTunes.  But, those are the facts.

     

    If you have access to another network, I would suggest trying your download on it.  I don't know if using an enterprise network was significant or not.  I just know that this worked.

     

    Sorry for being so wordy, but I thought that somewhere in all this information may be something significant or helpful to someone.

     

    Good luck.  God speed.

     

    Mr. Luigi

  • TD1001 Level 1 Level 1

    I was having the problem where iTunes Match won't upload certain songs. I read the solution on here to limit upload bandwidth in the router, but I have a Time Capsule and Apple doesn't allow such control, that I'm aware of. I found a software solution on the Mac to accomplish the same thing - I downloaded a copy of the Entonnoir app and it did the trick. I set it to limit upload for the HTTPS port to 100Kbytes. Every problem file then uploaded successfully.

  • truckstop Level 1 Level 1

    I have high-speed internet with Time Warner Cable in Brooklyn, NY.  Motorola Modem, Asus router - really fast connection.  SLOWING the UPLOAD down to a max of 3MB / sec. on the Asus router fixed this issue for me.  Very weird, but it worked.  FWIW.

  • jurneeka Level 1 Level 1

    I have been having this same problem since approximately November. I've searched and tried all the suggestions I've found on the discussions and NOTHING WORKS.  I am a group fitness instructor and I would like to have my music at my fingertips, which is why I subscribed.  It worked great for a year and now...ugh.

     

    That said, in reading some of these responses it appears that Mountain Lion could be the culprit and as it turns out I upgraded to Mtn Lion right before I started having issues with Match.  ugh.