Previous 1 8 9 10 11 12 Next 176 Replies Latest reply: Feb 23, 2014 6:28 PM by jpenguin911 Go to original post
  • Mr. Luigi Level 1 (10 points)

    Just thought I'd report back with an update:

     

    !)  Still having no problems with my new Mac Mini (referenced two comments above.)

     

    2)  Still having problems with my 3 MBP's which range in age from about 2 to 3.75 years old.

     

    All running OS X 10.8.3.

     

    Mr. Luigi

  • mrtymoose Level 1 (0 points)

    I've just (finally) had my issue resolved.

     

    It turns out the 2wire modem/router I was using is incompatible with Mountain Lion and iTunes Match.

     

    To resolve my issue, I disabled the router function and turned my 2wire into a modem only.  I then configured my Time Capsule for PPPoE and, whoo hoo, it works 100% reliably.

     

    I don't know what exactly is incompatible about the router, but when I made the changes suggested by Apple engineers, it started working and hasn't stopped.  Something in Mountain Lion has changed since Lion which has caused it to become more sensitive to something that the router was doing.  My Snow Leopard machines still work ok after the change.

     

    Credit to the Apple engineers for suggesting the change.  When I saw the MacBook Pro was working, I dismissed it being a network issue.  Good on 'em for being (politely) insistant about the changes.

  • Mr. Luigi Level 1 (10 points)

    Hi mrtymoose!

     

    So, if I understand you correctly, you were not using your Time Capsule's wireless router functionality originally?  Yes?  I am curious, why was that?  Was your other wireless router, the one that turned out to be incompatible, much "better"?

     

    Also, to complete this fix, you changed your the internet connectivity setting on your Time Capsule from, I assume, DHCP to PPPoE.  The upside of this is that it allowed iTunes Match to work!  Is there any down side (security wise, etc.) to using this setting?  I notice that the default setting is DHCP and wonder why.

     

    Sorry for all the questions.  Networking is not one of my areas of expertise.

     

    Thanks in advance.  Mr. Luigi

  • mrtymoose Level 1 (0 points)

    Mr. Luigi,

    Networking is not my strong suit either - hence the changes that I made under advice from Apple.

     

    When I first got my Time Capsule, it seemed to me that my modem/router was working okay and so I didn't want to change anything (as well as not realising I could disable the router function), so I just connected my TC to the modem in Bridged mode.  The modem/router was the DHCP server, it also provided firewall services (I think there may be where the problem laid).  The TC has always been configured as my wireless access point (dual band + wireless N versus "g" with the 2wire modem).

     

    I don't know if there are any downsides to my changes - I don't know if the TC has any built in firewall protection.  It does allow me to do port-forwarding and NAT, so presumably it does.  I have enabled the firewall services on all of my network devices however.  I did have other issues such as IP address allocation issues from time to time (conflicting addresses) and network latency when accessing TC storage.  Hopefully these have now been fixed too.  Certainly accessing the TC storage appears to be much quicker.  I'm hopeful.

     

    ...and of course, not forgetting, iTunes Match now works reliably!

  • Mr. Luigi Level 1 (10 points)

    Has anyone noticed if this week's update (10.8.4?) to Mt. Lion had any positive effect on the problem at hand?  I haven't tried. No new music.

  • kanhetwel Level 1 (0 points)

    Stil the same here in The Netherlands. While uploading i-Tunes is going into a loop.

  • antonio.vacas.rama Level 1 (0 points)

    Same problem in my iMac (Late 2009) with Mountain Lion. Afer two days in a loop, I've found this thread and tried to limit my upload bandwith to a third of my normal bandwith (using entonnoir app). Now, iTunes is uploading, very slow but uploading.

    I cannot believe an error like this in OS X, hope Apple will fix it soon.

  • cksum Level 1 (10 points)

    Wow, I've had this show up for a couple of days, which is what led me to read through all the pages. So much misinformation.

     

    First off, it has nothing to do with DNS. If you have a working internet connection, iTunes Match will work.

     

    It also has nothing to do with your router/modem firmware or how it handles network traffic. Some people even went so far as to say their routers were not compatible with iTunes Match. Seriously. No.

     

    It has nothing to do with your set up. I enabled iTunes Match on my second Mac that had never been set up to use it, and experienced a connection failure from the get go. So, it's not machine dependent.

     

    It also has nothing to do with your AirPort (Extreme or Express) firmware. I downgraded my 2ng Gen Express and it still didn't work.

     

    Some one posted that he had an iTunes Senior Team member read through this thread and they concluded that anything that worked was purely coincidence. They were right. Nothing in this thread will lead you to fix the problem, not directly.

     

    So why am I posting? Because I fixed it. How? Not sure, but it likely has something to do with credentials and how the iTunes servers respond to them. That's why the connection will go live if you go into your iTunes Account Purchased screen (in iTunes) and either download an app (or other purchase). You can also hide an app and it will reconnect.

     

    What did I do? Toggled my internet connection and then signed out of everything. Deauthorized my machine. Then I signed by in and reauthorized it. It didn't connect, but I went back into my account and just hide on of my purchases. Reconnected. It didn't stay for long, but after it got knocked off again, I again, went into my account and did the same thing. This time it stayed up. Has been good for a day now. Before it wouldn't stay connected for more than 3 mins at a time, and go dead for hours.

     

    This leads me to believe it's something to do with either the keychain or some server-side anomaly where iTunes will choke and drop the connection.

     

    So I'm urging anyone that has this problem to dig into their account settings and re-establish the connection through either downloading or hiding a recent purchase. I had to do it only a few times, and it's been good.

     

    In my case, the service has worked perfectly for over a year and these connection problems only showed up a day or two ago.

  • robert pfile Level 2 (155 points)

    you are experiencing a different problem, and/or it's coincidental as so many other things have been.

     

    limiting the upstream bandwidth definitely works. without the bandwidth limit, the failure occurs mid-upload, so credentials are good - the transfer starts and then at some point it just stops. using tcpdump i can just see the packets stop after some point.

  • mrtymoose Level 1 (0 points)

    For me, it was definitly a Mountain Lion problem.  I had Mac Mini running Snow Leopard and an iMac running Mountain Lion.  Only the iMac (running ML) would fail.

     

    Once I disabled the Router function in my modem and configured my Time Capsule to establish the PPPoE connection to my ISP, did the iMac start working reliably.

     

    To suggest that to do someting  "only a few times" is a proper course of repair is wrong.  It either works every time, or there's something else that's causing your problem.  For me, that cause was my modem's router function.

     

    If yours is working now, reliably, then that is a good thing - regardless of what you did, or think you did, to fix the problem.

     

    Cheers.

  • ishigami Level 1 (0 points)

    So it is 2014 now and still this fixed my problem too. Thank you so much!

  • jpenguin911 Level 1 (0 points)

    Just posting to say that ever since I upgraded to Maverics, iTunes Match has worked flawlessly. I know this thread was focussed on Mountain Lion, but upgrading fixed the connection problems for me. Hope this helps if anyone is still struggling with it

Previous 1 8 9 10 11 12 Next