Previous 1 4 5 6 7 8 Next 176 Replies Latest reply: Feb 23, 2014 6:28 PM by jpenguin911 Go to original post
  • Michael Allbritton Level 6 (16,785 points)

    Jon from Texas wrote:

     

    Remember, I'm just the messenger and my only desire was that my experience might be helpful to others.  Have a good day,

    I think it is helpful to know that you did get it fixed. But until we get concrete steps to fix the problem we can't really call anything a "fix."

  • Ducky01 Level 1 (0 points)

    I had this same exact issue ever since upgrading to Mountan Lion. iTunes Match had been stopping during the matching process and all of my matched songs from my other computer were greyed out and inaccessible.

     

    By using a lead from this (or another) thread, I changed my network DNS settings. I changed my DNS to Google DNS (8.8.8.8 and 8.8.4.4) and the match process started working and finally uploaded my remaining songs. After quitting iTunes and starting it again, my greyed out items were able to be downloaded. Perhaps the DNS I was using from my ISP was not resolving some addresses correctly?

     

    It's worth a try.

  • kevintmclean Level 1 (0 points)

    same here!! FRUSTRATING!!

  • Scottyb0721 Level 1 (0 points)

    FINALLY IT'S WORKING!!!!!!  Thanks Ducky01 I tried what you said and changed my DNS setting to Googles public ones and iTunes Match seems to be working. It is still in the process of uploading my new music, but seems to be working ok.  It has restarted a couple times during the process, but so far has uploaded probably 50 of my 75 songs added since the Mountain Lion upgrade and it hasn't errored out during the first step at all.

     

    Here is good info on how to change your DNS settings.

     

    https://developers.google.com/speed/public-dns/docs/using

     

    Hopefully this fixes others problems as well as it is a very frustrating issue.  Personally I have moved over to Google Play Music for my streaming as I think it is better, but my wife still likes to use iTunes Match.

  • Bjoe Level 1 (15 points)

    Here match is stable. Using cable connection (slow pings, but Googles DNS) it works processing found songs. Uploading songs only work via 3G connection (iPhone tethered).

  • Xander75 Level 1 (0 points)

    Still can't get it to work here. It's been like this for more than a week now.

  • Bjoe Level 1 (15 points)

    Ever tried a different internet connection?

  • Xander75 Level 1 (0 points)

    I've tried ethernet and wi-fi connections and it keeps looping Step 1

  • Bjoe Level 1 (15 points)

    Did you also tried different internet provider? If the problem is provider related ike in my case) wifi or ethernet wouldn't make any difference.

  • Xander75 Level 1 (0 points)

    If you mean changing the DNS settings then yes, I've tried that. I can try to reset the router, maybe that'll help

  • Bjoe Level 1 (15 points)

    No I don't mean changing DNS. 

     

    I mean a totally different provider. I did this by tethering my Mac to my iPhones mobile provider. Only with that connection my iTunes match is able to upload non identified songs.

  • Xander75 Level 1 (0 points)

    I've tried it and this works! I hope this bug get fixed soon, this solution works but waaaaay slower than my high speed connection

  • Bjoe Level 1 (15 points)

    Great. Anyone who could do this test as well?

  • Xander75 Level 1 (0 points)

    Somehow it all works fine again now through my normal ethernet connection. Maybe this trick clears some kind of bug?

  • Bjoe Level 1 (15 points)

    I don't want to dissapoint you. Without repetitive tests you can't be sure at all.

Previous 1 4 5 6 7 8 Next