Previous 1 5 6 7 8 9 Next 176 Replies Latest reply: Feb 23, 2014 6:28 PM by jpenguin911 Go to original post
  • Geo__ Level 1 Level 1

    I tried using my Verizon 4G Jetpack with my iMac instead of my wired connection through my local ISP. It did not work.

  • ncouture Level 1 Level 1

    Semi-Solved my problem!

     

    I have been puzzled by this problem for the past week and could not find any answer. Tried all the sign out deactivate delete songs etc without any success. The network "fixes" posted in this thread gave me the idea to activate the VPN on my computer. As soon as I did, the uploads started again...

     

    Definitly something network related from my perspective.

  • ryanpjcarey Level 1 Level 1

    VPN workaround works for me as well. Thanks ncouture. I still need to know why this is happening. Nothing changed with my network setup recently, it just stopped working one day. Hopefully Apple addresses it soon.

  • ncouture Level 1 Level 1

    I totally agree with you on finding out why. I have been trying without success yet. I tried DNS changes without success. It now works either through vpn or directly from my office but never directly at home.

     

    It used to work perfectly from home and I can't exactly pinpoint when it stopped working but it happens to be in the same week I upgraded to mountain lion. It then seems like the combo iTunes, Mountain Lion and my home isp (Cogeco in Canada) create the issue.

     

    To add to the fun, my iphone never updates it's itunes match anymore. Tried adding iTunes Match and removing it, erasing all music, reboot, kill application, etc. It just will not do anything regrarless of the network I am on. A little cloud appears for a couple of seconds as I go in music. A grey background stating that there is no music on my iPhone then follows.

  • robert pfile Level 2 Level 2

    i believe, unfortunately, that this is probably ISP-related for some people.

     

    let me preface all of this by saying that iTunes is the most "locked-down" program i've ever seen from apple. they strip all of the symbols out of the binary to make it very difficult for you to trace through the program with a debugger. and they even try to defeat the mechanism by which a debugger connects to iTunes.

     

    if some of you remember back in the day, apple released a "personal sharing" feature in maybe iTunes 4 or something like that. originally it worked over the open internet, but they quickly patched itunes to only allow it to work on a local subnet. based on some debugging experiences around that time, i can say that i think apple has re-implemented parts of the standard TCP/IP networking stack in itunes itself. this is again an attempt to foil people trying to reverse engineer the FairPlay encryption, or to otherwise use itunes in a manner in which apple/record labels disapprove of.

     

    i'm in the same situation as all of you - after upgrading two of my machines to mountain lion, i find that itunes match dies while trying to upload music and then starts all over again at step 1.

     

    using tcpdump, i just found out that 1) apple is using https to communicate between itunes and the servers, so there's really no hope of seeing the control traffic between the servers and iTunes and 2) while the match/library analysis is talking to apple's servers, the actual song data is being stored in amazon's cloud. the part that's dying is the upload into amazon's servers.

     

    i happen to have built my own home router, so i have a lot of control over it. i also happen to have more than one uplink, through two different ISPs and two different technologies. if i use one ISP as my default route, i get the iTunes match loops. if i use the other ISP, it works fine. this is consistent with people saying that using their work VPN lets iTunes match succeed, or taking their macbook to work lets it succeed.

     

    if i had to venture a guess, i'd say that there's some bug in the way iTunes's custom networking code interacts with the networking code in mountain lion. perhaps a packet comes out of order, or set with some weird combination of TCP flags from the first ISP, and iTunes chokes on it. i'd have to try to do more analysis of the traffic at the moment the upload fails to see if i can see anything interesting. if i'm right, people who are experiencing this problem are SOL until apple figures out what they've broken against network traffic that works properly against the rest of the operating system.

     

    so at least we can hope for a fix in iTunes 11, at the very least. maybe they've cleaned up some of their spaghetti code.

  • timfromwakefield Level 1 Level 1

    De authorising the computer worked. I am using Windows 7

     

    Thanks Whitewater

  • Bjoe Level 1 Level 1

    Serveral people tried this one before. Did not hold long or did not work out at all. Glad if it is working for you.

    I help myself out by tethering my iMac to my iPhone. 3G Network seems to be better for doing the iTunes Match process. None of the recent updates both of OSX and iTunes could change that.

  • Xander75 Level 1 Level 1

    Well I haven't had a problem with match for weeks... untill I turned off iTunes Match by accident and now it's stuck on step 1 again

  • aboutface Level 1 Level 1

    Spoke with Apple Care who fixed my intermittent iTunes Match connection issues after having upgraded to Mountain Lion:

    This is what he asked me to do:

    1. Go to your Macintosh HD drive in Finder (system drive)

    2. Go to Library

    3. Drag the 'SystemConfiguration' Folder onto the Desktop (creates a BU copy - just in case)

    4. Delete the 'System Configuration' Folder within the 'Library Folder' (empty the Trash Bin - just in case)

    5. Reboot - This recreates the network files (automatically)

    6. That's it!

    Works now like a charm

    P.S.: Just in case if you have done custom network configurations, write them down first.

    PPS: I did the above and it works, but please don't hold me liable for anything you do on your own machine : )

  • Bjoe Level 1 Level 1

    SystemConfiguration is in Library/Preferences

  • Bjoe Level 1 Level 1

    I've tested the solution provied by "aboutface"

    no effect at all

    Stiil need to tether my Mac with my iPhone in order to prevent iTunes match from intermittent stalls

  • David Trotsky Level 1 Level 1

    ok. Mine would get to random points and stop then keep restarting. I have an imac desktop and a dlink router. Apple support was useless. My OS and iTunes are all up to date. I am not wired - using wifi.

     

    After exhausting everything else I looked at something network related. I logged onto an open wi-fi in my neighborhood and it worked. So I knew I was close. Because of the distance the connection was very slow.

     

    I tried everything I could think of resetting the firewall in the router but couldn't get it to work. In short of buying a long Ethernet cable and bypassing the router entirely, I checked if the router's firmware was up to date. It's internal check says it was. I went to dlink's site to find there was an update after my version. I manually downloaded it and upgraded the router's firmware.

     

    So far everything now works fine.

     

    My suggestion is to check firewall and router settings. Update your router's firmware if possible.

     

    Hope this helps, I have about 4 hours invested in this.

     

    Dave

  • Bjoe Level 1 Level 1

    I have an Airport Extreme latest firmware. No effect reseting it. Just trying Google Music upload. Works like a charm. Just uploaded 1500 songs in one night without any trouble at all. iTunes Match is a major fail in terms of network. I'm waiting to the last minute before I renew my iTunes Match subscription.

  • robert pfile Level 2 Level 2

    it seems to me that iTunes 11 has fixed this problem. as a pre-upgrade sanity check, i tried to put a song in iCloud from my macbook air running 10.8.2, just to make sure i still had the problem. sure enough, it looped and looped and looped.

     

    now i've upgraded to iTunes 11, and i tried to add the same song to iCloud. it worked. and then i added another one just to be sure. that worked too.

     

    my home network configuration remains completely unchanged.

     

    happy for now, let's hope it holds!

  • Steven Massey Level 1 Level 1

    iTunes 11 had no effect for me.  I get the same behavior.  Files fail to upload on step 3 and the match process goes into a loop.

Previous 1 5 6 7 8 9 Next