Previous 1 8 9 10 11 12 Next 167 Replies Latest reply: Mar 7, 2014 2:13 PM by Golf25Radioman Go to original post
  • ulrichfromDE Level 1 Level 1

    Hello jfletcher,

    this is just obvious: what you describe can only work if you have the two networks connected by a bridge (just google for wlan bridge)


  • Michael Brill Level 1 Level 1

    Thank you. VirusBarrier had added my IP Address into the antivandal area due to port scanning. Wish I knew how to give points here!

  • Michael Brill Level 1 Level 1

    Thank you. VirusBarrier had added my IP Address into the antivandal area due to port scanning. Wish I knew how to give points here!

  • jfletcher72 Level 1 Level 1

    I am on the same subnet. No bridge needed. The router is my ISP's router that has wireless built in. I can ping the other hosts and I can connect to the other devices shared drives. I am just unable to do screen sharing over wireless.

  • ulrichfromDE Level 1 Level 1

    Hello JFletcher,

    - Okay!

    - So let's repeat: you can ping the system in question, but you cannot do screen sharing to it ALTHOUGH you have made a shortcut at Finder > goto > vnc://ip.ip.ip.ip ?

  • jfletcher72 Level 1 Level 1

    that doesn't work either.....

  • Tucker28 Level 1 Level 1

    Thank you for taking the time to comment in this thread. VirusScan did the same thing with me, listed port scan as the reason it was blocked.

  • DPSG-Scout Level 4 Level 4

    Hey everyone,


    spinner2012 suggested to enable access over the VNC protocoll and connect by pointing your client mac to vnc://IPADRESS. Apparently, the url scheme vnc://... just tells Shreen Sharing to connect to the remote Server using any protocoll. On my Mac, Screen Sharing will ask for a user name and password and connect via the Apple Remote Desktop protocoll, not the VNC protocoll, even though the url specifies vnc://.


    Some have suggested that the using this vnc:// url scheme solved all problems. This might certainly be true for problems related to the network.

    However, I checked the bookmark I'm using for a while now to find out I was already using this vnc:// url scheme for many years. There must be another bug somewhere. For me, Screen Sharing works fine for many days in a row and then, all of a sudden, I am not able to connect anymore. I have to ssh into the Server and force a reboot.


    I have now also enabled access via the VNC protocoll by clicking the appropriate check box under System Preferences and setting a VNC password. If this works, it would mean that you have to enable VNC access so that Apple Remote Desktop works reliably. This would be beyond any logic, since those are two different protocolls.

    Anyway, once you enable VNC you can also use dedicated VNC clients like Chicken of the VNC to connect, in case Screen Sharing doesn't work.


    Wait and see…


    For what it's worth, I am taking a complete guess that the issues with screen sharing might also be related to problems with the grafic card driver. I am connecting to a mid-2007 iMac 24", ATI card 2600, OS X 10.8.2.


    Recently, I have had issues similar to those described here.

    Re: 24" iMac Screen Freezes since 10.6.3 update - pls help!


    FYI: Replacing the mentioned kernel extension caused more system freezes so I revertet that pretty quickly.

  • ulrichfromDE Level 1 Level 1


    To isolate the problem, you could use another vnc server app on the machine in question. If the prob persists, we have isolated it to the server system itself; if not, we have isolated it to be the vnc server app....

    just an idea...

  • stumbleone Level 2 Level 2

    For what it worth, I have the clasical screen sharing problem too.  Setup:  10.8.2 iMac trying to connect to an ancient Macbook Pro 3.1 over a home LAN.


    The MBP is dual boot with two disk partitions, one 10.6.8 and one 10.8.2.  The iMac connects screen sharing to the 10.6.8 partition instantly.


    The iMac will not connect SS to the MBP's 10.8.2 partition until firewall is turned off on both machines.  Then it connects, and the 10.8.2 partition will connect SS to the iMac.


    Don't pretend to guess at what's going on.

  • andrewdwright Level 1 Level 1

    i've exacty the same problem. did you mange to fix it? i'd appreciate some ideas.  thx. Andrew

  • Golf25Radioman Level 1 Level 1

    My Screen Sharing was working well then yesterday I couldn't connect.  I tried my security software (NetBarrier) for a possible block (has happened before) but there was nothing there.  My last attempt at fixing I unchecked "Screen Share" in Sharing and then rechecked it.  And all was well.  Don't ask me why this came up but it's worth a try if you've tried everything else. 



  • mugwump88 Level 1 Level 1

    I just wanted to add somewhere that Messages screen sharing was not working until I figured out the answer.  The screen would connect for a second until it would freeze and a connection error message would appear, that there was no information for 10 seconds causing the connectin to time out.


    Well, it turns out it was a bluetooth audio issue.  I removed my bluetooth headphones from the list of bluetooth items, and after it was removed then screen sharing worked without a problem.  Now I remove the headphones from the list before every screen sharing session, and it works well.


    So, hope that helps someone, somewhere.

  • Lazlo666 Level 1 Level 1

    I've posted this before to this somewhere in this mess of posts...


    I think I've tried everyone's fix at one time or another...anything from simply turning sharing on/off to switching between VNC and Apple Remote Desktop to reformatting and reloading Mt Lion on both machines...


    worked once for almost every trial I did, twice for some and for several months for others.


    Now, I'm back to IT DOES NOT WORK! NO NEW APPS on either Mac, sharing simply won't!


    tried every iteration mentioned in these posts but none seem to work consistently or permanently.


    I've been a Mac owner/user/prosletizer since 1984 and this is the most annoyingly long unanswered issue I've seen.



  • theali3n Level 1 Level 1

    Started having the same issues over the weekend. Knowing it couldn't be anything installed or configured wrong, I looked for other things I changed and the 1 thing was I moved my macbook pro and the headless mac mini to my 5GHZ network ( using stock Asus router ) and this is when I believe the issues started.


    What was interesting is that I have teamviewer on the mini so I can get to it from outside and each time that Screensharing wouldn't connect I'd login using teamviewer ( which worked every time ) and then either Screensharing would "start to work" or I'd enable disable form the system settings and everything would start to work. I thought it could be a sleep related issue or a "network going to sleep" but I have the mini turned on all the time with no sleep.


    After doing some searches it looks like there is a thread with a similar issue:


    They talk about only the "server" having to be on 2.4 for Screensharing to be stable, but I moved my Macbook and the mini back to 2.4 and the screensharing issues stopped.


    Definately a bug on Apples side.