1 4 5 6 7 8 Previous Next 167 Replies Latest reply: Mar 7, 2014 2:13 PM by Golf25Radioman Go to original post
  • 75. Re: Screen sharing not working in mountain lion
    Merbil Gonzalez Level 1 Level 1 (10 points)

    Here's what's worked for me:

         Although enabling 'Remote Management' theoretically obviates the need for enabling 'Screen Sharing' within the Sharing Preference Panel. I found that enabling 'Screen Sharing' prior to 'Remote Management' seemed to fix ScreeSharingMenulet functionality. 'Screen Sharing' will lose it's checkmark once you activate 'Remote Management' but, at least for me, the sharing enabled Macs now show in the ScreenSharingMenulet.

     

    RicardoG

  • 76. Re: Screen sharing not working in mountain lion
    15922 Level 1 Level 1 (80 points)

    i think that that's the way it is, because remote management controls everything, so you don't need to check the screen sharing box anymore. although the remote management is a server that controls a lot of computers, so if you have a personal computer and only need to control one or two computers, remote management is unnessesary.

  • 77. Re: Screen sharing not working in mountain lion
    chinhster Level 1 Level 1 (0 points)

    I spoke too soon.  I tried to connect through screen sharing again and couldn't.  I think I'm just going to upgrade the remote Mac to Mountain Lion.

  • 78. Re: Screen sharing not working in mountain lion
    Golf25Radioman Level 1 Level 1 (5 points)

    chinhster wrote:

     

    I spoke too soon.  I tried to connect through screen sharing again and couldn't.  I think I'm just going to upgrade the remote Mac to Mountain Lion.

    There goes the rub, chinhster.  If your other computer is "too old" to upgrade to Mountain Lion (and we won't get into that mess - to old my ***), you're "stuck" with having your home (well my home) network with a computer in the system with "only" Lion.  And I'm very hesitant to "hack" (as I've found instructions to do) an install on this OLDER Mac Pro (1,1) - not sure what kind of can of worms that would bring about.  I've read many success stories, but what about when OS updates (like the one today) come out - will the "hacked" Mountain Lion on an "unsupported" MacPro work?

     

    Tom

  • 79. Re: Screen sharing not working in mountain lion
    Perry Gershon Level 1 Level 1 (55 points)

    Sorry to say that neither 10.8.1 nor the new Apple Remote Desktop Admin 3.6.1  did anything to correct this problem.

  • 80. Re: Screen sharing not working in mountain lion
    hamdicarlo Level 1 Level 1 (0 points)

    Hi,

     

    as i don't need to mention that i did suffer from this problem as well!

     

    Funny enough is that i have MBP and Mac Mini both running ML, MBP stopped screen sharing my mac mini recently (only screen shares few times after fresh rebooting Mac Mini) but my mac mini has no problems screen sharing my MBP!!!

     

    I cross checked both Macs configuration to see if i am missing anything! and nothing strange at all.

     

    However, i do have ARD installed on both machines, and i have updated both system to the latest versions 3.6.1 to make sure all is well.

     

    Did a fresh reboot on mac mini, nad screen share worked well on both Finder and ARD, (only for a few times before hitting road block!), i started to check every functionality in ARD on my MBP, one step at a time and i noticed the option 'Upgrade Client Software' under the Manage tab in the menu! (bear in mind that i performed manual update on my mac mini earlier and confirmed that it was a success. i hit upgrade client software, i chose my mac mini from the list, I wait until process is done (blue loading bar running) and then i get the message it was a success......... wait! wait!!!! then i hit control on ARD menu to control mac mini..... and MIRACLE!! it worked.

     

    Note that prior to me doing 'Upgrade Client Software', i was trying to control my mac mini through ARD but not luck!!

     

    Try this if you have ARD installed and i hope it will work for you too.

  • 81. Re: Screen sharing not working in mountain lion
    FlutePixzy Level 1 Level 1 (0 points)

    WOW! 6599 views. You'd think Apple would have told us this was going to happen. Without reading all 80 replies... I had this problem as well. I upgraded my MBP to Mtn Lion and lost screen sharing with my iMac. Decided I wouldn't upgrade the iMac until I could figure out what happened.

     

    I did read that someone suggested signing out of Mobile Me. Obviously that won't work if MM isn't available anymore. So, I signed in to iCloud on my iMac, unchecked everything and signed out. Did the same on my MBP and my iPhone for good measure since I have absolutely no intention of storing diddly-squat on some stupid "cloud" when I have a perfectly good wireless network at home with two TCs (I work out of my home and don't need access to anything when I'm out).

     

    Anyway, that did the trick. Screen sharing was immediately available. Now I'm off to figure out why my MBP and iPhone calendars won't sync.

  • 82. Re: Screen sharing not working in mountain lion
    Stephen Toback Level 1 Level 1 (0 points)

    son of a gun if that didn't work. I thought it was a networking issue because I was able to get Screen Sharing o work when connected to a wired network. Didn't have that option at home. I read this and thought that there is no way that could have worked, but it did. So thank you.

  • 83. Re: Screen sharing not working in mountain lion
    Deuce man Level 1 Level 1 (0 points)

    FlutePixzy wrote:

     

    So, I signed in to iCloud on my iMac, unchecked everything and signed out.

    Just signing out of iCloud on the remote (Lion) Mac, then signing back in worked for me.  Woohoo!

     

    A fretful part of signing out process is that it insists on deleting all iCloud Calendar entries from your Mac.  With Address Book, it gives you the option of keeping your entries but not iCal/Calendar.  Signing back into iCloud copies the Calendar entries back to your Mac and merges Addresses.

     

    I take that back.  I may have misremembered signing back into iCloud before testing it but since then I put it to sleep for the night and just woke it up to test it again.  No go.  Drats.

  • 84. Re: Screen sharing not working in mountain lion
    FlutePixzy Level 1 Level 1 (0 points)

    My issue with this cloud thing is twofold. One, I have no need or interest in it and I won't be forced to put my calendar, address book, documents or anything else into some cloud that a hacker could later cause to rain.

     

    Two, I never told my computer to sign in and store anything in a cloud. And I have recently verified this with AppleCare. Nonetheless, when I had to sign in to turn off this thing I never turned on it warned me that removing the information I had not stored on the cloud would remove it from my computer. WHAT??

     

    Working to resolve with AppleCare and when we have a solution I will post it here and to as many of the other related discussions regarding syncing as I have time for (there's a lot).

     

    I wish Apple would stop deciding what is and what is not universally essential. I suppose what Apple hath created Apple can certainly take away, replace or force you to eat.

  • 85. Re: Screen sharing not working in mountain lion
    N4KHQ Level 1 Level 1 (0 points)

    I don't think my problem had anything to do with iCloud, sigining in and out does not help. I had a mid year 2007 imac running Mountain lion at home. I could not screen share to the home iMac if it was sleeping. I could connect from the home iMac to the office, MBP or wife's iMac. I replaced the home iMac and office iMac with new iMacs. Home computer pops right up sleeping or awake after the replacement. My problem seemed to be solved for about a week and a half. I could connect any way I tried. About 30 minutes ago, I tried to connect from my home computer to the work computer and it would not connect. VNC would not connect either. The office iMac is on a public IP. The home network is
    Dynamic IP with NAT - DCHP ip numbers. I went to the office and forced quit screensharingAgent and screen sharing started working the second I quit. I am using Back to My Mac because my home network has a dynamic IP number but I can connect to my offic iMac with a VNC client which wakes the iMac. Once the computer is awake, I can connect using Back to My Mac.

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    D

  • 86. Re: Screen sharing not working in mountain lion
    FlutePixzy Level 1 Level 1 (0 points)

    Though it sound like you have plenty of experience, I wanted to address just a few points from your post and I'll do them in the order you mentioned them.

    1. It is impossible to screen share with my sleeping iMac. As I primarily use my laptop at home, I have set my iMac to automatically go to sleep after 1am and wake at 11am so that I can screen share during those hours if needed. The screen is dimmed as much as possible (why it can't blackout like the laptop I don't know), and the screen saver is set to start after 3 minutes of inactivity.
    2. My home network is simple. I have a Netgear DGN3300, modem router that provides DSL service from ATT. Attached to the Netgear is my home security system cameras, my DirecTV box, blu-ray, printer and my Time Capsule. The Netgear security is set with WPA2-PSK. I can, but I do not connect access my home network through the Netgear, that is done strictly through the Time Capsule.
    3. I have two Time Capsules. The first one I purchased to use with my laptop. When I purchased the iMac I needed a larger TC in order to have room for backups. The first TC is set using DHCP in Bridge mode with the same security as the Netgear (separate password) ,and it controls network access. The second TC is set to extend the network created by the first TC. Both are set to allow file sharing.
    4. I don't use Back to My Mac because it requires using iCloud. When I signed in and back out, it was to ensure that nothing was enabled.

    I'm glad we've both found a solution for our separate situations. However, I mention all these things regarding my system because while yours works for someone who doesn't mind putting their information out in cyberspace on a "cloud" where it can be subject to hacking (AppleCare admitted it is "possible but unlikely" - for now), there may be someone else like myself that prefers to keep everything under their own roof.

  • 87. Re: Screen sharing not working in mountain lion
    Perry Gershon Level 1 Level 1 (55 points)

    I believe 10.8.2 (not yet public) fixes this whole issue. I have tested for a few days now

  • 88. Re: Screen sharing not working in mountain lion
    Golf25Radioman Level 1 Level 1 (5 points)

    Perry Gershon wrote:

     

    I believe 10.8.2 (not yet public) fixes this whole issue. I have tested for a few days now

    I hope 10.8.2 addresses the Calendar Notifications debacle too.  I hate the set time for them, no adjusting - just every few minutes they cascade down the right side of the screen.  Almost like a nagging....well I'll stop myself there. 

     

    Tom

  • 89. Re: Screen sharing not working in mountain lion
    Steven W. Riggins Level 3 Level 3 (980 points)

    When repairing permissions under 10.7.4 I see:

     

    Warning: SUID file “System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAg ent” has been modified and will not be repaired.

     

    It says 58 minutes left to repair permissions (LOL, darn Mac Pro and your slow HDD) I will try re-installing the 10.7.4 Combo Updater and report back

     

    Edit: Looks like this warning is "normal" but I still find it quite odd given this issue

1 4 5 6 7 8 Previous Next