Previous 1 5 6 7 8 9 Next 167 Replies Latest reply: Mar 7, 2014 2:13 PM by Golf25Radioman Go to original post
  • Steven W. Riggins Level 3 Level 3 (980 points)

    Installing 10.7.4 Combo Updater fixed this issue.  I then repaired permissions again, and did not see the
    "Warning: SUID file “System/Library/CoreServices/RemoteManagement/ ent” has been modified and will not be repaired." message in the log.

  • Steven W. Riggins Level 3 Level 3 (980 points)

    Well crud, one logout and login later, it is back to not working. unable to auth net agent

  • scottl3 Level 1 Level 1 (0 points)

    Oh, please be true! Any idea how long until the 10.8.2 update will be released?



  • Biscuit1018 Level 1 Level 1 (0 points)

    I have just had the same issue except it was a Lion Mini (10.7.4)  that I couldn't Screen Share.

    I was connecting from a Mountain Lion iMac.

    It started happening after a minor software update on the Mini (JAVA, Safari etc. No OSX Software version change).


    I tried rebooting - No luck


    Thanks to this forum

    - Repair Disk Permissions - On its own no luck

    - Reboot - I did a shutdown and a powerup




    I don't think the issue is connected to Mountain Lion. Looks like a corruption creeping in somewhere.


    Thanks Forum

  • Biscuit1018 Level 1 Level 1 (0 points)

    It seems I spoke to soon.


    The problem resurfaces days later.

    I have found a cold boot fixes it... temporarily

  • Biscuit1018 Level 1 Level 1 (0 points)

    Am giving this a go to see if its a permanent fix.

    My Lion Mini doesn't need iCloud so if it works thats great.


    The logical quiestion to follow this fix is WHY does it work?

    I don't know how screen sharing could be connected to iCloud?

  • N4KHQ Level 1 Level 1 (0 points)

    If you have a fixed IP number, you don't need iCloud but if you have DSL and don't pay extra for a fixed IP and even if you do your are probable using NAT -  DHCP to serve up IP numbers for your home network, you probable need iCloud. Apple uses Bonjour on a WAN to get your IP number. Screen Sharing using your browser works fine. If you enter vnc://168.8.xx.x in Safari's address line where 168.8.xx.x is to IP number of the maching you want to connect to, you can screen share 100% of the time, assuming you have reboted or forced quit the ScreenSharingAgent.


    Hopefully the next OS update will fix the problem, it should be released anyday now.

  • James Wade Level 1 Level 1 (45 points)

    My problem was that Screen Sharing would connect to my headless Mini Server, but all I would ever get was a black screen, unable to log in.  What worked for me was to set the display sleep and system sleep to never.  Since I could not connect using screen sharing, and the mini was headless I logged in using ssh, then used from the command line:


    sudo pmset -a displaysleep 0

    sudo pmset -a sleep 0

    shutdown -r now


    Don't really know if I needed to reboot (via the shutdown -r now), but what the heck.


    Screen sharing has worked fine ever since, on multiple occasions.

  • Guido Paap Level 1 Level 1 (0 points)

    Hi Perry, thanks! This did the trick for me! It's definitely a bug.


    "If you go to Activity Monitor on the host computer, look for the process screen sharing agent.  I have found that it has remained open when clients cannot share the screen with the host.  Force quit that process and screen sharing now restored."

  • Perry Gershon Level 1 Level 1 (55 points)

    Best fix, by far, is to find a copy of 10.8.2 and install it.  I don't normally install beta system software, but in this case the bug was so irritating I was desperate.  Fix has worked on 5 machines for me for about two weeks of use

  • N4KHQ Level 1 Level 1 (0 points)

    Force quitting ScreenSharingAgent will work until you try to screen share with the display sleeping. You will have to force quit ScreenSharingAgent again or restart.

  • N4KHQ Level 1 Level 1 (0 points)

    10.8.2 fixed screen share for me. Here is a short recap:

    Home iMac DSL dynampic IP

    Office iMac public IP

    Home iMac would not screen share if display was sleeping.

    Office worked fine.

    I replaced both computers

    Home iMac start work fine

    Office started doing the same thing as home. This was not a big a problem for me. The office iMac has a public IP and I could screen share using the vnc:// in the url of Safari.

    Thanks Perry for finding ScreenSharingAgent and reporting the problem to Apple.

  • Lazlo666 Level 1 Level 1 (10 points)

    Wishful thinking i'm afraid....had problems with intermittent VNC/Remote connections since 10.7.4 (usually fixed by restarting client Mac, at least until 2nd connection attempt). Now, 10.8.2 and cannot connect at all, with or without restarting the client (as well as my own). Works fine locally to older Cube, just not to the target (non-local) Lion client.

  • sexymacman Level 1 Level 1 (0 points)

    make a function and put it in $HOME/.profile, do it in this manner, make sure you backup your existing profile


    cp -v $HOME/.profile $HOME/.profile-bkup


    fixvnc () { sudo /System/Library/CoreServices/RemoteManagement/ ickstart -restart -agent ; }


    declare -f fixvnc >> $HOME/.profile


    then source $HOME/.profile


    copy this to all your $HOME/.profile to all of your macs with the vnc issue.


    when the mac complains and says reconnecting, ssh in and type fixvnc it will restart the ARDagent and clear all info. then you can connect again successful with open vnc://ipaddress


    I have been fighting with since recently the upgrade to 10.8.2, I run a macmini, and 3 macbooks, the macmini is my media server so obviously ssh and screensharing are very important to me. I hope this helps.

  • Golf25Radioman Level 1 Level 1 (5 points)

    Had another loss of Screen Sharing the other day.  I went to my Mac Pro (my screen sharing computer) and unchecked all the sharing boxes, then rechecked them.  Went to my MBPro and started Screen Sharing, it asked for the address, but once I put it in everything was well again.  I do have Remote Desktop installed on the Mac Pro, but not active.  Wonder if I should remove it since Screen Sharing does all I need.



Previous 1 5 6 7 8 9 Next