10 Replies Latest reply: Mar 25, 2006 3:56 AM by Rollie
Chris Girard Level 1 Level 1 (100 points)
Awesome.Spent around 900 bucks today to upgrade my G4 mini to an intel solo core mini.
Not only did I struggle with target mode and have to do 2 re-installs and move apps manually , but I purchased a mighty mouse that I cannot use.
I inserted the disc, ( the first disc after the last re-install ) and cannot get it out. I have rebooted several times with the mouse button held down, I have used the eject key, I have held down command option f o ...nothing. I have tried to fake burna disc from iTunes, I get an error message telling me there isnt software to burn or a burner installed. The closest apple store is 75 miles away...Oh Yeah, I have now had my mini for 8 hrs and havent been able to do sh*t with it. I should have kept my G4 1.25 mini.
Any help??

Mac Mini, 20 gig iPod,30 G iPod, Intel mini, Mac OS X (10.3.7)
  • Chris Girard Level 1 Level 1 (100 points)
    I forgot to add that I am running the lastest OS ( I had to update the security update today when I logged in )
  • troydimock Level 3 Level 3 (505 points)
    i don't know if this will help, but if you go into itunes and like quadruple click really quickly the eject from your ipod, sometimes that has a tendency to eject everything that can be ejected. That worked for me on the two occasions that i have tried. but i don't know if it will work for you though but you could try it.
  • kd5boc Level 1 Level 1 (40 points)
    Have you tried the disk utility?

    When it comes up, you should see 2 drives...the HD and CD/DVD

    You can click on one to examine it.

    If the CD/DVD drive doesn't show up at all...take it in to Apple. I had a HD issue and the nearest store was 80 miles away...but I took it in anyway to have it fixed under warranty. If you have already done 2 reinstalls (which are not recommended) then it sounds like it may be a hardware issue...
  • robnich Level 3 Level 3 (775 points)
    I also had a disk that would not eject no matter what I tried and I finally was successful in ejecting it by standing the Mini on its side while I pushed the Eject button on the keyboard. I don't know what made me try that, but it worked.

    If you try this, be sure the power cord doesn't come out of its socket on the back of the Mini, as it is a rather loose connection.

    Bob N.
  • Chris Girard Level 1 Level 1 (100 points)
    I have checked disc utility. It only shows my hard drives. This is fustrating. I can hear the disc spin up for about 4 seconds during start up
  • robnich Level 3 Level 3 (775 points)
    Disk Utility will not see CD/DVD drives, but the System Profiler will (Apple Menu/About This Mac.../More Info.)

    Did you try ejecting with the Mini on its side?

    Bob N.
  • NatalieStam Level 1 Level 1 (10 points)
    Whenever I get a disk stuck in my mac mini I restart it and the whole time i just keep hitting the eject button on the key board.

    I know, it sounds ridiculous, but it works. You just have to make sure you start hitting it before the desktop comes up.
  • kd5boc Level 1 Level 1 (40 points)
    I hate to say this, but you might be better off taking it in to Apple...I know it's a good drive down there, but there might be something wrong...if teh Eject doesn't work, and holding the mouse doesnt...wait...

    Have you reset the PMU?

    Unplug the unit for about 30 seconds...then HOLD the power button and plug the power back up. Release the button and then turn it on like normal and hold teh mouse button to Eject.
  • Bill_R Level 2 Level 2 (325 points)
    First, quit all applications that are using files on the disc. Then try one of these alternate methods:


    Choose Apple menu > Restart and hold down the mouse or trackpad button until the disc ejects.

    I am not sure if the following applies to a Intel based MAC:

    If all other methods fail, you can try to eject the disk using the firmware (this may not work on all computers). To use this method, start up and briefly use the computer with only the firmware loaded, not the standard Mac OS X interface.

    To eject a disc using firmware:
    Restart the computer.
    When you hear the startup sound, press and hold the Command-Option-O-F keys. (The Command key has an Apple on it.)
    Release the keys when you see a white welcome screen.
    At the prompt, type:
    eject cd

    Press Return, then wait a few seconds. The disc drive should eject the disc, and "ok" appears on the screen when the action is complete.
    Type:
    mac-boot

    Press Return.

    Your computer starts up normally and you see the familiar Mac OS X desktop.
  • Rollie Level 1 Level 1 (10 points)
    I've had this happen as well. Do you have Toast installed?

    If you do, open up the program click on recorder from the top pane and then choose eject.

    I find this works every time.