Previous 1 2 Next 20 Replies Latest reply: Mar 12, 2014 11:14 PM by aerophanto Branched to a new discussion.
Nomis_Co Level 1 (0 points)

About 3 days ago i did an update to Mountain Lion. First all went very well but when i started a video my mouse began to jerk. I saw that the process coreaudiod went up to 20 - 30% cpu usage. I read in the communities that i have to Pram reset, Repair the Volume delete audio files, change coreaudiod.plist from false to true and so on. I did a complete reinstallation and later also a downgrade from mountain lion to Lion 10.7.4 but it didn't help. I don't know what i should do?! Can anybody help me? Got an iMac 27" Mid 2011 Core i7 12GB RAM

iMac (27-inch Mid 2011), Mac OS X (10.7.4)
  • mac_ro Level 1 (0 points)

    I had the same issue and tried a lot. But in the end, it was this hint: tings/



    • Deleted the Audio folder located at [OSX HDD Name]/Library/Preferences/ and create a new one as root in the terminal:
      "sudo mkdir /Library/Preferences/Audio"


    • then set permissions:
      "sudo chown -R _coreaudiod:admin /Library/Preferences/Audio"


    Cheers, Roland

  • Nomis_Co Level 1 (0 points)

    Hey Roland!


    Thx for your fast reply! I already saw this site and tried this what you wrote but it didn't help I found out that when I'm sliding the regulator to the left side in the audio-settings particularly in the balance-setting the left speaker doesn't work so maybe it's an hardware problem and because of this the coreaudiod process is using so much cpu. I now brought my iMac to an Apple Authorized retailer. Hopefully they find the problem.


    Cheers, Simon

  • aekeus0424 Level 1 (0 points)



    I am having a similar problem with my 2011 MacBook Air 13". The left speaker will only output crackling sound if the volume is set to the highest level. The right side does not seem to have a problem. Any idea what could be causing this?



  • briansmyth Level 1 (0 points)

    This worked a treat for me. The _coreaudiod service was using up 120% CPU and adding in the folder (which was already missing) fixed it immediately. Thanks a million.

  • computermatt Level 1 (0 points)

    I uninstalled MacPorts and didn't know why my computer was performing so poorly.  I used top in the terminal to see what was going on and creating this folder with the permissions fixed the CPU usage issue.  Thanks for the post.

  • Adel Sabry Level 1 (0 points)

    @mac_ro   Thank you so much


    Thank you so much, I followed your steps, and it solved my issure instantly as soon as  I


    " sudo chown -R _coreaudiod:admin /Library/Preferences/Audio"


    on my New MacBook Pro 15", i7 2.6 GHz, Mountain Lion 10.8.2


    Thank you so much


    This Solved my Problem

  • Bilyard Level 1 (0 points)

    I am on Lion and was having similar problems with coreaudiod over 100% and crippling the system. I have also read people on Snow Leopard having similar problems. Eventually I found that the /library/preferences/audio folder (that is the root /library folder, not system/library or username/library) was missing (this may even have been self inflicted, ironically, following some online advice on how to speed up my system!) Roland's solution should work, or you can as I did just copy the above audio folder from another Mac (I used my partner's who is on Snow Leopard and it worked fine). Another useful bit of info I picked up during the process is whilst you're sorting all this out, if your system has ground to an almost halt, you can disable the coreaudiod process using the following commands in terminal:


    To load or unload coreaudiod temporarily:

    sudo launchctl load /system/library/launchdaemons/

    sudo launchctl unload /system/library/launchdaemons/

    To load/unload and have this persist even when rebooted:

    sudo launchctl unload -w /system/library/launchdaemons/

    sudo launchctl load -w /system/library/launchdaemons/


    The unload will disable all the audio but gives you your memory back whilst you replace your audio folder, then just run the load command and reboot.



  • John-Paul May Level 1 (20 points)

    That's a truly incredible tip


    sudo mkdir /Library/Preferences/Audio


    sudo chown -R _coreaudiod:admin /Library/Preferences/Audio



    thank you very much indeed.

  • Chris_1983 Level 1 (0 points)


    Today I had the same problem. After reading this article, I have tried to solve the problem with Time Machine. I noticed that the folder "/Library/Preferences/Audio/" no longer exists. The problem itself occurred only two days after the loss of the folder.




    Change to the directory "/Library/Preferences/". Open Time Machine and choose a day on which the folder still exists. Restore folder. Reboot (it's better that way). Open Disk Utility and repair the permissions.


  • Lightsheer Level 1 (0 points)

    Mad props to mac_ro.  That tip saved by butt!!


    Thanks Mate!!

  • cytex Level 1 (0 points)



    I have been pulling my hair out trying to figure out why my brand new Mac Mini was going beserk.

    Activity monitor showed nearly 100% CPU usage...and I could not do anything on my computer.


    I had no idea what I was doing but nervously followed the exact instructions provided.   IT WORKED!! 


    Curious, but Apple support was unable to help and referred me to another tech who is supposed to call me back tomorrow.  Now that will NOT be necessary.  Again, thank you!

  • GooberSnattch Level 1 (0 points)

    Can you explain step-by-step exactly what you did? I'm having the same problem but I'm not understanding HOW people fix it.    Any details will be helpful!! thanks!!!!

  • GooberSnattch Level 1 (0 points)

    nevermind, figured it out and it worked

  • cytex Level 1 (0 points)

    Glad to hear it worked for you also...the Apple Tech did call back and I told her how I managed to fix the problem, with instructions from this thread.  She was not aware of how to do this little trick.


    I will definitely keep this thread BOOKMARKED, in the event it happens again.

Previous 1 2 Next