5 Replies Latest reply: Aug 14, 2012 9:45 AM by pmfoto
peterfromwesthausen Level 1 Level 1 (0 points)

My Aperture is hanging. All 3 repair-options (with alt+cmd) does not work.

circle + "Aperture 3 öfnen" / "open Aperture 3" is showing for hours.

Bildschirmfoto-2012-07-31-um-08.58.32.jpg

What can i do?


iMac, OS X Mountain Lion
  • 1. Re: open Aperture 3 prompt and nothing else
    léonie Level 9 Level 9 (51,665 points)

    Peter,

    can you launch Aperture at all,

    • for example by holding down the option-key⌥ when launching and creating a new, empty library? This will tell us, if your library is corrupted in some way.
    • Or by launching it from a different user account? If you do not have a second account, create one for testing from the "System Preferences > Users & Groups" panel. This can tell us, if you have corrupted preferences or presets or other problems with your user account.

     

    Where is your library located? On your system drive, or on an external volume?

     

    What is your Aperture 3 version? Did you upgrade to 3.3.2 for Mountain Lion compatibility?

     

     

    Regards

    Léonie

  • 2. Re: open Aperture 3 prompt and nothing else
    peterfromwesthausen Level 1 Level 1 (0 points)

    I have a very new System - Mountain Lion with all Updates and Aperture 3.3.2. It was starting after the last update. I don't know the reason, why it's not getting open. Nothing important change.

     

    on my other accounts:

    Bildschirmfoto-2012-07-31-um-18.16.jpgBildschirmfoto-2012-07-31-um-11.09.jpg

    If I make a new library with Aperture will open but shows nothing at all. Only the menu bar.

     

    Perhaps a new install will help.

    (If my canon printer was standard it crashes all programs with cmd+p. But this canon-drivers are to download on apple.com. So i fixed the problem with a reinstall. And usually you don't have to install this stuff - but there is a download! - my disk seems ok, says disk-utility)

     

    I use it for my job! A wedding is waiting to finish.

  • 3. Re: open Aperture 3 prompt and nothing else
    léonie Level 9 Level 9 (51,665 points)

    If it does not even show the application window, that usually indicates a broken user preferences file, if it happens with a new and empty library.

     

    Remove the preferences from the user library.

     

    But that you have the same trouble in all accounts, is a bad sign indeed; reinstall Aperture, and if that does not fix it, reinstall the operating system; see Aperture 3: Troubleshooting Basics

  • 4. Re: open Aperture 3 prompt and nothing else
    peterfromwesthausen Level 1 Level 1 (0 points)

    Thx for the links at tips. I solve the starting-problem by reinstall from DVD and update it. The only problem was the lost of metadata - but this can be reload from the originals over the menue.

    The pitty is only, that i have to redo this installation-prozess after some days too :-(.

  • 5. Re: open Aperture 3 prompt and nothing else
    pmfoto Level 1 Level 1 (0 points)

    hello i need help with this problem, any ideas????????

     

    Aperture still not opening so, i did open Iphoto as a message recommended to upgrade library, what I did was to select the aperture library to be showed in Iphoto and it works, but after using few times i found another problem

     

    trying to open Aperture the following message appear:

     

    -------------------------------------------------------------------------------- ------------------------------------------------------------------------------- - --------------------

    Warning

     

    There was an error opening the database for the library “~/Pictures/Aperture Library.aplibrary”.

     

                                                                                                                                     (Quit)

    -------------------------------------------------------------------------------- ------------------------------------------------------------------------------- - --------------------

     

    also when I try to open iphoto this message appear:

     

    -------------------------------------------------------------------------------- ------------------------------------------------------------------------------- - --------------------

    Caution:

    The current screen resolution is not optimal for iPhoto.

                                                                        

                                                                                                                                     (OK)

    -------------------------------------------------------------------------------- ------------------------------------------------------------------------------- - --------------------

     

    if  I do click another message appear:

     

    -------------------------------------------------------------------------------- ------------------------------------------------------------------------------- - --------------------

    "Your photo library is either in use by another application or has become unreadable

     

    Shut down and restart your computer, and then open iPhoto again. If the problem persists, try rebuilding your photo library.

    To do this, quit iPhoto, and then reopen it while keeping the Option and Command keys pressed.

    You can also try restoring your photo library from a backup."

     

                                                                                                                                    (Quit)

     

    -------------------------------------------------------------------------------- ------------------------------------------------------------------------------- - --------------------

    and then close, so none of the program open and i dont know what to do.