Previous 1 6 7 8 9 10 Next 294 Replies Latest reply: Sep 15, 2015 10:30 AM by rogercrocha Go to original post Branched to a new discussion.
  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    I do have the same issue, my iMac looses connection during 6-8 hours of sleep, my MacBook Pro does not.

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    And what about: pmset -g networkoversleep 1

    By default it's 0

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    Hello Knidsrok,


    I've found something while trying a lot of things to solve the issue, what I did was to reset the Time Capsule, then from my iMac I set it up using AirPort Utility.


    Usually I connect to my 5GHz network. By setting up the Time Capsule from my iMac, it has now in Keychain the passwords for the 2.4 and the 5GHz. And in Network Preferences/prefered networks I've the 5GHz at the top (because I want to use it) and 2.4 below.


    Now is the strange part, when I leave my iMac asleep for a while it disconnects from the Time Capsule to connect to my AirPort Express. I noticed that while using AirPort Utility from my MacBook Pro. My Time Capsule spreads 5 and 2.4GHz and the Express only 2.4GHz. My iMac is not in the same room as Time Capsule.


    So here is my conclusion, after a few hours of sleeping, the iMac enters in a deeper sleep, and the WiFi signal is maybe very low. Before it was disconnecting from Time Capsule, because the distance was too long. Now it connects to my AirPort Express next to it because it has the passwords to log to it.


    I'll let it during the night, see if tomorrow it will be still connected.

  • Meissner Level 1 Level 1 (5 points)

    Solved !   New to Macs...  migrating from Windows XP finally !  After a little fiddling and investigating found the solution:


    Go to System Preferences:  Sharing:  Select Remote Login !


    Voilá...  your done. 


    Note it takes almost 15 seconds to wake up my brand new Imac...  It took under 1 second to wake my nine year -old PC !




    Screen Shot 2012-12-30 at 11.36.30 .png

  • vestax32 Level 1 Level 1 (0 points)

    Meissner, your solution does not solve the problem.



  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    I've some news for you, first I made a clean install on OS X 10.8.2 on my MacBook Pro and my iMac.


    The MacBook Pro keeps the connection over Wi-Fi and after 12 or even 24 hours of sleep, I can wake if from sleep with a remote app from my iPhone. With the iMac it's different, after 6 hours of sleep it disappears from the network. I noticed that simply by using AirPort Utility from my MacBook Pro or iPhone. I click on Time Capsule and I see the wireless devices connected to it. During a few hours the iMac is still connected, and after 6 hours it disappears.


    Next, I plugged the iMac with an ethernet cable to my Time Capsule, now iMac is still connected even after 12 or 24 hours of sleep (it works like MacBook Pro does over Wi-Fi).


    But I want to use it over Wi-Fi, because to perform this test, I moved the iMac to the living room, I don't want to leave it here, it has to be in my bedroom.


    With a lot of search I've found something very interesting, I didn't try it yet:


    - My MacBook Pro uses hibernate mode 3

    - My iMac uses hibernate mode 0


    Do you think it could solve the issue by changing the hibernation mode of the iMac?


    Let me know what you think,

  • ChicagoBubba Level 1 Level 1 (10 points)

    I'm going to add my voice to this issue. I got a new MBP in November, and I was eager to use BTMM to connect to my 27" iMac at home while I am on the road. However, WOL is not working for my iMac. I have read this entire thread, but I opted to not try any of the "fixes" yet since people reported back that it wasn't working for them.


    I'm going to submit this as a bug to add my request for a fix from Apple.

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)



    2 days ago I was trying to compare the settings of my MacBook Pro (which wakes on lan without any issue) with the settings of my iMac (which disconnects from the network after something like 6 hours of sleep).


    I was thinking it should be something related about how does the Mac handle the sleep and how it reacts during the sleep mode. In the preferences, I've notices that my MacBook Pro uses hibernate mode 3, my iMac uses hibernate mode 0.


    So, I changed the hibernate mode to 3 on my iMac. And over 12 hours of sleep I was able to wake it up without any issue. At the same time, I changed the hibernate mode on my MacBook Pro to 0. Guess what? It reacts like the iMac now, it disconnects from the network after 6 hours of sleep.


    To change your hibernate mode type in terminal:

    sudo pmset -a hibernatemode 3


    If you want more information about hibernate modes, here's the link


    I'll inform you if the problem comes back.

  • monsterbob101 Level 1 Level 1 (0 points)


    I have been following this discussion for some while now and this solution really did the trick for me! My main problem have been connecting to my late 2011 MacMini with Plex Media Server. I checked the settings and they were set as hibernatemode 0. After changing this to hibernatemode 3 it is now possible to wake the MacMini using the IOS or Mac Plex client. This is not possible when hibernatemode 0 is set.

    So, for my maybe limited requirements this solves the issue. Thank you!

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    I'm happy to help ;)


    Let me know, if you let the Mac mini asleep for an entire night or weekend, if you can access it and if it wakes on lan. Because it was my problem with hibernate set to 0. It worked fine exception after 6 hours of sleep, it disconnected. Now it keeps connected!

  • kane_TO Level 1 Level 1 (10 points)

    Changing the hibernate modde didn't work for me.  I had this same problem when I first got my imac a few years ago.  I fixed it somehow, but I can't remember what I did.  Now after upgrading to Mountain Lion it's back.  Wish I hadn't upgraded!


    One question though, Apple claims that the wake for network access is only supported using an Airport Extreme basestation, but it had been working for me with a linksys router.  Do most people have this problem when using an airport extreme?

  • bjw Level 4 Level 4 (1,325 points)

    I have had this issue intermittently with an AirPort Extreme.   I plan to try this solution as I'd never heard of this setting and it seems logical to try. 


    I believe I posted much earlier in this thread or a similar one that my mid-2011 iMac wouldn't wake for network access.  A clean install of Mountain Lion improved things dramatically, but the problem came up from time to time.  I'm hoping this solution might completely eliminate the issue. 

  • kane_TO Level 1 Level 1 (10 points)

    I notice that I cannot wake the computer when I put it to sleep directly using the apple menu.  It's more likely to wake over network when it goes to sleep after the set time, though not always). 


    Just an oberservation.

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    Hello everyone,


    Hibernate mode 3 doesn't solve the problem.


    In fact, I think everyone was looking into iMac settings (me included) and it was maybe not where to look at. So I decided to look into AirPort Utility settings and guess what, I think the solution is here.


    From what I've found on forums and Apple supports about people reporting the problem, they all say "the problem came after my upgrade to Lion or Mountain Lion from Snow Leopard" and maybe you are in this case.


    With Lion and Mountain Lion the AirPort Utility changed, and one setting by default also changed.




    By default AirPort Utility is set to "WPA2 Personnal" for your wireless network security on your AirPort Base Station (Time Capsule, AirPort Extreme and AirPort Express).


    Back to Snow Leopard, (where the problem wasn't here according to a lot of people) the default settings were "WPA/WPA2 Personnal". I think that changing back to the previous settings may solve the issue.


    I don't have strong knowledge about network configurations, but when I'm faced to a problem, I try to find anything that could solve it.


    If someone knows more than me, let me know if it's where to look at.

  • vestax32 Level 1 Level 1 (0 points)

    I have tried this method on my BT Homehub router and it has not fixed the problem. This really is starting to take the p*ss, Apple SORT IT OUT!!!!!!!!!!!!

Previous 1 6 7 8 9 10 Next