Previous 1 16 17 18 19 20 Next 293 Replies Latest reply: Apr 28, 2015 2:25 PM by Romiks Go to original post Branched to a new discussion.
  • vestax32 Level 1 Level 1 (0 points)

    If you go into Network in Airport Utility settings, what is 'router mode' set to?

  • StigBull Level 1 Level 1 (10 points)

    DHCP and NAT.

  • ShivaSound Level 1 Level 1 (0 points)

    Still broken in 10.9.1

    Broken since 10.6.8 in multiple macs.

    2 different mid-2010 mbp (both worked fine on 10.6.8)

    1 2012 27" imac (broken since bought on 10.8, now on 10.9.1)

    1 2012 mini(broken since new on 10.8, now on 10.9.1)

    Same results in two different networks (one on a linksys, one on a ubee router)

    I have read this entire thread, none of these fixes work, (besides never letting the machines sleep)

    How hard can this be for apple to get right?

    Fail.

  • StigBull Level 1 Level 1 (10 points)

    ShivaSound: Maybe it's your routers?

     

    I have a Time Capsule (not the tower model, the Mac Mini form factor one), and since Mavericks I have been able to wake my Macs at home every single time I try. No exception.

  • Inked apple Level 1 Level 1 (0 points)

    Yep, mine works flawlessly in Mavericks too. First time in years that it has.

  • MacUserAE Level 1 Level 1 (10 points)

    I just ran into a very interesting issue that has started to happen within the last 24hrs.  When itunes is running, itunes match is turned on and my ios devices appear in the right upper corner of itunes,  putting the iMac to sleep it is no longer seen in my shared devices from my MacBook Pro.  Once i turn itunes off, the issue goes away.  This is definately new, and I spent several hours speaking to Apple and the senior rep suggested that I erase and reinstall the entire Mac OS.

     

    I am wondering if anyone else can reproduce this before I go erasing and reinstalling.

     

    Thanks.

  • mbriody Level 1 Level 1 (0 points)

    I am trying to get this working on Mavericks with my MBP. I've read the whole thread and all the other links.

     

    Until today nothing worked other than disabling sleep. Then for one glorious hour suddenly everything did - I could wake locally (via a utility), via Teamviewer remotely and locally could wake it and also the DSL reports web page. Great, I thought. So I know for sure my port forwarding is all fine. Now its all stopped again!!!

     

    The only thing that happened was that one hour passed - I changed nothing. I had ssumed the problem was solved and had moved on.

     

    Right now I can ssh in remotely or locally and have access to the files on the Mac via a laptop on the LAN, I just can't get it to wake up for Teamviewer access, even locally.

     

    As a workaround, is there something I can do via ssh to wake it (other than a reboot which is currently my only option)?

     

    Oh and my darkwake value is already set to 8 (by default - I didn't change it).

  • mbriody Level 1 Level 1 (0 points)

    Okay it now seems my test method was flawed. I was using the command line "pmset sleepnow" to trigger sleep and then testing if I could wake it up and that's when I was successful over ALN and internet.

     

    I can now repeat those results.

     

    But it appears the the MBP went into some other different sleep mode sometime within the hour after I stopped testing and that's what I could not wake up. So my original queries still stand....

  • lexvo Level 1 Level 1 (60 points)

    I saw the same behaviour with my iMac: after setting it to sleep, I can wake it up. But after some time it seems to enter some "deep sleep" mode and I can't wake it anymore.

  • Abraham Zabih Level 1 Level 1 (0 points)

    I think I found a fix. I have not been able to get TeamViewer WOL working and found this on another forum.

     

    I went to /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist and changed "PrioritizeNetworkReachabilityOverSleep" from a "0" to a "1". Now WOL works fine with TeamViewer and think it will fix everyones issues.

  • mbriody Level 1 Level 1 (0 points)

    Oh great. This appears to have worked, even when I have the lid closed BUT it disconnects from TeamViewer and sleeps again like 3 seconds after I login.

     

    Annoying!

     

    Is there something else I need to do to stop it sleeping again?

  • Garry Brooke Level 1 Level 1 (10 points)

    It’s the middle of 2014 and still Wake On Lan isn’t fixed. I can’t get it to work for my Mac Mini. My setup is:

     

    • Mac Mini (mid-2011) connected by WiFi to a Netcomm NF3ADV modem-router. Setup as a media server using Front Row (which still works in 10.9.3 !).
    • iMac (late 2009) connected to the Netcomm by ethernet.
    • Both Macs running OS X 10.9.3 with all updates.
    • Screen Sharing and File Sharing from the iMac to the Mini works well.
    • Netcomm WakeOnLan setting is on and the MAC address for the Mac Mini is set correctly.

     

    Have read all 19 pages of this thread. It seems that nothing seems to work completely for everybody.

     

    I have tried the PrioritiseNetworkReachabilityOverSleep option. I didn’t bother testing the WOL that because nothing I did would get the Mini into Sleep remotely (which I need).

     

    I have tried the WakeOnLan and WakeMe utilities. WakeOnLan did work for a couple of days but has stopped working since.

     

    Remote Logon and Remote Apple Events are enabled.

     

    Have decided not to try the DarkWake option, given various comments on this thread.

     

    The Netcomm router can send magic packets (three at a time). It doesn’t wake the Mini.

     

    I have lodged a bug report with Apple. What else can I do ?

  • Cody_G Level 1 Level 1 (0 points)

    I just broke down and bought an airport extreme router, which fixed all of this. I got tired of trying to debug this. I spent hours (NOT worth my time) trying to fix this issue. Spent the $200 and got it over with. Very happy with the router in AC mode as it did better than my current wireless router.

  • StigBull Level 1 Level 1 (10 points)

    Do you have a Time Capsule/Airport Express/Extreme?

     

    I haven't had a single problem with waking my 2011 Mini since I upgraded to Mavericks, and I use a Time Capsule as router.

     

    The magick packet has to destination ports if I recall correctly, maybe your modem/router forwards the packet to the wrong one? Have you tried tcpdump and see if the magic packet really is forwarded?

     

    Let me just stress this again: Not a single problem since Mavericks using Time Capsule.