Previous 1 4 5 6 7 8 Next 294 Replies Latest reply: Sep 15, 2015 10:30 AM by rogercrocha Go to original post Branched to a new discussion.
  • bratman91 Level 2 (185 points)

    Well, the apps I have tried and described in my previous posts are all from the Apple app store, and not all of these will wake up my iMac from sleep. There seems to be two levels of sleep because some remote apps will wake up the iMac and thus allow some other remote apps to work but others remain unable to. On the other hand, there are apps that will wake up the iMac to the extent that all other remote apps will work. My inexpert speculation is that this may be a function of the "darkwake" feature that I have read about in other forums (perhaps some apps wake up the iMac fully while others just partially wake it, while yet others cannot achieve any level of wake up - sounds a bit like bringing up teenagers!)

  • andreambrosio Level 1 (0 points)

    I found a small workaround for it, but it requires having another mac in the network.


    I am on a similar setup. Airport Extreme Base station in one room where the modem is and another AEBS in another room where the computers are. The two base stations connect to each other wirelessly, but the computers all all being served by the same Base station and are all wired via Ethernet.


    I noticed I cannot WoL using Logmein, so I kept one of the computers (2011 mac mini) on "never sleep". I connected through logmein to it and used Apple remote Desktop to try and Wake the other. It fails.


    Now the weird bit: from the Finder, you can still see the other computer (2011 iMac) in the network so I tried to connect to it. It will fail in a bizarre way: it allows me to see the first level of network shares, but won't allow me to browse further. I think this has to do with some network caching, but after retrying to wake the iMac from ARD, it succeeded.


    I tried the same technique a few times under the same conditions (imac inaccessible at first, try to wake from ARD, fails, try to wake from Finder, fails, retry from ARD, succeeds).


    Guess there's a big bug with WoL on ML (I'm using 10.8.2 with the supplemental update).


    Apple, it would be great if you could fix it!!

  • Kentzo2010 Level 1 (0 points)

    I've encountered the same issue with my 2010 iMac (10.8.2). It's connected via WiFi to Asus WL-520GU/GC (DD-WRT v24-sp2 (10/10/09) micro).


    I was able to make it wake up by sending the WoL magic packet from 2011 Macbook Air (10.8.2) using the wakeonlan tool ( also available through homebrew).


    Looks like the AirPort card does not listen for magic packets everytime, but at some intervals. Furthermore the interval differ for different sources of the packet. Lenths of interval in ascending order: <machine_subnet_broadcast> (e.g.,


    So, to wake you mac, you have to continiously send the magic packet until machine is avialble.


    Here is the script (assuming you've already installed wakeonlan):

    #! /usr/bin/env sh





    while sleep 0.5; do

        wakeonlan -i $2 -p 7 $1


    (Most recent version of the script is also available at

  • bratman91 Level 2 (185 points)

    THere is an interesting thread in the link below, which proposes what seems to be perhaps the best solution so far to the "wake on network access" issue


  • joda1956 Level 1 (10 points)


    I tried it, and that is not the expected reliable solution. Still waiting for any solution from Apple or for an answer to my feedback for a change...


    Best regards

  • Flight0fideas Level 1 (0 points)

    I have been dealing with this issue for a while and I tried everything that has been listed in this thread. Nothing here worked properly for me. I then found a suggestion on the support page of iteleport that points "darkwake" as the culprit. I followed the procedure suggested by iteleport and I can now successfully access my Mac mini as I previously was able to. My only concern with this change is that I am not quite certain that the Mac is actually going to sleep, I have to do further testing to find out. Regardless, this may help most of you. Steps to disable darkwake are listed below.




    As an administrator, edit the following file:




    Find the KernelFlags key and change it from:


    <key>Kernel Flags</key>





    <key>Kernel Flags</key>



    Reboot your Mac. Wake on LAN should now work.

  • joda1956 Level 1 (10 points)

    Hi, thanks, this solution was already known in the thread. After an upgrade from Apple the original Boot.plist without darkwake string was back. 

    I tried it once more a minute ago and come back if it works.

  • bratman91 Level 2 (185 points)

    There are posts on one or two forums that report problems after setting the darkwake parameter (short-duration freezing of the computer, USB's not working etc) so I for one have decided not to change either the darkwake parameter or edit the PowerManagement .plist file referred to elsewhere it this thread. Instead, I have simply changed the Energy Saving option so that the computer never sleeps. OK, this might use more energy but my iMac gets barely warm when sleeping so I don't think it is much. Additionally, this might be kinder on disk drives in that they do not need to keep spinning up.


    By the way, the behaviour of my iMac when set, respectively, to never sleep and to sleep when possible, has not left me confident that, when it was on Lion, it ever slept at all (just the screen turned off). I base this, firstly, on the fact that my external hard drive never stopped spinning although it does with Mountain Lion and, secondly, I don't recall it getting stone cold as happens with Mountain Lion in sleep. This suggests that the computer never went into sleep mode and, hence, the external drive (and presumably the computer disc) never stopped.


    Nevertheless, Apple should provide a solution to this issue and, ideally, give an explanation of  the differences between Lion and Mountain Lion in their implementation of the Energy Saving options. I have submitted a bug report to Apple and suggest that others do the same to try to encourage a rapid response. "It just works"!!!

  • wifiguru Level 2 (240 points)

    To all of you folks who see this issue, if you sleep your Mac and from within your local network if you try to wake the machine up for screen sharing etc., does it work ? If that works, then this could be a Back to my Mac specific issue rather than a simple Wake issue within your local network.

  • David Munch Level 1 (5 points)

    wifiguru: It doesn't work.

  • bratman91 Level 2 (185 points)

    Wifiguru:i have the "wake on network access" problem and "back to my Mac" has never been enabled on my iMac. I do not have a second Mac and I don't think that "back to my Mac" can be used from my iPhone or iPad. However, an app called Hippo Lite does wake up the iMac and display from my iPhone/iPad, but other apps are not able to even connect.

  • Trueroman Level 1 (10 points)

    I am also having this problem, Late 2011 15 inch MacBook Pro running 10.8.2. Have tried every solution on this thread and still no luck.

  • joda1956 Level 1 (10 points)


    I tried that modification of boot.plist on my mini. It works somehow. I'm not sure if the mini wents to sleep, but it wakes up perfectly when I try to use a share via my iMac.

    I wonder if anybody else has tried it.

  • chasb441 Level 1 (0 points)


    Have you read the whole thread? Yes people have tried this and yes it seems to work but there is some doubt as to weather the mac is truly asleep. So if it works for you fine but before adding any comments please read the whole post, it helps others to understand if your comments are worthwhile trying.

  • joda1956 Level 1 (10 points)


    Of course your comment is much more helpful than mine. I read the thread and the count of responses to the darkwake solution are not as many to define any rules on it.

    Perhaps you can share your experiences instead of playing some kind of Daddy. ;)

Previous 1 4 5 6 7 8 Next