Previous 1 2 3 Next 133 Replies Latest reply: Jan 8, 2015 6:41 AM by ktonini Branched to a new discussion.
Inquisitor-LSL Level 1 Level 1

Good Day.

 

Since upgrading to OS X Mountain Lion I've experienced some unexpected networking issues.

 

Unlike others reporting in this forum that they are unable to achieve 802.3ad Network Link Aggregation, I do not have this issue.

 

However when I shutdown or restart the 802.3ad Network Link Aggregation (bond) is physically lost, although the settings remain.

 

To get the 802.3ad Network Link Aggregation link working again, first I need to delete the bond, add back each ethernet, then set up the 802.3ad Network Link Aggregation bond again, afterwhich the bond works just fine until shutdown or restart.

 

*I'm using a TP-LINK TL-SG3216 (JetStream L2 Managed Switch) + Cat 6 Ethernet cables. Physical setup and Switch has not changed*

 

This is not an ideal situation, and for the long term having to go through this procedure everyday will become tedious.

 

One other observations, with the 802.3ad Network Link Aggregation bond made and working, within the advance tab, the Hardware Tab is greyed out. Previously in OS X Lion this was not the case and this part of the advance tab feature could be used to set frame sizes.

 

Any thoughts or assistance to obtaining a 802.3ad Network Link Aggregation bond that remains after shutdown or restart would be highly welcomed.

 

Thanks in advance.

 

 

 

P.S. Apple......Thanks for OS X Mountain Lion, some nice bits, but alas needs some attention to overcome various operational issues. Our other Mac Pro's are firmly staying on OS X Lion & OS X Lion Server until Mountain Lion gets the fixes that Mac Pro community needs, especially those whom use Mac Pro to earn a living.


Mac Pro (Mid 2010), OS X Mountain Lion, Mountain Lion 802.3ad Network Link
  • DimsBE Level 1 Level 1

    Hello !

     

    Same issue here since day 0 when I moved to 10.8. MacPro is connected to Netgear GS108T and Bond0 interface cannot come up after reload, unless I clear bond config (by deleting it) and re-configure it again.

     

    Hopefully I don't need to restart the box frequently otherwise I would be moving back to Lion

  • Inquisitor-LSL Level 1 Level 1

    DimsBE & All

     

    I have established that when the machine is commanded to SLEEP, upon recovery the aggregated link stilll works fine and has not reset.

     

    So although not ideal, at least an interim workaround.

     

     

    I've also dug a little deeper into the perference files and compared OS X Lion to OS X Mountain Lion (NetworkInterfaces.plist)

     

    I notice that in Lion each ethernet is called up as:

     

    <string>IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/RP03@1C,2/IOPCI2P CIBridge/ETH0@0/Intel82574L/IOEthernetInterface</string>

     

     

    whereas in Mountain Lion each ethernet is called up as:

     

    <string>IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/RP03@1C,2/IOPCI2P CIBridge/ETH0@0/Intel82574L/en0</string>

     

     

    I'm continuing to explore, to see what other changes/differences exist, maybe somewhere there is the key to this problem? ?

  • Inquisitor-LSL Level 1 Level 1

    All

     

    I've contacted Apple Support directly this afternoon on this subject to get a solution!

     

    After a 46 minute call I have been informed that Apple 'Enterprise' team are aware of this issue and are working on a patch solution now which is likely to be part of the first round of issues to be resolved in the 10.8.1 update.

     

    No timescale for the patch could be provided , but the Apple representative did say historically the first patch normally comes out quickly to resolve issues. Let's hope this issue get's fixed.

     

     

    One other thought that I had, is there anyone in the OS X community able to bring together an applescript to automate the the workaround that I originally posted, at least then it would be quicker to get the aggregated bond up working after a restart.

     

     

    Until either the patch or a really nice person can put out an applescript, i'll either endure the daily procedure to get the bond working or keep the Mac Pro in sleep mode overnight.

  • macproser Level 1 Level 1

    Good to know. I am having the same issue.

  • BCinOAK Level 1 Level 1

    Same issue here.

  • stefan.schreck Level 1 Level 1

    Count me in.

  • Inquisitor-LSL Level 1 Level 1

    All

     

    Two weeks with this Mountain Lion 802.3ad issue (the most polished OS X yet......apparently...), and it's all too much of an inconvenience.

     

    No updates from Apple as to roll out of update/patch/fix/service pack, so........

     

    Restored back to Lion, 802.3ad works, the Mac Pro works, I can work.

     

     

     

    P.S. Sorry to hear of others having same issue (those having posted in this thread), and possibily others of the 470+ that have read this thread to date.

  • macproser Level 1 Level 1

    Inquisitor-LSL

     

    Thanks for the update -

  • phocus-it Level 1 Level 1

    I had the same problem with Mountain Lion and had to manually active Trunking on our HP Procurve Switch J4904A in Switch Configuration>Port-Trunk Settings>the two ports for your System>then activate "TRK1 with LCAP" on the first and the second port. After saving these settings on our Switch the bond worked in 10.8. Ethernet1 and 2 are now working together again. Green lights :-)

    Marc

  • phocus-it Level 1 Level 1

    Sadly but truly after restarting OSX all Connections are lost, no connections partners are found. it worked fine before restarting OSX. Weird Problem...

  • Inquisitor-LSL Level 1 Level 1

    phocus-it, Thanks for your post.

     

    A question if I may, I and others can get 802.3ad link aggregation bonds to work (see original post), I guess our issues are when the Mac is restarted or booted post shutdown the bond does not come back up live as it does within OS X Lion, so i'm interested in your case do you have to re-make the virtual interface (bond) within OS X Mountain Lion with your setup upon every restart or not?

     

    If you're not needing to remake the virtual interface upon every restart, maybe this issue is a function of hardware setup (802.3ad Switch type) used, or a susceptibility within OS X Mountain Lion over OS X Lion?

     

    Thanks

     

    Inquisitor-LSL

  • Inquisitor-LSL Level 1 Level 1

    phocus-it, Thanks again for your post.

     

    Sorry to hear you have the exact same symptoms, if you're happy to never restart OS X Mountain Lion the bond once made will keep working, the bond will still be active is you resume from Sleep, any restarting and you'll be deleting the virtual interface and making a new one after each restart.

     

    I did a couple of weeks everyday make the bond work, after which got bored and went back to OS X Lion.

     

    It's interesting to note the symptoms occur regardless with manufacturer of 802.3ad compliant Switch is being used, I run TP-LINK, you're running HP, others on Netgear.

     

    On my side my L2 managed switch allows me to make a 802.3ad aggregated link as either a 'Static LAG Link' or dynamic 'LACP', i've tried both types with OS X Mountain Lion, same end results - makes No difference.

     

    Cheers

     

    Inquisitor-LSL

  • Brian Covalt Level 1 Level 1

    10.8.1 is out and does not resolve this issue.  Bummer.
    When talking to the Enterprise Apple Support agent he assured me that this was a high priority and would be resolved with the first OS update.

  • macproser Level 1 Level 1

    Rats -

Previous 1 2 3 Next