Previous 1 5 6 7 8 9 Next 133 Replies Latest reply: Jan 8, 2015 6:41 AM by ktonini Go to original post Branched to a new discussion.
  • Rosko255 Level 1 Level 1 (0 points)

    So for those of you still having problems...


    We've had two issues open with Apple Engineering that related to the link aggregate connection. The first one was for it not keeping the connection after reboot, which has been fixed (after many escalations) in the 10.8.3 update released yesterday. The other issue we have open is for the server app not recognizing certain bonded connections, this is an issue with the sever app and not the OS. They are hoping to have this fixed in the next app update as they've identified the issue and confirmed it with what we've seen.


    Just no update on when the next version will be released.

  • Inquisitor-LSL Level 1 Level 1 (0 points)

    Well after my last post where I dug out my ML drive, installed 10.8.3 and network aggregation was still broke, I've given it another go.




    Wiped drive clean.


    Installed ML.


    After ML booted I did not make/configure a bond, simply connected to a local network share and installed 10.8.3.




    Made bond, Bond okay and live, Restarted.


    After restart Bond okay and live, Shutdown and waited 10 minutes, hit power to boot.


    After cold boot, Bond okay and live.


    So I would say with the limited testing, network aggregation does seem to be fixed, However...........


    The 'Hardware' tab located: Network Preferences / Advance / Hardware, for me when I select it still results in it greying out the hardware window does not appear (where you can select MTU etc), this is not fixed to my mind.



    So a question to the other posters whom have been successful after 10.8.3 install, does this window open for you?


    I've attached a picture of the window from Lion (because in ML it won't show) so all better understand what I can not see.





  • ikarus79m Level 1 Level 1 (0 points)

    Any news on this? I was just about to build a post production media server based on the Mac Mini with ethernet aggregation:



    But this scares me! Seems like the link will now hold through a reboot but with the server app not seeing the linked connection would that mean that I could actually nore share my media with the iMacs connected to the server as outlined in that link above?


    That would really mess with my whole set up.

  • Inquisitor-LSL Level 1 Level 1 (0 points)



    Pretty amazed, since starting this discussion a year ago:


    11726 Views and 122 Replies.


    Countless calls to Enterprise Apple Tech Support, eMails etc and the support of this forum and Mountain Lion has aggregated ethernet that is stable. A passage of rites, well you decide.


    Not sure on ML Server aggregated ethernet status, personally i've stayed on Lion Server and gone and got a Synology box (well it's Apples loss).


    I'm not sure what else we need to do or say now, Objective achieved (mostly).



    Thanks one and all for your participation.






  • JohnPembsC Level 1 Level 1 (0 points)

    I'm running a Mac Pro with 10.8.4. The LACP bond seems to be working fine, but the whole Netinstall thing isn't - NO interfaces show in Server app so I can't set up Netboot to image my clients.


    My experience with setting this up has just been one headache after another. If anyone has managed to get this to work, I'd be grateful to hear how! For now, it looks like I'll have to fall back on the trusty x-server (10.6)/Server admin.


    Like a previous poster said though, Apple (by their own admission?) appear to have little interest in supporting enterprise products. Unless they're ios based devices.... Besides, as they recently reported a quarterly net profit of $6.9 billion.... well draw your own conclusions depending on how cynical you are!



  • philoupin Level 1 Level 1 (0 points)

    I have only recently set up link aggregation on Mac Pro 2009 QUAD 2,93 Hz running 10.8.4 installed, so can't comment on how it was on previos OS versions. Had problem after restart / cold start with "cable not connected / plugged in" message in Network Preferences and could only restore service by deleting the link aggregate interface in Network Prefs and setting up Ethernet 1 and Ethernet 2, then creating anther link aggregate / virtual service.


    Last time it wouldn't connect afetr startup I did this in Terminal:


    sudo ifconfig en0 down

    sudo ifconfig en0 up

    sudo ifconfig en1 down

    sudo ifconfig en1 up


    Effectively making Ethernet ports 1 & 2 inactive and active again. After that the link aggregate interface connected itself (red -> yellow -> green light in Network Prefs). I thought I would eventually have to make a Terminal script to send the UP / DOWN commands after startup, but today I start up and link aggregate is there and connects without me having to do anything. Let's see how long it holds...

  • Wautr Level 1 Level 1 (0 points)

    I have been running into this issue as well. After setting up link aggregation and the booting, the link fails with error "no partner"


    Issue occurred on  a mac pro running OS X 10.8.2 and and a mac pro running OS X 10.8.3.


    The OS X 10.8.2 was exhibiting the issue where is the hardware tab for the aggregate link is grayed out as described earlier in this thread. I upgraded it to 10.8.4 too, which got rid of that issue.


    If anyone is interested, I made some tcpdumps of the LACPDU communication between a mac pro and the switches during boot and after enabling/disabling the network interfaces. If you want a copy of these, just let me know.

    I'm by no means an expert on the topic, but:

    The dumps made during os x boot indicate that the mac never picks up it's partners status (all partner properties in it's LACPDU's set to 0). After making the network interfaces inactive/active the mac does not exhibit this behaviour.


    I've settled for the work-around: I've made a lauchdaemon that disables/enables the network interfaces, checks the bond health and attempts to reload the network interfaces again if the bond is not active.

    This has been working well so far.

  • Inquisitor-LSL Level 1 Level 1 (0 points)



    Service Pack 10.8.4 solves the Network Aggregation issues, and maintains bond after restart/reboot. Many have commented in this thread 10.8.4 solves this reported issue.





  • Tim Kilburn Level 1 Level 1 (20 points)

    In response to John.  Can't recall exactly where I found this so can't exactly give credit where credit is due.  to make Net Install work on 10.8 Server with Link Aggregates, edit the bootpd.plist file in /etc with your favourite editor.  Look for the group of lines similar to below:







    Where bond0 is my Link Aggregate.                the Interface will still not show within the Server app but the images or NetBoots will be served from the 10.8 Server once edited.  Restart after the edit just for security.


    I'm thinking that this issue with the Server app may be affecting my OD replication as well.



  • phocus-it Level 1 Level 1 (0 points)

    There you go: Apple Updated the Server Software to 2.2.2 ... today.



    the german translation is "Unterstützung für die Verwendung von gebündelten oder virtuellen Netzwerk-Interfaces in Server." which is exactly our problem with link aggregation on ethernet connections > "Support for using bonded or virtual network interfaces in Server "


    new OS X Server version is 2.2.2. available on 9/17/2013



  • mvest20 Level 1 Level 1 (115 points)

    So not to drag this back up, but the Server 2.2.2 update has now gone missing.  It appears to not be available from the App Store, at least in the US store.  Does anyone have any information on this, or know if it will ever return or if the only option is to upgrade to Mavericks server?  If that's the case, is this issue resolved in 10.9 as well?

  • mvest20 Level 1 Level 1 (115 points)

    I was finally able to get a download code for 2.2.2 from the server team.  After I did the update, the interface is still unavailable to choose to work with NetInstall, and thus the service can't be started since there is no interace avaialable.  I also tried the bootpd.plist modification, and that also does not resolve the issue; the plist gets marked as corrupted and OS X re-creates a new default plist with the netboot service disabled. 

  • Miscanalysis Level 1 Level 1 (0 points)

    Hi All,


    Well I just bought a TP-Link TL-SG3216 Managed switch (supports 803.11ad), in the hope I could set up an LACP config between my 2013 Mac Mini (non-server production PC) running 10.9.1 and a Synology RS812+ NAS. On the mac side I am bonding the ethernet port and a thunderbolt ethernet adapter. I am able to set up the bond, then enable the ports on the switch as LACP, and the DHCP server (billion router/modem) is able to assign an IP through the switch and all is good. However, if the Mac goes to sleep or gets restarted, upon awakeing the link says "self assigned IP", where the IP should be something like 192.168.0.x, However, the self assigned IP is in a different subnet all together (like 192.168.94.x). The only way to get it to work again is to delete the bond and repeat the initial setup process, and do it every time I awake or restart the Mac.


    Any suggestions or recommendations? I haven't launched a support issue yet, as perhaps it is something wrong with my config.


    I set it up once before with a cheap netgear GS108T switch, and it all worked well. But since then I have moved house, updated OS and bought a switch with more ports. But can't be sure if it is the OS, or the switch.


    Although it seems, the synology nas can reconnect to the DHCP server fine upon restart etc through LACP.


    I tried through a static LAG, but the Mac kept saying "no partner". Thanks

  • ktonini Level 1 Level 1 (0 points)

    I'm having this same issue, actually using a GS108T switch.  It's only slightly less painful, but instead of deleting the whole bond and re-adding it, try editing the bond and removing one of the links, adding that link to the main connection list, let it connect and turn green, and then add it back to the bond. Still painful, but it removes a couple of the steps.


    The terminal fix didn't work for me unfortunately.

Previous 1 5 6 7 8 9 Next