Previous 1 2 3 4 5 6 7 Next 96 Replies Latest reply: Dec 22, 2014 10:03 AM by Mountain Bear Go to original post
  • BobH1.3.4.5 Level 1 Level 1 (0 points)

    I've tried the tip about enabling debug mode options and unchecking the multiprocess window option.  That works but then I lost ability to swipe.  Can't be without that, so I'm back to being frustrated by this 'feature'.

  • christurbo Level 1 Level 1 (10 points)

    You need to enable the debug option on Safari toolbar then enable use Single-process windows.

     

     

     

    • Quit Safari, then launch the Terminal (located in /Applications/Utilities/) and enter the following command
    • defaults write com.apple.Safari IncludeInternalDebugMenu 1
    • Relaunch Safari and you’ll see a “Debug” menu appear on the far right, alongside “Help” (yes, this is different from the Develop menu)
    • Pull down the new Debug menu and scroll down a ways until you see “Use Multi-process Windows” and select it so that it’s unchecked
    • Open a new Safari window and if you see an [SP] next to the web pages title, you’re now in single process mode, which prevents the automatic refreshing of webpages
  • christurbo Level 1 Level 1 (10 points)

    Just to reitterate - it has nothing to do with enabling/disabling Safari extensions.

  • christopher rigby1 Level 4 Level 4 (2,085 points)

    I agree. And I don't know why there is this sudden hysteria about the problem. SAFARI HAS ALWAYS BEEN LIKE THIS!!! I like very many things about Safari but I've always hated the way that a Go Back reloads a webpage, unlike Firefox, or just about any other browser, which return you instantly to the page as it was, from the cache.

     

    There is one way to confirm this problem : go to a site that you know changes every day (e.g. a newspaper or a daily word game or something). Go to that site in both Safari and Firefox. Next day, launch both browsers and observe...

     

    Safari will load TODAY'S page not yesterday's -

    Firefox will load YESTERDAY'S page.

     

    This is how Safari seems to work. It always reloads web pages when you do a Go Back. It's infuriating but it seems to be part of the design.

  • bfurm Level 1 Level 1 (0 points)

    No it hasn't. And we are talking about two different Back Page motions. For mine clicking the actual back button would always reload from the cache. But suddenly last year the two finger swipe to Back Page started to reload completely, but the button still did the cache. I changed mine to a 3 finger swipe and it loads from the cache. Use 2 and its a complete reload. It's purely a bug that Apple is blind too or ignoring for whatever reason.

  • christurbo Level 1 Level 1 (10 points)

    Follow my guide above to fix Safari so that it doesnt reload a the page on a 2 finger swipe.

    It will return to being lightening fast again.

  • christopher rigby1 Level 4 Level 4 (2,085 points)

    I'm not talking about gestures, as I disabled them following the loss of comments I was typing by picking up the mouse which was too sensitive, and went 'Back" when I didn't want it to.

     

    I use Command-[ and have done for years and years, in many flavours of Safari. And certainly for the past few years (not recently) this has refreshed a webpage rather than reloading instantly from cache.

     

    This is WHY Safari - when relaunched the day after you last use it, and your session with it - gives you the latest version of the tabs in that session. Whereas if you do the same thing in Firefox or Opera, you get YESTERDAY's page as it reloads everything from cache.

     

    Try it, if you don't believe me.

  • Areo66 Level 1 Level 1 (0 points)

    The method suggested above involving the Debug menu does work for me. However, it disables the swipe feature so I must click the Back button. This is a non-solution.

     

    This argument on refresh being there to save you from looking at yesterday's news reminds me of the "a feature not a bug" excuse we used in our college days when programming presentations went south!

  • s2_bo Level 1 Level 1 (0 points)

    I tried you guide and it does stop the refreshing on going back. But it disables two finger swiping so its no good as thats how i always navigate Safari.

     

    Please keep psting yout findings people.

    Pothetic that apple hasnt sortted it out yet!

  • erwelt Level 1 Level 1 (0 points)

    You can use the shortcuts cmd-right and cmd-left to navigate through history. That’s still less painful than waiting for a reload each time.

  • Richard Falk Level 1 Level 1 (0 points)

    Cmd-[ (History-Back) to go back and Cmd-] (History-Forward) to go forward seem to work great at not reloading, unlike the arrow keys in the upper left of the toolbar.  Thank you so much for that tip!

  • machamara Level 1 Level 1 (0 points)

    Based on all above ideas here is what worked for me (just set this up so too early to say what else it breaks)..

     

    Do the Debug step and check the "Use Single Process Window" (make sure you read this http://osxdaily.com/2011/09/20/stop-safari-auto-refreshing-web-pages-in-mac-os-x -lion/ - read the caveat at the bottom of the article and only select this option if the benefits outweigh the issues it may cause).

     

    Yes I know this disables the two finger swipe back and forward..so a workaround is to use a tool like BetterTouchTool (http://www.bettertouchtool.net) and make a safari specific setting for 2 finger swipe left and right to enable the History Bk and Fwd as shown in the last two entries in the pic below:

     

  • homever Level 1 Level 1 (0 points)

    Is this all about cache?

     

    You wait until the webpage completely loaded, then you go to another page, by this way it should work without reloading.

  • BobH1.3.4.5 Level 1 Level 1 (0 points)

    The refreshing on swipe back REALLY is a pain when for example shopping on Amazon.com.  When you go back from a product/item detail page to the product list page, it positions you BACK AT THE TOP of the list, not where you left off.

     

    Really stupid how this works.

     

    Bob H

     

    P.S. I've tried the single process option thing ... but then you loose ability to swipe back.  That is not an acceptable work around for me.

  • IgorUKBR Level 1 Level 1 (0 points)

    I solved my problem by doing something very simple:

     

    Installing Google Chrome. It's blazing fast and way easier than bothering with tech stuff like Debug and all...

     

    Just my 2 cents.