Previous 1 2 3 Next 98 Replies Latest reply: Jul 12, 2015 9:48 PM by iamhector
charleyfromNZ Level 1 (0 points)

What's up with Safari constantly reloading pages?


For example, say I'm on reddit, click a thread, read, swipe back there is a substantial pause while it reloads the entire page. Why can't it just use the cached version and be instant? Happens on any site and did not used to behave like this in Lion.

MacBook Pro, OS X Mountain Lion
  • tgd85 Level 1 (5 points)

    I'm having the same problem. Every time I click a link in an open tab, and go back using the "swipe back" function on my mouse, Safari reloads the entire web page rather than using its cache. This makes for some serious delays when browsing. The problem occurs on every web site I have visited since upgrading.


    Currently running Mountain Lion and Safari 6.


    Any ideas how to fix this? I can't begin to tell you my frustrations at the moment. Any help would be very much appreciated.

  • firechant Level 1 (10 points)

    I was having this problem too.  Eventually I disabled all my extensions wondering if one of them was causing it.  Sure enough, the problem ended up being adblock.  I have it disabled now and it doesn't reload when going back anymore.  The bad news is no adblock.  :/

  • Hersco Level 2 (270 points)

    Adblock is disabled on my Mac and I still have the problem. I haven't yet determined what other extension might be causing this. This problem just started. None of my extensions are newly-added ones. Also, the reloading seems to happen only when I move my mouse onto the page after going back.

  • Hersco Level 2 (270 points)

    Followup to my previous post:


    For me, disabling the extension, Do Not Track Plus (v2.2.0.510) fixed the problem.

  • tgd85 Level 1 (5 points)

    Thanks to everyone for troubleshooting this. Had a chance to test out some of your solutions, and unfortunately I am still having this problem. Here is a list of my extensions, (maybe seem very redudant, but I am a privacy advocate)


    1. Adblock Plus

    2. Javascript blacklist

    3. Google Analytics Blocker

    4. Do Not Track Plus

    5. Ghostery

    6. Clicktoflash


    I tried disabling Adblock and DNT+ individually, and then togther, but both left me with the same problem. I am going to try completely uninstalling them now to see if that helps. I might even try disabling other extensions to see if that is the problem and will report back with my results. Am experiencing no issues with all extensions disaabled, but of course, this takes down all my privacy defenses (not good).

  • Precision Gem Level 1 (0 points)

    I have no extensions, never did, and I have this problem. I drives me crazy.

  • Hersco Level 2 (270 points)

    UPDATE: Do Not Track Plus (v2.2.0.510)  may not be the culprit after all. I have had recent success by disabling Ultimate Staus Bar 1.2.5 and turning Do Not Track Plus back on.

  • Hersco Level 2 (270 points)

    Here is the explanation I received from Karl Dearden, the developer of Ultimate Status Bar:


    "There is a bug in the Safari extension api that causes some pages loaded from the cached to not initialise correctly with regards to extensions. What this means is that some extensions on those pages will break, but only when that page is completely loaded from the cache. USB tries to detect this situation and if it does it reloads the page (thus the "page reloading when mousing over a link on some cached pages" bug."


    If this is the case, I wonder whether choosing "Disable Back/Forward Cache" in the Debug menu would fix the problem?

  • samsamcardiff Level 1 (0 points)

    I have this problem, yet i've never installed a single extension.  It all started when i upgraded to Mountain Lion - which came with a Safari update.  This is particularly frustrating because i only have access to 3G internet.  I have switched to Google Chrome for the time being although this is not a proper solution.


    Currently on a MBP Retina 15" 16GB Ram.


    I don't understand why there are no options to address this issue in Safari preferences.


    Any suggestions would be greatly appreciated.

  • Hersco Level 2 (270 points)

    I enabled the Debug Menu setting, "disable back/forward cache," and so far so good. I was able to renable the troublesome extension with no reloading issues so far. You may want to try it. If you can't see the Debug menu, here are instructions on how to enable it:


    How to Enable Safari’s Hidden Debug Menu

    • Quit Safari
    • Launch the Terminal and enter the following defaults write command:

              defaults write IncludeInternalDebugMenu 1

    • Relaunch Safari


    The “Debug” menu will be visible to the far right in Safari’s menubar choices. If you want to disable the menu, go back to the Terminal and type:

             defaults write IncludeInternalDebugMenu 0

    Another option worth exploring may be the NoPageCache extension:

  • Bamtan Level 1 (0 points)

    @Hersco: I've tried your method however disabling back/forward cache hasn't worked for me.


    I believe it's entirely down to the extensions panel.


    The only way I've been able to resolve it was toggling all extensions off or uninstalling them. I currently only use Reddit Enhancement Suite.

  • BloodyHippy Level 1 (0 points)

    @Hersco: I've "solved" my problem by disabling all of my extensions, but that's far from a solution. I use Adblock and RES, and I don't want to sacrifice them just to use Safari. Disabling Multi-process windows and the back-forward cache also do not help. I've tried installing several random extensions, and ALL of them break the back-forward button when tried alone; including the NoPageCache extension you mentioned. This issue is a real pain for me due to my slow connection, any other ideas on how to fix it?

  • Hersco Level 2 (270 points)

    It is obvious that there are multiple causes. What solves the problem for one person doesn't work for others. I agree that disabling all extensions is not a solution.


    Safari 5.1.7 continues to be problem-free for me in Snow Leopard after disabling back/forward cache. Bamtam and BloodHippy: What version of Safari/OS X are you using?


    I hope that everyone who still has this problem has sent feedback to Apple: .

  • BloodyHippy Level 1 (0 points)

    I've submitted a bug report, hopefully it gets fixed in the next update! In the meantime, I'm open to any new temporary fixes as they're found.


    I'm using Safari 6.0 on the latest Mountain Lion.

Previous 1 2 3 Next