Previous 1 2 Next 20 Replies Latest reply: Jul 19, 2015 10:10 PM by budkin
alto2080 Level 1 Level 1 (0 points)

Trouble playing games


MacBook Pro, OS X Mountain Lion, trouble playing games
  • mattw gx Level 1 Level 1 (115 points)

    When I started up Spore for Mac in Mountain Lion with all patches installed, the screen went white with horizontal lines flashing on it. No problems with audio.

     

    I was able to resolve the problem by enabling "Use FBO for Backbuffer" in the Transgaming Cider preferences box. This is the box that goes away if you have disabled the "Display this on subsequent starts" option. I was not able to get it to come back on another account where I had disabled that option. Instead I had to go into the file "Library/Preferences/SPORE Preferences/config" with a text editor and change

    "fbobackbuffer" = "0"

    to

    "fbobackbuffer" = "1"

     

    After that everything worked fine.

  • AdornedPheonix Level 1 Level 1 (0 points)

    Thanks so much! Being trying to fix that for ages, and it works now! Thanks!

  • pheelup Level 1 Level 1 (0 points)

    I can't find the SPORE Preferences folder.  I looked the the library/preferences, system/library/ , and even the packaged contents of the app.  Can someone help?  Thanks.

  • selannes Level 1 Level 1 (0 points)

    I can't find the SPORE preferences folder either.  Under the Spore folder is just the icon for Spore and Galactic Adventures and the two readme files...

  • Mke_W Level 1 Level 1 (0 points)

    I had the same problem, and mattw's fix above solved the problem. Thanks!

     

    The config file should be in the folder /Users/[your user name]/Library/Preferences/SPORE Preferences/, which you can access via Terminal.

     

    Or, if you perfer to navigate via the Finder: in the Finder, click on the Go menu and choose "Go to Folder..." and enter the path above. Right click (or control click) on the file "config" and choose "Open With", then choose TextEdit. Then follow mattw gx's instructions above to edit the file.

     

    Note that the SPORE Preferences folder was not in the System/Library/Preferences folder (at least in my case).

  • pheelup Level 1 Level 1 (0 points)

    Thanks for reminding me about the "go to folder ... " feature.  I opened it with TextEdit, followed mattw gx's instructions but it did not work.  The icon bounces for a while, another will come, the spore splash screen comes up and then the icon disappears. 

    Anyone have any ideas?  Thanks.

  • mattw gx Level 1 Level 1 (115 points)

    Oh. That's a different bug. Delete the spore application and reinstall it. Do not install the updates. Start up spore to the galaxy screen on every account that you want to play it from. Then you can install the updates.

  • mentalwasteland Level 1 Level 1 (0 points)

    I've got a new MacBook Pro (retina display) w/ Mountain Lion. Couldn't run Spore, even with the FBO back-buffer on. I did a complete re-install as suggested, without loading any upgrades. Still doesn't run. It starts up, I get the splash screen, the screen goes black, flashes white, then I get an exception raised ("Unhandled page fault on write access to 0x0000000c at address 0x00e60501"). It asks me if I want to debug the exception. If I select no, it quits. If I select yes, the screen flashes and it quits.

  • Jamaicanmango72 Level 1 Level 1 (0 points)

    Hey there

     

    I just bought a MacBook Pro this past summer and I can't run Spore, although I deleted everything, did the config update, and reinstalled it.  I'm still getting the same error message and am getting annoyed.

  • DxeZzPain Level 1 Level 1 (0 points)

    me too

  • Joe Concaugh Level 1 Level 1 (5 points)

    anyone going to come up with a solution to this issue.  I have the same result.

  • Hulanik Level 1 Level 1 (0 points)

    I am experiencing the exact same problem.  I am running Spore 4.0.  I tried to update to 5.1, but the patch won't install with this version. I will attempt to install the trial version and if that works, may have to re-purchase a new license.

  • Gablud Level 1 Level 1 (0 points)

    Hi,

    I experienced the exact same problem as you all described which was very frustating since my 8 year old really wanted to play this. It opened and then vanished!

     

    My mac is an old Pro from mid-late 2007 on which I updated first to snow leopard and then to mountain lion. I also updated the RAM to 4 GB from originally 2.

     

    I got Spore finally to work by help of the instructions I googled. In short you have to drag the installed program to the bin. Then you need to find the Spore preferences folder and also drag this to the bin. Then empty the bin. Restart and follow the following instructions that I copy in here. Good luck! ( the worst part was to find the Spore pref file, the rest was only very time consuming).

     

    ( to zap the PRAM, please google that and you find instructions of which buttons to hold down during restart)

     

    ------

     

    To find the pref folder:

    /Users/[your user name]/Library/Preferences/SPORE Preferences/, which you can access via Terminal.

     

    Or, if you perfer to navigate via the Finder: in the Finder, click on the Go menu and choose "Go to Folder..." and enter the path above. ( your user name is of coarse the name you see in finder when you look at your harddrive and the name may not correspond fully to your name in the uppermost screen list, this was the case for me)

     

    -------------

     

    What finally worked was this:

     

    Delete All The Things - Drag the Spore program to the bin. Also delete Spore's preferences folder which is hard to find in the new OS.

     

     

    Zap the PRAM

     

    Do a clean install - do NOT update. Click NO when ask to update!!!

     

    Restart, zap the PRAM.

     

    Open the game, it will ask you to update. Let it load the first update, then quit.

     

    Restart, zap the PRAM.

     

    Repeat the single udpate - restart - zap PRAM process until you've done all five

    Done!

  • platerpus7 Level 1 Level 1 (0 points)

    how the **** did you know that?

Previous 1 2 Next