3 Replies Latest reply: Aug 1, 2012 10:06 AM by topcop1
topcop1 Level 1 Level 1 (10 points)

Recently I had a number of problems where I had to get a new hard drive and restore everything.


The hard drive was replaced after I brough my MacBook Pro to Apple regarding a problem with my slideshows.  The music, and sometime the pictures, were skipping and/or pausing for various lengths.  I had tried repair data without success.


The tech felt the hard drive was having problems so it was replaced.


After a full restore the slideshows were a little better in that only the music skipped or paused.  I checks the music source and it was all fine.


So we went back to Apply and our only choice was a Rebuild Database (was reluctant to do this because I thought I might loose all me projects like slideshows and albums.)  Well, the Rebuild worked and the slideshows seem fine.


However, now whenever I scroll through pictures, photos from everywhere show up for a split second before changing to the correct photos.  In slideshows the stream of photos accross the top are all random from the IPhoto data base.  When I select one of them, the correct photo is displayed.


It doesn't seem to affect the slideshow but makes it difficult when editing.


Any ideas?   I am using IPhoto 11 p.3.2 and I have installed the latest update.

  • topcop1 Level 1 Level 1 (10 points)

    I have tried, several times, to rebuild my thumbnails.  However. after progressing to a little over half way I keep getting the following message:


    The volume for “DSC_3556.JPG” cannot be found.


    Insert the disk or connect to the server volume and wait for it to appear on the desktop, then try again.


    With the options -  CANCEL            FIND PHOTO     TRY AGAIN


    Find Photo does not give me any possibilities and Try Again doesn't work.  So I keep hitting cancel.  Each time I hit Cancel and a new "Volume for..."  comes up.   I have spent hours hitting Cancel and although the Progress Bar moves a bit, it never ends and usually crashes.


    I try again and it appears that the same volume I cancelled the first and second tries appear again.


    I also noticed that every time I open an event there is a mish mash of pictures with only a few that belong there.  Howver, when I click on them, the right photo appears.


    This is a real mess.

  • Terence Devlin Level 10 Level 10 (133,930 points)

    Are you running a Managed or a Referenced Library?


    A Managed Library, is the default setting, and iPhoto copies files into the iPhoto Library when Importing. The files are then stored in the Library package


    A Referenced Library is when iPhoto is NOT copying the files into the iPhoto Library when importing because you made a change at iPhoto -> Preferences -> Advanced. (You unchecked the option to copy files into the Library on import) The files are then stored where ever you put them and not in the Library package. In this scenario you are responsible for the File Management.


    It sounds to me very like iPhoto is looking for the photos on the old drive.






  • topcop1 Level 1 Level 1 (10 points)

    Thank you Terrence, but the problem has miraculously gone away.


    The option to copy files into the Library on import was checked, so that was not the problem.


    Last night I again tried to Rebuild the Thumnails.  Once again the progress bar went a little over half way before I started getting the "Cannot find.." message.  So I sat there for about an hour hitting the cancel button and watching the progress bar barely move.   since I had taken notes from two earlier session I kept watching the mesages wondering if all the stuff that came up before and I had cancelled would reappear.  When I thought I was maiking progress I started seeing volumes that had appeared in the prior session.  That is when I pressed Stop to cancel the rebuild.


    The system then went into the Rebuilding Cache mode and after about 30-40 minutes it was done.


    And low and behold, EVERYTHING was acting normally.  No phantom pictures showing up.   I rebooted IPhoto this morning and confirmed that all was in order.  No missing pictures, all events showing the right pictures and slideshows running flawlessly.