Previous 1 2 3 Next 31 Replies Latest reply: Feb 25, 2013 6:10 AM by sean_chan Go to original post
  • macfrompc Level 1 Level 1 (0 points)

    This stabalized me for about 24 hours. I also did a Permissions Repair. Mail has been totally stable now for almost a week.  :-)

  • snailspace Level 1 Level 1 (0 points)

    I tried this, and everything was fine until I tried to enter an email address in the "To:" field. I was able to type 2 letters, then the rainbow ball spun for a second, and then Mail crashed.

  • Siraf72 Level 1 Level 1 (0 points)

    You're a star! This solved two problems I had. Both Mail and facetime were crashing on launch. Deleting the relevant container files fixed both of them.

  • Stan Jensen Level 1 Level 1 (45 points)

    Quote - - - -hi guys, I read through several threads before I found this one.
    My MacPro (Retina SSD) does NOT have





    really have no idea what to do ...





    - - -  I have the sample problem, not in the master Library nor in the user lIbrary

  • Stan Jensen Level 1 Level 1 (45 points)

    OK  have to open up terminal


    and do this command


    The you can hunt down the needed folder...   wehhewwwwwwww


    chflags nohidden ~/Library

  • parro55 Level 1 Level 1 (0 points)

    Mine crashes when entering text into new mail then when reopened and report sent the entered text is still there,

    but its so inconvenient.

    This is new imac and my old one ran snow leopard and never had the probs that ML is showing.

  • cjsoz Level 1 Level 1 (0 points)

    Hi All,

    I am also having this problem with Mail constantly (and I mean constantly) crashing. I've tried all of the above suggested fixes (where I could actually find the relevant files) to no avail. Is Apple going to fix this problem or what. I love my Mac but email is so crucial to our everyday lives now that I'm seriously thinking of changing to another brand. Anyone have any news?

  • jenncmatt Level 1 Level 1 (0 points)

    I also could not find the ~/Library/Containers folder until I revealed all the hidden folders/files. I opened terminal and typed:


    defaults write AppleShowAllFiles TRUE




    killall Finder


    Which relaunched Finder.


    My ~Library/Containers folder showed up then as a hidden file. After I had trashed the file my mail started working properly. Then I typed this into Terminal:


    defaults write AppleShowAllFiles FALSE


    That hid my files again (I had to relaunch Finder again to see the change)


    Also, as another note, I have two hard drives running two different Mountain Lion versions on my Mac Pro, and I had to trash the folder from both drives for mail to work on either.

  • Stan Jensen Level 1 Level 1 (45 points)

    I cannot get my count to work...


    ie I will have read all the emails, and it will still show that there are unread emails.


    I have about 10 email accounts on mail. Not sure that makes a difference, but it is more info.

  • snailspace Level 1 Level 1 (0 points)

    I tried this a few times with no success. The crux of the problem seems to be when Mail tries to find contacts, because the crash happens reliably while I'm typing in the "To:" field. After typing 2 or 3 letters, Mail crashes.


    So far nothing has helped.


    Given the number of posts here and hundreds of crash reports sent in, it's pretty sad that Apple hasn't figured out what's wrong.

  • Stan Jensen Level 1 Level 1 (45 points)

    they had a minor update a couple of days ago that fixed something to do with the mail database file, have you downloaded that yet?

  • snailspace Level 1 Level 1 (0 points)

    Um, I keep up to date with everything that the App Store says needs updating. The update I installed yesterday covered Mail, but had something to do with the display of Japanese characters.


    The thing is that I have 2 Macs: an iMac 2010 and a MBA 2011, both running the exact same versions of all the system software and all the same basic Apple software, yet Mail is essentially non-functional on the MBA and works just fine on my iMac.


    Based on my reading of all the posts in this and related threads, all sorts of different "solutions" are "working", but people then re-post to say the fix didn't last or suggest another "solution." There's something fundamentally wrong with Mail, and Apple needs to wake up and fix it. Unless they're abandoning their computer customers to focus on mobile devices.


    I downloaded Sparrow, and although I don't like being linked in yet another way to Google, Sparrow works on my MBA, and Mail does not.

  • hyperchris Level 1 Level 1 (0 points)

    I had lost auto-complete when entering email addresses. My Contacts data (from iCloud) was fine but for some reason Mail had lost the ability to see it. This was a fresh install that worked fine for weeks and then just stopped. Note that I wasn't doing anything tricky either (Google mail, etc.)


    The sean-chan post was what pointed me in the right direction. This folder ...

         /Users/Chris/Library/Containers/ Support/

    ... contains symlinks for these folders ...




    ... the originals of which are located in here ...

         /Users/Chris/Library/Application Support/


    Once i recreated those symlinks I was back in business. I realize my problem is a tangent to this thread but I think folks might want to explore this Containers folder as it appears to be vital to how Mail finds things.

  • ChrisAdmin Level 2 Level 2 (265 points)

    This solved the mail issue for me - AND another issue I was having in iPhoto believe it or not - when I was trying to add in e-mail addresses to share a photostream, it would not autocomplete any of the addresses I had in my address book. Renaming the ~/Library/Containers/ folder has corrected that issue as well! Thanks Sean!

  • acrimoniousman Level 1 Level 1 (0 points)

    This worked for me as well. Upon inspection of the original symlinks in my .../Data/Library/Application Support/ folder, the AddressBook and SyncServices links were broken (e.g. pointed to nowhere as in AddressBook ->). I recreated the AddressBook and SyncServices symlinks to point to the corresponding folders within the ~/Library/Application Support/ folder, and everything appears to be working now, whereas before Mail would crash on startup with the system log message, "Error: The AddressBook datafile is a directory!". Now, my address book entries work as expected when composing a new message.



    Thanks for the hint!