Previous 1 2 3 Next 33 Replies Latest reply: Oct 9, 2012 3:48 PM by Ryan Burkholder
Tho615 Level 1 (10 points)

Upgrade from lion server 10.7.4 to mountain lion osX server. After upgrade osX server keep giving alert that host name change everytime I reboot the server. Anyone know how to fix this? Everything seem to work except that annoying host name alert.

  • Strontium90 Level 4 (3,860 points)

    Are you on a .local AD network?  What is it changing to and from what?

  • Masterofnonsense Level 1 (10 points)

    I am seeing the same issue on my 2 ML Servers.  Both were clean installs, not upgrades.  Both servers have valid hostnames of server.domain.com.

  • Tho615 Level 1 (10 points)

    Thanks for reply, I am on the .private connecting VPN.

  • Gary Finch Level 1 (140 points)

    Hi,

     

    I also have the same issue. changeip -checkhostname returns ok so DNS is functioning correctly.

  • Cteam Level 1 (0 points)

    Have you checked the reverse DNS lookup for the server's IP?

     

    My server was changing it's name to match it's reverse DNS lookup... !

     

    To test, try running:

    nslookup <server's expected name>

     

    then

     

    nslookup <server's IP address>

     

    and check they both come back as expected.

  • Tho615 Level 1 (10 points)

    nslookup came back as expected.

     

    DNS all OK with matching name.

     

    I name the computer to osx-server and host name also osx-server to match.

    What the problem is after reboot server app alert keep saying host name change from osx-server to osx-server.domain.private

     

    I try doing a clean install of both ML and OSX server app and still same problem.

  • Cteam Level 1 (0 points)

    When you accept the alert, in my experience a wizard appears asking to set the type of network. I usually tell it that I'm using an internal network (middle option I think!) as opposed to a private network or internet network. Not sure if that will help ?

  • David Urban Level 1 (0 points)

    I had this same problem.  I would set the host name to mydomain server. then when I log out and log back in it would be changed to myFQDN$.  I figured it out it was because in profile manager I had set the toggle on the login module, Options, to "Set computer name to the record name".  Basically everytime I login to the machine it would change the name.

     

    HTH

     

    David

  • Tho615 Level 1 (10 points)

    Can you tell me where in profile manager is the toggle? I can't seem to find it. Or can you tell me step by step what you change to get it working?

  • Tho615 Level 1 (10 points)

    Finally got it working now. I delete and re-added my apple ID under System preferences -->User & Groups. I reboot/log off about 50 times now and no more alert of the hostname change.

  • ablyes Level 1 (0 points)

    delete and re-added my apple ID under System preferences -->User & Groups. I reboot/log off about 50 times now and no more alert of the hostname change.

     

    Hello,

     

    Your Solution (above) doest'n work on my OS X Server.

    What can i do ? Please i need your help.

     

    Thank you.

  • tcpudp Level 1 (20 points)

    This did not work for me either.

     

    Please can somebody give some help?

     

    Thanks!

  • rcsmac Level 1 (0 points)

    I tried deleting/re-adding the AppleID but it didn't solved the problem.

    Evertime the server boots, I get the alert of the hostname changed.

  • Tho615 Level 1 (10 points)

    I forgot another thing I did in server app. Go to Open Directory and click on the Locales tab, edit the Default locales and remove any servers name from the list. Give this a try. As of now I the alert message have not return for me.

Previous 1 2 3 Next