Previous 1 2 3 Next 43 Replies Latest reply: Jan 26, 2016 11:29 AM by LuckyKnuckle7 Go to original post
  • Eddie Yam Level 1 Level 1

    I think "expanion drive" is just a name, you may try to follow the command (with screenshot) in my first response in this post, and in the 2nd screenshot, you can find the full command list of "diskutil".


    Hope this help and let us know your result :)

  • lost9505 Level 1 Level 1

    Hey man look I'm sorry to ask but could you post step by step for me I have no idea what to do all I wanna be able to do is use the hdd again, thanks

  • Eddie Yam Level 1 Level 1

    1. Use the "diskutil" command to verify the UUID of the "Logical Volume Group (LVG)" of the locked partition.


    (without quote) "distil core storage list"


    2. Once you get the UUID, use the command to delete the LVG.


    (without quote) "diskutil corestoreate delete (the UUID you got in command 1 result)"

  • lost9505 Level 1 Level 1

    ok so im gonna post a picture of what came up when i tried your method i have no idea if what im doing is even close to what you said, im truy sorry fo rbegin such a pain but terminal is def not my thing. just tell me what to input in there with this new info and ill try it.harddrive.png

    alsoi have included the system information on the seagte external so if you could just gimmie something to cut and paste into terminal id reall appericate it.


    <S/N Image Edited By Host>

  • Eddie Yam Level 1 Level 1

    Sorry my typo, first command should be "disktil corestorage list" (without quotes)

  • lost9505 Level 1 Level 1


  • David Re Level 1 Level 1

    Great solution worked for me.  I thought I had a trashed disk on my hands.  Thanks very much!!

  • chocolotto Level 1 Level 1

    Thank you Eddie!! Your simple solution using the terminal to delete the locked partition solved my problem.


    I'm a complete Mac newbie but thought I'd try to do a clean install on my MBA but it went horribly wrong. I was following another website with instructions on how to do this. When I tried to erase my existing disk, which was already encrypted, I input my existing password and then chose a new password....but then some error flashed up when I tried to erase the disk.


    I cleared the error but then my disk disappeared! The SSD was still listed and verfying that said it was all OK. I tried everything to add it back but basically every option to erase/partition was grayed out/disabled.


    After a bit of panicking and taking my time to slowly go through every word on every screen I could possibly click on, I finally spotted the message "The partition contains a locked disk and can not be resized until it is unlocked" which lead me to this forum! Thank you again Eddie.


    Since I knew the existing password and gave it a new one (albeit the same password) I wonder why the error happened and I was presented with a locked disk. Or maybe it's not even related to encryption/FileVault? Oh well, at least I know the solution.

  • zorp Level 1 Level 1

    This is the best option, it is quick and it works.

    Eddie Yam wrote:


    I got the same problem with my external HDD (with 2 partitions) while I was using one of the encrypted partition as Time Machine backup. I could not erase it after I upgrade to Mountain Lion, and it shown "this patition contain a locked disk and can not be resized until it is unlocked" in Disk Utility.


    Finally I get it fixed by the "diskutil" command in "Terminal" in "OSX > Applications > Utilities".


    I used the command "diskutil" to verify the UUID of the "Logical Volume Group (LVG)" of the locked partition.

    Screen Shot 2012-08-03 at 11.04.04 AM.png

    Then use the command to delete the LVG.

    ** All logical volume under this groiup will be deleted!!

    Screen Shot 2012-08-03 at 11.05.15 AM.png


    Once the operation finished, I am able to recreate the partition in Disk Utility.


    Hope this help!!

  • Level 1 Level 1

    I hope this isn't a dumb question... but how do I get into disk util if I can't boot into the OS? I had the same problem as everyone else, deleted my partition (received an error) and now can't boot into the OS at all... I do the Command R thing at boot up, and select the Disk Utility - same error (the partition contains a locked disk......) - is there anyway I can launch a terminal session from there?? thx

  • Glue197 Level 1 Level 1

    Thank you Eddie, you helped me bring my external drive back to life too!

  • bwchism Level 1 Level 1

    Thanks Eddie, you saved a flash drive for me as well.

  • Sunzi Level 1 Level 1

    First off Eddie, Thank you very much for your posts. I have a 2011 Imac with a 256 SSD and a 2 TB HDD. While fooling around with boot camp and various other partions I made the mistake of not decrypting my HDD. I really made a mess of my HDD and couldn't partion it back to the way I had it.


    I can confirm the terminal commands given by Eddie do infact work on a second internal drive as well. Thanks to these terminal commands and Time machine my Imac is back to the way it was.

  • CocodynBob Level 1 Level 1

    This thread is a little old but I wanted to give a shout out and thanks to Eddie Yam.  Big help!  Thanks.

  • jdavid4it Level 1 Level 1

    Thanks for your post Eddie Yam! regarding how to delete a "write-protected LVG"

    It really helped me out since I had forgotten how to do it, and I was searching the web for the solution.