1 Reply Latest reply: Jul 31, 2012 3:34 PM by Demo
Callello Level 1 Level 1 (0 points)

I am trying to update my ipad 2 but it keeps telling me that it isn't eligible for the requested build how can i fix this problem


iPad 2, iOS 4.3.3