Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Import video to Aperture library on Mountain Lion

I was on OS X Lion and all worked perfectly, but when I've installed Mountaion lion and Aperture 3.3.2... It can't import any types of video files to Aperture library now.


When I go to File -> Import -> Files ... it shows me an empty folder (if there is video only) or photos:


User uploaded file


When I drag and drop any video file to Aperture icon, it says:


User uploaded file


So, if I import video file to iPhoto library and then open it in Aperture, it can't play video:


User uploaded file

User uploaded file


I've searched about this problem, but I couldn't find anything. I don't know where's my mistake. Maybe Aperture on Mountain Lion has bug?

MacBook Pro, OS X Mountain Lion

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Hallo in2om,


yesterday my problem was solved.

First I reinstalled (and updated) Aperture again, but this did not help.


Then I started from the recovery partition (cmd-r during start) and reinstalled Mountain Lion. No, you won't loose anything (but have a backup anyway!!). I did not have the Golden Master (as TheWrongStuff had), but the "normal" release fom the AppStore. But reinstallation helped anyway!

Now I am able to import again, and play my "old" movies, as it used to be!


Anyway, Apple is interested in my Aperture Library, I will send it to them on Monday. If they find out anything else, I will report here.


Just try to reinstall Mountain Lion, you can't do anything wrong doing this, I hope it works for you, too.


Have a nice weekend!

Posted on

Question marked as Helpful

Aug 8, 2012 1:41 AM in response to in2om In response to in2om

I have installed and run a host of applications and have not been able to break Aperture again.

The only apps I haven't tested from other posts are Chrome, AppCleaner and PS Elements.


I have resolved the issue for myself following the steps in my earlier post.

I will be sure to post the cause back if it breaks again but for now I'm sorted.


Note - this was a clean build - no import tools were used and all prefs were set up again from scratch.


Time for a fresh start 🙂.


Regards,

AJL.

There’s more to the conversation

Read all replies

Aug 1, 2012 4:46 AM in response to in2om In response to in2om

That is indeed not funny, but for me the import of all kinds of videos to Aperture works well. What is the type of videos you are trying to import?


Just to make sure - you have not by any chance accidentally excluded videos from import in the import settings? That section of the import settings is missing from your screenshot.


User uploaded file

Aug 1, 2012 4:46 AM

Reply Helpful

Aug 1, 2012 5:13 AM in response to in2om In response to in2om

Your pictures were showing like below, thanks for the second link. But what is the file type of your videos? mpeg, quicktime movies, AVI?

See the list of supported video formats: http://support.apple.com/kb/HT4025


This list is not exhaustive, Aperture may support more formats than listed below, but any codec mentioned clearly should be supported.


User uploaded file

Aug 1, 2012 5:13 AM

Reply Helpful

Aug 1, 2012 6:08 AM in response to in2om In response to in2om

It was .MOV from iPhone and .MP4 from Canon camera. Any ideas?


I cannot test with .MOV from iPhone, but .MOV from the iPod touch and Canon and all movies play well.


Have you installed any third party video codecs lately, like the 3ivx codec?


Can there be permissions problems with the folder you are importing from?

Aperture has been known, to not to be able to play video, if the library is in a shared folder.


I'd try to do some general Trouble Shooting Basics, repair the permissions of the Library, remove the preferences.

Aug 1, 2012 6:08 AM

Reply Helpful

Aug 1, 2012 6:39 AM in response to in2om In response to in2om

I have Perian (http://perian.softonic.de/mac) installed and Flip 4 Mac (http://flip4mac-wmv-windows-media-components-for-quicktime.softonic.de/mac), for better video compatibility with Windows media, but I think it is unlikely that missing codecs are your problem, if you could view the videos before.


I mentioned the codecs, because some third party codecs interfere and even may cause Aperture to crash, for example:

Aperture 3: May be unresponsive or have slower performance with third-party video codec

Aug 1, 2012 6:39 AM

Reply Helpful

Aug 1, 2012 12:10 PM in response to in2om In response to in2om

I do have exact the same problem as you, in2om!


Not only that I can't import videos from my Canon SX230 (.mov-files), which worked fine under the very same version of Aperture (3.3.2) under Lion, but also I can't play my old video, that is already in the library.


And the same thing here with iPhoto, I can import and playback here, even the old video!


BTW, I did remove that 3ivx-codec, but it did not help!

Aug 1, 2012 12:10 PM

Reply Helpful

Aug 2, 2012 2:11 AM in response to in2om In response to in2om

I reported this strange behavior to Apple, using the "Feedback" within Aperture.

They aked for a System Report and a movie-file, which I sent.


Now the only thing we can do is to wait. If they can solve the problem, I will report here!

Aug 2, 2012 2:11 AM

Reply Helpful

Aug 2, 2012 5:05 PM in response to in2om In response to in2om

I got the same problem

it couldn't be import any type of videos in Aperture


I use the same library file in Aperture and iPhoto, it's shared.

in iPhoto, I could import video and play it, works good.

but when I enter Aperture and use the same library which is video imported

the video shows, but the thumnail is corrupted, and video isn't playable.


i've tried clean install mountain lion

and after finished, I just install one software Aperture

at this time, Import video funtion works good.

but after I rebuilded my mac on this clean installtion

the problem's emerged.

Aug 2, 2012 5:05 PM

Reply Helpful

Aug 3, 2012 6:34 AM in response to lin qi-zhen In response to lin qi-zhen

Guys, let's write a list of applications that we have installed. Maybe so we can find an "unnecessary" application. I'll begin.


1Password

Adobe Photoshop CS6

Aperture

AppCleaner

Blackmagic Disk Speed Test

BreakTime

Cyberduck

Disk Drill

Dropbox

Dropbox

Firefox

iPhoto

Google Chrome

iWork '09

Opera

PhotoSweeper

Skitch

Skype

Spotify

TextExpander

Transmission

Twitter


I think the problem in an "unnecessary" app. Who has the same apps? 🙂

Aug 3, 2012 6:34 AM

Reply Helpful
User profile for user: in2om

Question: Import video to Aperture library on Mountain Lion