Previous 1 2 3 4 5 6 7 Next 99 Replies Latest reply: Aug 28, 2013 1:45 PM by jsnauman Go to original post Branched to a new discussion.
  • NOYBUS Level 1 Level 1

    FYI, if that file is missing problems with Aperature aren't the only side affect.  Just spent two hours trying to get AVI files to play using quicklook and turns out to be due to the same problem.  I recently restored from time machine and that file was missing.

  • in2om Level 1 Level 1

    After the last update it stopped importing again

     

    Can someone share com.apple.xpchelper.cache with me (and not just)?

  • AJL. Level 1 Level 1

    <Link Edited by Host>

  • in2om Level 1 Level 1

    Thanks for your quick reply.

     

    It just works!

  • Aye Es Oh Level 2 Level 2

    So was the com.apple.xpchelper.cache file missing entirely or was it somehow corrupted?

  • in2om Level 1 Level 1

    The file is missing entirely.

  • Aye Es Oh Level 2 Level 2

    Interesting... I wonder if some sort of cache cleaner app is responsible for this.

  • apeacefulguy Level 1 Level 1

    I think you nailed it man. Cheers to the coordinated effort! The dropbox file really saved me time!

  • ClimbrJohn Level 1 Level 1

    After a Time Machine restore I had the issue described by the OP.  I did not have a copy of com.apple.xpchelper.cache in my /System/Library/Caches/ folder.  I used the file posted by AJL. and after a reboot it immediately resolved the problem.  Thank you!  I can now import new videos into Aperture and view my previously imported videos.

     

    Some extra info: currently (and prior to the Time Machine restore) I am using OS X 10.8.2 and Aperture 3.4.3 (both the current versions).  I did a Time Machine restore from an AirPort Extreme with a USB HDD attached.  The restore seemed to work fine except for Aperture.  (I think I recall having to rebuild my Aperture library prior to its first use due to it not starting properly.)

  • aswick Level 1 Level 1

    Similar thing as ClimbrJohn happened to me:

     

    I upgraded my hard drive and was able to get a copy of com.apple.xpchelper.cache from the old hard drive.  File copy and reboot yielded similar results.

     

    OS X 10.8.2 and Aperture 3.4.3 (current versions).  I did a Time Machine restore from a Time Capsule.  The restore seemed to work fine except for Aperture.

  • Daviathon Level 1 Level 1

    AJL! You are the best!

     

    This is exactly the problem with my system. I have recently reinstalled OSX via Time Capsule Backup. Going to

     

    /System/Library/Caches

     

    com.apple.xpchelper.cache did not exist. Thanks to you again, I was able to get this file and once I rebooted, my .AVI, .MOV, and .MP4 videos were able to be played! The thumbnails were still all kinds of messed up, but easily fixed by recreating them.

     

    APPLE NEEDS TO READ THIS! This is important. It hasn't been fixed in over 6 months, it would appear. I'm sure I wasn't the only one aggrivated by this problem, and I am sure there are less Tech savvy people still suffering.

  • John Caradimas Level 1 Level 1
    expertise.serversenterprise
    Servers Enterprise

    OK, after being troubled for a couple of months with my Aperture not importing new and not playing old videos, and after following the advice about the xpchelper.cache file and being ready to re-install Mountain Lion, I got an epiphany, which apparently has solved the issue for me.

     

    What I did was to remove all the extended attributes from the files in my Pictures folder. I used the command

     

    xattr -cr Pictures

     

    And presto, functionality for videos returned to normal.

     

    It appears that the only folder I can't remove the extended attribute from is one of my vaults, which resides in the Pictures folder, but that doesn't seem to create any problem. From what I saw, at some point in time, arround May or June, an upgrade must have added extended attributes to several of my folders, including the Aperture library. I can tell when that happened because I file my picture per month, so all folders including the 2012_05 folder had the extended attribute, but not the 2012_06 folder.

     

    I can now enjoy my videos in Aperture!!!!!

  • nigelradestock Level 1 Level 1

    I have just done a Time Machine restore and found this problem too.

     

    Thank you to everyone who found out what has gone wrong and how to fix it, and a special thanks to AJL for hosting the missing com.apple.xpchelper.cache file.

  • gallai Level 1 Level 1

    Replacing the cache file worked for me! Thanks for figuring this out!

    com.apple.xpchelper.cache


  • Togart Level 1 Level 1

    Thank you so much - the cache file solved all my problem too