Previous 1 3 4 5 6 7 Next 99 Replies Latest reply: Aug 28, 2013 1:45 PM by jsnauman Go to original post Branched to a new discussion.
  • hare2608 Level 1 Level 1 (0 points)

    Thank you so much, I have had the the same problem with playing the movies in Aperture,


    once again thank you for the file ""


    greetings from Germany

  • korsonian Level 1 Level 1 (0 points)

    Thanks for the file! Got me going again after hard drive replacement and restore from time machine.

  • Mrakoplaš Level 1 Level 1 (0 points)

    I had the same problem after time machine restore, reinstall of ML helped, thanks!

  • OB1@PR Level 1 Level 1 (0 points)

    Thanks AJL...your a genius.  I had the same problem and the file was not present.  I added it and now vides are able to downloaded and played once again.  Did you figure out how this file was removed.  Like others, I did a restore after adding larger HD and found this issue after.

  • TheWrongStuff Level 1 Level 1 (5 points)

    I had this issue when doing a restore of a hard drive that failed using the WIFI based installaton and restore. I.e. start the machine, connect to a wifi network and start the restore process, then connect to a Time Machine to finish.


    I recently upgraded to a Macbook Air and connected both laptops together (FireWire with a Thunderbolt to Firewire adapter in the Air) and had no issues at all.


    This may mean that the issue is specifically related to a wifi install unless someone here can verify that they used another method to install ML.

  • Togart Level 1 Level 1 (0 points)

    No, it is definitly not a wifi related problem. I had this issue when I restored my system from a NAS which was connected via LAN - so I am pretty sure it is a TimeMaschine problem.

  • TheWrongStuff Level 1 Level 1 (5 points)

    Sorry, I think you misunderstood me. What I meant by a wifi restore is when you have a hard drive failure and insert a new hard drive, the new machine now prompt you to connect to wifi so it can create the initial restore process directly from Apple. It then downloads the install files and installs a copy of mountain lion without you having to insert a disk. (it also prompts you for the option to restore from Time Machine)


    The alternative to this is installing via USB which installs a fresh copy of Mountain Lion without having to download it (or if you have a new machine the software is already installed).


    So, my theory is that something is the wifi (internet) based restore process is broken but a fresh install seems to be fine.

  • Togart Level 1 Level 1 (0 points)

    Ah, ok, my fault, now it is clear to me. Thanks for the explanation.

  • John Caradimas Level 1 Level 1 (10 points)

    Further to my comment in my previous page, on this subject, I recently had to copy my Aperture Library to my Macbook, from the iMac it usually resides in. Of course, doing that meant that I had to relocate all the master files etc. but it also had the side-effect of my videos not showing again. I tried the xattr solution, I had applied on the iMac, but no good results. So I just restored the file, from the link supplied in this thread, and presto!


    Worked like a charm again.

  • Brisbane Lee Level 1 Level 1 (0 points)

    Well i have had EXACTLY the same since HD replacement under warranty which then was restored via TM .

    I have chased my local store many times in the several months since this to express the problem but have been told on many occasions it has been cuased by me and not this .

    I have been pulling my hair out in frustration and cant believe Apple have not even let loyal customer know of this BIG problem.


    Many thanks to AJL for resolving this . Is there a way to make TM back this up to ensure this does not happen again ??



  • AJL. Level 1 Level 1 (5 points)

    Hi Brisbane Lee,


    In short, I have not been able to get Time Machine to back up this file from its native location.


    The following command is supposed to let you specify files to back up, but I tested it and it doesn't work for me:

    sudo tmutil removeexclusion /System/Library/Caches/


    Interestingly enough, the /System/Library/Caches location does get backed up, just not the contents.


    I have chosen to copy the file to /System/Library/XPCServices which does get backed up (IMHO this is where the system should reference the file from anyway - and if I can figure out how to do that then I'll let you all know - Apple can send me a pay slip ).


    The cause of my issue was some commands I run to clean up my system, part of which was flushing this location. So now I have added a few lines to copy the file back after cleaning the caches. I don't know why the file is being removed for other people, but I suspect maintenance apps could be involved given it is a cache directory.




  • Togart Level 1 Level 1 (0 points)

    Before this issue, I had said cache files can not lead to these kind of problems, because if they are corrupted or missing at all, the system will normally rebuild them. So IMHO it is a really strange problem. I am a liitle disappointed and surprised too, that Apple does not do anything to fix this issue - as far as I know.




  • Kay Fisher Level 1 Level 1 (0 points)

    I can import .mov files and play them fine on my iMac but not on my Macbook Pro.

    Neither machine had the /System/Library/Caches/ file on it.

    I downloaded from the drop box as per several replys ago and rebooted - no help.

    Because my iMac Aperture works fine without this file I think the problem is unrelated to the missing cache file but admittedly for most of you that seems to fix (or nudge) the problem.



    Kay Fisher

  • andyBall_uk Level 7 Level 7 (20,490 points)

    slightly OT, since I don't have Aperture to play with, but

    sudo /usr/libexec/xpchelper --rebuild-cache

    also replaces the 'missing' file


    I did check quicklook-playing an (xvid via perian) avi file, which is another reported problem solved by restoring the file - sure enough, it would not display, with repeated log messages :[202]: Failed to communicate with qtkitserver: Connection invalid[202]: Failed to initializeServer(), returned 5


    restoring the cache using xpchelper, & rebooting, seemingly allowed quicklook to work again as expected.

  • pietp Level 1 Level 1 (0 points)

    Thanks very much for helping out with this problem.

    After installing the Cache file from a other Mac with Aperture all is fine for me again, can import video from iPhone and all, and can play the video's again in Aperture.


    The problem on my system was caused bu cleaning (system) cache using IceClean, so that's one clean action I will skip in the future


    Thanks again to everybody who contributed to this issue, my Aperture is doing well again



Previous 1 3 4 5 6 7 Next