Previous 1 3 4 5 6 7 Next 99 Replies Latest reply: Aug 28, 2013 1:45 PM by jsnauman Go to original post Branched to a new discussion.
  • pietp Level 1 (0 points)

    One more remark to this issue on my system.

    Before re-installing the cache file in Finder scrolling thru video directories the preview/content wasn't showed at all, just the circle turning and turning, now I have a picture from the movie agian

    So, this is also repaired with the install of the cache file, and not only the Aperture problem with video's

    Just for information, perhaps it' s helpfull



  • mxast7 Level 1 (0 points)

    Hi Ajl,


    I ran into the same problem not being able to import videos into aperture. If possible could you also please provide me with ? It would be a great help.


    Thank you

  • léonie Level 10 (85,375 points)

    If you really want to restore the xpchelper.cache instead of reinstalling, use the Terminal command that andyBall_uk posted in this thread - you do not need to download a file.


    Re: Import video to Aperture library on Mountain Lion


    But reinstalling the system would be safer;  restoring the Cache will mitigate the symptoms, but not fix the source of the problem. You must have installed something, that requires that this Cache file is necessary, and this should not be the case.

  • Jeffrey Young Level 1 (0 points)

    Restoring the missing cache file /System/Library/Cache/ using andyBall_uk's terminal command (Re: Import video to Aperture library on Mountain Lion) and then a reboot enabled quicklook to play AVI files on my mac again. 


    Can somone enlighten us as to what this file does and also the xpchelper command used to restore this file ?

    I replaced the hard drive in my Mac a while ago and quicklook played AVI files just fine after that.  Then just the other day I was looking at the same and newer AVI files created by my secuirity camera and noticed that the quickllook preview and thumbnails where not being computed.

    I can't pinpoint exacty what applications were installed/removed/updated on my mac before this occured.

  • léonie Level 10 (85,375 points)

    If you open a Terminal and type the command "man xpchelper" you will see the following manual entry:



         xpchelper -- XPC helper agent








         xpchelper performs services on behalf of the XPC IPC facility.



         This command is not intended to be invoked directly.

    This command is run, when Mt. Lion is installed, and is only to be run by system services, not directly!


    The xpchelper cache is used by the xpcd daemon for XPC services, which undocumented. The file is in a property list format and contains entries for a variety of standard applications;

    I tested what happens, when I remove the file. On none of my macs (two iMacs, three MBPs with different Intel processors) the removal if this file did cause any problems. Videos were playing well. Which makes me assume, that a healthy system should be able to run without this file in its cache. And if this is not the case, something must have been installed, that is corrupting the system library, so that Aperture has problems without this cached file.

    That is why I am worried, that simply restoring the xpchelper file will only obscure one of the symptoms of the problem and not heal the problem with the system installation, so you may run into the same problem again later.

    Reinstalling the system will be a safer solution in this case, even if it is much more trouble. It should suffice to reinstall on top of the current system - no clean install necessary. A clean install would defeat the purpose, because you would have to reinstall all your apps afterwards and probably reintroduce the very same problem by reinstalling the app that is causing all this.




  • AJL. Level 1 (5 points)

    In my case the file needs to be present for video to function, no application was causing this.

    I tested a full clean Install of 10.8.2 and install of Aperture only. After removing the cache file and rebooting, the video breaks immediately for me.


    This issue was actually causing me to lose footage.

    Apple needs to fix this, it's not good enough. All I presented was a quick fix to help people - andyBall_uk has taken it to another level discovering you can just rebuild the file (genius).


    Until Apple rectify this flaw, the decision to reinstall the entire OS as a way to run the command vs. simply running the command is discretionary I guess.


    I know what I would choose (big thanks andyBall_uk)!!!

  • léonie Level 10 (85,375 points)


    I have read your post and the whole thread - and I am impressed by what you found out and it helped many people here, and I like Andy's solution on how to restore the missing helper file using a terminal command.


    But for me it is clear that the missing xcphelper file cannot be the primary reason of the problem with your videos. It is more so, that it is the final straw that tumbles an otherwise already broken system. As I said, on none of my five macs removing this file caused a similar problem with videos. I also asked other frequent posters here to check this out, and none of them could confirm on their systems that removing this file will cause the videos to break. xpchelper is used for all kinds of other apps, and all are working. One of your system frameworks must be working differently from mine. And for me the big question is, what application or utility installation caused the exchange of a library framework, so that all of a sudden this cached file is neaded to be present on some systems. It must be a multimedia app or driver, since only videos are problematic. It occasionally happens, that installing some third party application will replace a dynamic library by an older version that is incompatible with your the current system, and then all of of a sudden completely other applications will crash or have problems, see for example Aperture and Final Cut 4.


    My only concern is that by adding this file you will be patching a broken part of your system instead of replacing it by a working one. Restoring the broken part to its original version will require reinstalling - and it is not such a big issue, since you can install on top of the old system.


    Until Apple rectify this flaw

    It is very unlikely that this is a flaw caused by Apple, unless you can confirm that you are not running any piece of software on your mac that has not been created by Apple, and that each and every part of your software has been updated and is specified to be compatible with your current MacOS X version.




  • andyBall_uk Level 7 (20,490 points)

    >> I also asked other frequent posters here to check this out, and none of them could confirm on their systems that removing this file will cause the videos to break


    I mentioned here & in the lounge thread that quicklook of avi video failed


    >>did check quicklook-playing an (xvid via perian) avi file, which is another reported problem solved by restoring the file - sure enough, it would not display, with repeated log messages :[202]: Failed to communicate with qtkitserver: Connection invalid[202]: Failed to initializeServer(), returned 5


    restoring the cache using xpchelper, & rebooting, seemingly allowed quicklook to work again as expected.


    I can't explain why yours works w/o the file, although it's been suggested that only some formats show up the problem. Reinstalling OS X (in logs here, anyway) runs much the same  terminal command & moves the created file into place - maybe your & other logs will show if that just doesn't happen, or if it's removed later.

  • léonie Level 10 (85,375 points)

    Thanks for chiming in, Andy. I did not know how to reference your post in the Lounge.


    Quicklook works fine on all my macs, with or without xcphelper, also for all AVI files I tested. But can you post a link to a video that does not play on your system without the cached file, so I can check that on my Mac?

  • John Caradimas Level 1 (10 points)

    It may sound stupid, but have you rebooted your machine(s) after removing the file in question? It seems that the system check for the file when booted, from then on, if the file is there, videos work, if not, they do not work.

  • andyBall_uk Level 7 (20,490 points)



    I used the first one I saw, sitting on another desktop - it happened to be a 750MB avi

    mpeg-4 xvid , no idea if that's significant. So no link, sorry. If I check more & find one, will post again.

  • léonie Level 10 (85,375 points)

    It may sound stupid, but have you rebooted your machine(s) after removing the file in question?

    Good idea, John. Yes, sure I did reboot. I even checked my backups. On one of my Mac Book Pros seems to never have been an instance of xcphelper since more than a year, and still videos are working well in Aperture.

  • léonie Level 10 (85,375 points)

    Andy, thanks a lot.

    Meanwhile I found two .AVIs that are hanging, when I try to preview them without xpchelper. But both of them are using Microsoft mp4 codecs and would not even play, if I had not flip4mac installed, and that is not Apple standard software. What do you have installed, to make AVIs play?

  • John Caradimas Level 1 (10 points)

    LeonieDF, it was just a thought.

  • léonie Level 10 (85,375 points)

    it was just a thought.

    That's what I thought!

Previous 1 3 4 5 6 7 Next