Previous 1 3 4 5 6 7 Next 99 Replies Latest reply: Aug 28, 2013 1:45 PM by jsnauman Go to original post Branched to a new discussion.
  • andyBall_uk Level 7 Level 7 (20,495 points)

    >>did check quicklook-playing an (xvid via perian) avi file, which is another reported problem solved by restoring the file - sure enough, it would not display,

  • léonie Level 9 Level 9 (63,915 points)
    (xvid via perian) avi file


    I have disabled Perian, because it installs the 3ivx codec, which can be causing Aperture to crash or hang.

    I'll try perian later; I have two avis, that need Perian. But if perian does not work without a cached file installed, it is a bug in Perian - after all, a Cache is a temporary storage, that an application should not rely on to be filled.

  • andyBall_uk Level 7 Level 7 (20,495 points)

    a 'bug' in more than Perian, if you believe that missing files should never upset an app or codec...


    I tested a .mov file, after removing Perian & restarting, it also fails to 'quicklook' with similar errors

    it's from a camera, with mono sound, but has always played w/o any special codecs afaik, and still plays in Quicktime w/o Perian


    MPEG-4 video (mp4v)

    PCM-MU-LAW (ulaw)


    again, rebuilding the cache & restarting seemingly allows it to quicklook as expected. I'll test with a clean install of 10.8.2 sometime, but it's not Perian related here. So, not all movies, but some  - the few mp4's I checked were fine, as you found.

  • andyBall_uk Level 7 Level 7 (20,495 points)

    sorry, still off-topic regarding Aperture, but

    same .mov video, new install of 10.8.2 after erase, no files/settings migrated except the video

    quicklook worked normally... removed xpc cache, restarted, no quicklook... rebuilt cache, restarted, works again.

  • Clarknet Level 1 Level 1 (5 points)

    So I just had this bug. Very odd, same as everyone else. Aperture used to import video then stopped. I had installed Free Flip4Mac a couple weeks ago. This is the first time I used Aperture since.


    Found this thread. Deleted Flip 4 Mac. Restarted with cmd-r. Reinstalled Mountain Lion.


    Fixed! How weird. Thanks everyone!

  • simonfromteddington Level 1 Level 1 (0 points)

    Just like to re-iterate...


    I hade this problem also, it wasn't due to any recently installed software; it happened after having a hard disk fault and having restored from Time machine back-up.  As previously described all videos looked corrupted and won't play or even import anymore. 


    The command line fix (using xpchelper worked perfectly) - nice one Andrew.

    As a software dev I can say that im very confident that the video issue was not directly caused by the initial HD corruption i suffered (my first thought); it was a side effect of the full restore.

    The fact that all my videos that were corrupted across a number of years of writing to different parts of the main disk, this issue just would not be manifesting itself as showing this kind of corruption.


    In short, I trust that the command line fix was all that was needed.

    And also that an apple fix is sorely needed for that!

  • jsnauman Level 1 Level 1 (0 points)

    Can this file be reposted? I see the link is gone. My Time Machine does not seem to have it either. I am having this problem now with Aperture 3.4.5. Anytime I load a card with video on it the Loading Assets wheel spins on and on. I have to copy the movie files off the card using finder and then delete them from the card for aperture to final load it. I do not like having to store my videos seperately!




  • jsnauman Level 1 Level 1 (0 points)

    Thank you Nigel. They deleted your reply again but I got it in my email. Appreciate the response!!! Thanks so much!!!

  • nigelradestock Level 1 Level 1 (20 points)

    I don't know why they deleted it the second time as I explained what it was and why I was posting the link!


    Anyway glad you managed to get the link and download it.

  • jsnauman Level 1 Level 1 (0 points)

    Didn't work for me afterall. Stuck loading assets for over an hour.

Previous 1 3 4 5 6 7 Next