Previous 1 2 Next 19 Replies Latest reply: Jan 23, 2013 11:58 AM by Emiliotdf
Branden Williams Level 1 Level 1

Folks, wanted to recap this as I am finding the problem much more broad than my original post (here: https://discussions.apple.com/message/19123146#19123146). Here's my setup:

 

  • MacBook Air 13", Mid 2011
  • Mountain Lion
  • Wifi Problems, cannot connect to open wi-fi and Sprint hot spot.
  • CAN connect to Time Capsule (at least I could before I started futzing with my setup while on the road)

 

here's what I've done so far:

  • Reset SMC
  • Zapped PRAM
  • Reduced MTU to 1300
  • Set hotspot to 802.11g only
  • Set IPv6 to Local-link only
  • Set up a new user account, no connection there either
  • Repair disk
  • Repair disk permissions
  • Removed WiFi in networking control panel and re-add.
  • Remove the network from control panel AND remove keys from Keychain

 

What I have not done but will try later:

  • Reinstall ML
  • Disable WMM

 

Observations:

  • ML seems to think there is a connection to the wi-fi, but it can never get an IP address
  • Using a static IP on the network doesn't help the problem
  • My hotspot never really registers the MBA as a connection

MacBook Air, OS X Mountain Lion
Solved by Branden Williams on Aug 1, 2012 5:26 PM Solved

OK, the only thing that has solved my issue is a fresh ML install from the rescue partition. I used my wired connection for the install just in case something was horky with the Wifi.

 

Your mileage may vary!

Reply by Branden Williams on Aug 2, 2012 1:07 PM Helpful

Here's a great list of other ideas from OS X Daily Tips.

All replies

  • Branden Williams Level 1 Level 1

    OK update, disabling WMM queueing did not solve the issue, nor did running Network Diagnostics (found that in another post).

  • Branden Williams Level 1 Level 1

    I've also sent in a PCAP of what happens to apple.  Hopefully this will help them fix.

  • tsprice Level 1 Level 1

    I have the same issue on my new MBA.  I read on a post here that one guy unchecked the ituneshelper in the Login Items, so I tried that cause who needs it anyway and I have been been stable so far.  Its worth a try.  Good luck.

  • Branden Williams Level 1 Level 1

    Not me. I disabled that ages ago for different reasons.

     

    Another update, got to the house, NOTHING is working network wise. Wired via USB adapter, home WiFi, nothing. Off to reinstall.

  • Branden Williams Level 1 Level 1

    OK, the only thing that has solved my issue is a fresh ML install from the rescue partition. I used my wired connection for the install just in case something was horky with the Wifi.

     

    Your mileage may vary!

  • tsprice Level 1 Level 1

    I really wish Apple would come out and admit that they have a problem and to fix it users need to do a clean install, I guess I'm going try this since my wifi problem persists, ugh.  Thanks

  • Branden Williams Level 1 Level 1

    Here's a great list of other ideas from OS X Daily Tips.

  • tsprice Level 1 Level 1

    Wow, the steps from that link have really helped!  Thanks

  • MariusRime Level 1 Level 1

    Same here. Macbook Air 13", purchased a fewm months ago, stopped connecting to the internet after update to Mountain Lion. Will try a few tips given here before taking it to back the store.

  • Branden Williams Level 1 Level 1

    FYI, I am hosed again. Things were working fine and now they are no longer working. I'm going to head to the Genius bar tomorrow PM, will update here if anything comes of it.

  • MariusRime Level 1 Level 1

    Tell you what worked for me .. finally.

    Had two Apple technicians on the case - over the phone. Have to say, those guys are awesome! - with patience of saints! But to the point! As there was nothing obviously wrong with operating system, they promised to call me back the following day but suggested talking to my Internet Service Provider about the router (D-Link router). The ISP remoted to my iMac and logged into router site and changed channel selection from automatic to manual. He chose channel 13, and suddenly my MBA connected and has been connecting smoothly ever since. The reasons I had problems was that there was over 10 available wi-fi networks in my flat, some of which showed as having stronger signal than my own. The ISP guy told me this, increasingly, becomes and issue, especially in blocks of flats - the ether is  filled with wi-fi networks to the point of saturation. He also said, his choice of channel 13 was just a fluke and it might turn out I'd have to change it again. 

     

    So, although the problem is now solved, there still remains this one nagging question: Why did the wi-fi connectivity zonked right after Mountain Lion upgrade?

  • Branden Williams Level 1 Level 1

    Ahh, gotcha. In my case, this would be going to say a hotel, or coffee shop, or even airport where I don't have the ability to change the channel. I can see the channel selections, but I'm wondering if this is where the root of the problem is. Wi-Fi channel selection stuff.

  • Branden Williams Level 1 Level 1

    OK, I saw a genius today. As it turns out, the problem was caused by a third party security add in (Hands Off!). It needed to be reinstalled and all the rules blown away. So far, I am stable again. Thanks to all with suggestions!

  • kegger Level 1 Level 1

    My problem was corrected (for 2 days now) when I followed Brandon's OSX daily tips and changed the MTU setting to manual and 1453... will keep you posted. Thanks for the head's up, Brandon!

Previous 1 2 Next