Previous 1 2 3 4 5 6 Next 75 Replies Latest reply: Aug 28, 2015 11:28 PM by John de Graaff Go to original post
  • cretino Level 1 Level 1 (0 points)

    Same problem!!

    I try to remove all .ics files from ~/Library/Mail Downloads/,  but I use OS X 10.9 (yes, several years later, we are bstill talking about the same bug... thanks Apple!) and the ~/Library/Mail Downloads/ don't have any .ics files. I deleated any thing in that folder anyway... but didn't solve the problem.

    I talked to Apple support and they were not aware of the issue...!!!!!! Whaaaaaat!

  • ImJester Level 1 Level 1 (0 points)

    I believe I have solved everyone's problem with this...assuming that people still have the problem.   Anyway, the problem is that the appointment in the ICS file is outside of the Day Starts Time and Day Ends Time.   If you modify those times in your preferences to include 24 hours or a reasonable time, you should be able to double-click the ics file or drag it to your calendar successfully.

  • mutatron Level 1 Level 1 (0 points)

    Nope, that did not solve it for me. Actually, I'm not even sure what you're talking about, but I changed my preferences to 24 hour time, and it didn't fix it.

     

    This is a .ics file my daughter got from her place of work, her residency schedule for the whole year. I've looked at it using TextWrangler, and can read the dates from that. iOS 7 kind of reads it, but it misses a lot of the information that's in the file. Somehow my daughter can read it, probably because she doesn't keep her MacBook up to date.

     

    From reading this thread, I suspect with each update, Apple makes .ics files more and more difficult to read. The developers come to this thread to find out which hole to close next. As a developer, just looking at the format of the file, it seems simple enough that I could write something that would read and format it into a calendar for me. Thanks, Apple!

  • mutatron Level 1 Level 1 (0 points)

    I found out how to do this. Log into your Google account on Chrome. Click on the icon with nine squares, and select Calendar. Since this was my daughter's work schedule, I clicked on the down arrow next to My Calendars and created a new calendar. Then I clicked on the down arrow next to Other Calendars, selected Import Calendar, selected the .ics file using the Choose File button, selected the target calendar, clicked Import, et voila! Now I have my daughter's schedule available to me on my Mac as well as my PC, my iPhone, and my iPad.

     

    BAM!

  • zeugmatis Level 1 Level 1 (0 points)

    Same here, Mavericks but been this way for a while.  Click .ics attachment, iCal opens and does... nothing.  Opening the attachment in a text editor, it very clearly had "STATUS: CANCELLED" so this was a cancellation.  Tested with another cancellation - same result.  Maybe this particular field isn't part of the spec?   But it would sure be nice if someone at Apple could take five minutes to add some code to parse that field and at least provide a popup box or something notifying it was a cancellation; doing absolutely nothing is terribly unintuitive and unsettling to the user.

  • phil9014 Level 1 Level 1 (0 points)

    For me the problem seems to have been that the .ics file I was trying to import was set as VERSION: 1.0.  I noticed that imports that DID work were VERSION: 2.0.  So, I edited the content of the ics file to read version 2.0 and it imported properly.

  • timrb84 Level 1 Level 1 (0 points)

    Try looking at this thread. It looks like Apple removed some support for Sync services (that Outlook needs) to move to different methods.

     

    outlook calendar sync with Ical mavericks, outlook calendar sync with Ical maverik

  • spod_dmd Level 1 Level 1 (0 points)

    Thanks for this simple solution, this worked for me. meeting.ics files emailed to me from a client using Outlook never used to change anything in my iCal which was really frustrating. Changing to open the file type with calendar.app worked a treat.

  • Phil 1960 Level 1 Level 1 (0 points)

    Phil,

     

    I tried every fix in this thread, nothing worked. Then I tried your fix. Editing the version to 2.0 worked !!!

     

    How do we get your post moved to the top to save everyone else wasted time?

     

    Thanks
    Phil.

  • fastasleep Level 1 Level 1 (10 points)

    I had a similar problem and think I just solved it!

     

    - Go to Mail > Preferences and switch "Add Invitiations to Calendar" to Never and close the Preferences window.

    - Go again to Mail > Preferences and switch "Add Invitiations to Calendar" to Always and close the Preferences window.

     

    Previously Google Calendar invites coming in email weren't getting added, and manually clicking them would just put focus on Calendar but nothing would happen. After doing the above, I can now click on invite.ics and they'll appear in Calendar, and just forwarded myself a couple emails with invites attached and they're showing up in the Calendar inbox icon. Back to normal!

  • fastasleep Level 1 Level 1 (10 points)

    Well, this seemed to work but now I think it was a coincidence. I found another thread below where someone had figured it was if there were non-alphabetical characters in the Location field. I checked, and the one I couldn't open today had a dash in the location. Removed that with a text editor, saved it, and it worked! Sender was Outlook, so not sure which ics creators are a factor. This did not seem to be a problem when creating an ics in Calendar with a dash in the location field, as I could reopen those just fine. Go figure...

     

    iCal not accepting windows ".ics" invitations since enabling iCloud..

  • Shandly Level 1 Level 1 (0 points)

    Hi i have opened .ics in outlook and it said start time was after finish time thus failed. in ical

  • JohnnyDeLuxe Level 1 Level 1 (0 points)

    Hi Shandy - and others here,

     

    I had this issues from time to time, and solved the issue with the fix suggested here, changing the version from 1.0 to 2.0 before.

     

    But today, it happened again, on my rather new iMac with the new beta Yosemite installed on a fresh formatted HD.

    The calendar invitation could be clicked on, but I could not se the invitation in my Mac Calendar!

     

    When opening the ics file (cmd + i) I noticed that the "Open with" was set to "CalandarFileHandler" - but I could also select (use drop down menu window) to set it to "Calendar". So I changed the setting to Open With "Calendar (default)" and selected "Change all".

     

    That did the trick for me. I assume that the ics for some reason was set to import to the Outlook/MS calendar that comes with the Office package I use for Word.

    So, for those who has installed MS products this might be a possible thing to look out for.

  • AlanB_is_me Level 1 Level 1 (0 points)

    Hi Shandly,

     

    I have been seeing this as well. Turns out that there is an error in the .ics files I was trying to load, where the application that created the .ics files only used a single hour digit to define a time before 10am. From the looks of the ical v2 specification, all times should use 2 digit hours - i.e. they should put a leading 0 for those early times.

     

    Looks like iCal misinterprets the start/end time if there is only a single digit for the hour (in the fields DTSTART and DTEND in the .ics file). Explains why sometimes it would work and sometimes it would be ignored (and put an error in the Apple System Log) and sometimes it would go into a totally different day (as it adds 80+ hours to today's date!) This could look even more weird if the times are in UTC format and your timezone is totally different.

     

    I don't think this is necessarily an iCal bug but it would be helpful if it properly checked field lengths and gave an appropriate error in the log. I also see a small window flash on the screen and disappear again very quickly each time I tried to load a file with this error in it. Again, if iCal thinks there is an error, why not give me a message I can read and clear manually?

     

    Anyway, editing the file manually (in TextEdit) and adding a leading 0 to the relevant time fields allows the files to be imported correctly. Oh - and a good way of quickly seeing whether the .ics file is valid is to look at it with the inspector (cmd-i). If it is OK, the calendar icon will show the right day and times. If it is not a good file, the icon will just show an empty grid.

  • Falcobuzz Level 1 Level 1 (0 points)

    Hi

     

    I couldn't import ics invitation received by email (in Mail). When I clicked on the ics invitation iCal was opening buy the ics invitation didn't appear.

    Reading a few post I realized I could drag the ics invitation from from to iCal and then the invitation appeared into the "Waiting to confirm box" - on the right of the calendar button. By default is tried to sync using the "on my mac" account.

     

    ANSWER:

     

    I wasn't using this account, so I DELETED all my "on my mac" calendars and iCloud calendar is my default. From now on all my ics invitation are imported into iCal AND they sync flawlessly to my other device (iPhone 5 and iPad 4).

     

    MacBook Pro (Retina, Mid 2012)