Previous 1 2 Next 21 Replies Latest reply: Jan 12, 2014 9:18 AM by IH456
J. Ackermann Level 1 (0 points)



I'm running a 2012 iMac Intel with the new Mac OS X 10.8, and everything runs just fine and smooth with the new iMac Intel..


But since the upgrade to OS X 10.8 from OS X 10.7 Lion, our older client iMac's that still run on OS X Tiger 10.4.11

can't find the network printer anymore, which was no problem while still running OS X Lion on the host iMac.


The client network is connected to the host through Airport Extreme.


Any hints and clues about how to get rid of that problem are very much welcome, thanks in advance.



iMac, Mac OS X (10.7.3), thanks for any useful hint, j.a.
  • J. Ackermann Level 1 (0 points)

    Completing my own question:


    The mentioned problem concerns not only the printserver at the client iMac's that run on OS X10.4.11, but file sharing in general is no longer possible between Tiger and Mountain Lion. The iMac's that run with Tiger can't detect the host Mac that runs on 10.8 at all, but the opposite way it still works, Mountain Lion allows to access all client Mac's that run on Tiger.


    So there must be a bug within the server- and filesharing functions between the 2 different OS, and I have no idea how to eventually solve this ugly problem ....

  • pengtao Level 2 (280 points)

    What is your printer model?  Where and how do you connect the printer to?

  • J. Ackermann Level 1 (0 points)

    Hi pengtao,


    the printer model is a hp lasercolorjet 5550. It is connected through usb to the new intel iMac with os x 10.8, and on this mac the printer works fine, no problems so far. The network of the older client iMac's that still run on os x 10.4.11 is connected to the host mac through airport extreme, and printer sharing is set active in the airport configuration.


    Internet access works fine for the client mac's too, but they can't detect the host mac server anymore, and the printer doesen't shows up in the printer menu, so I can't add it. Btw, the latest hp printer software is installed on the client iMac's too, but it doesn't help neither.


    Why does the os x 10.8 can connect to the client mac's - all the hd's and files from the old imac's are mounting and are accessible, but vice-versa it doesn't works? When clicking on the server icon on a iMac that runs on os x 10.4.11, it never shows me the intel mac hd, but only the client hd.


    For now we can print only by file transfer to the host mac, which is still better than nothing ...


    I hope this info is useful to approach the source of the problem, thanks in advance for the appreciated help.

  • matrix12x Level 1 (0 points)

    I am having exactly the same issues.

    My printer is on my iMac 10.8

    I am trying to print from my powerbook 10.4.11

  • Mark Steele2 Level 1 (90 points)

    I'm having the same problem with an HP 1320 connected to a Mac Pro running 10.8 and an older G4 iMac running 10.4.11 that cannot see the shared printer.


    I've got some work arounds involving print to PDF and shared folders that I could probably hook up with a folder action, but I'd rather not have to do that.

  • Matt Broughton Level 5 (4,980 points)

    I experimented with this a bit today and was not able to print from a couple of older G3s running OS X 10.4.11 to a printer shared on a 10.8.1 machine.  I was able to print from that G3 running OS X 10.3.x to the printer on OS X 10.8.1.


    The only thing I turned up in the logs came from the OS X 10.4.11 machine where the CUPS error_log showed--

    D [05/Sep/2012:14:47:42 -0500] AcceptClient: 11 from localhost:0.

    D [05/Sep/2012:14:47:42 -0500] ReadClient: 11 POST / HTTP/1.1

    E [05/Sep/2012:14:47:42 -0500] get_printer_attrs: resource name '/printers/ ' no good!

    D [05/Sep/2012:14:47:42 -0500] Sending error: client-error-not-found

    D [05/Sep/2012:14:47:42 -0500] ProcessIPPRequest: 11 status_code=406

    D [05/Sep/2012:14:47:42 -0500] ReadClient: 11 POST / HTTP/1.1

    E [05/Sep/2012:14:47:42 -0500] get_printer_attrs: resource name '/printers/ ' no good!

    D [05/Sep/2012:14:47:42 -0500] Sending error: client-error-not-found

    D [05/Sep/2012:14:47:42 -0500] ProcessIPPRequest: 11 status_code=406

    D [05/Sep/2012:14:47:43 -0500] ReadClient: 11 POST / HTTP/1.1

    E [05/Sep/2012:14:47:43 -0500] get_printer_attrs: resource name '/printers/ ' no good!

    D [05/Sep/2012:14:47:43 -0500] Sending error: client-error-not-found

    D [05/Sep/2012:14:47:43 -0500] ProcessIPPRequest: 11 status_code=406


    I would suggest that all that have this problem submit a report to Apple using their feedback page or via radar if you have a developer's account.

  • IL mac Level 1 (0 points)

    This may seem silly but it resolved my problem. I have a 2008 iMac with a Canon printer plugged in and I was able to wirelessly print from a 2012 MBP when both were on Lion with print sharing. After both were upgraded to Mountain Lion, the MBP stopped finding the Canon and I got the same error messages that others were posting on various discussion threads. Then today I realized that one of my iphone/ipad apps stopped talking to the iMac and the solution I used before was to reboot my Netgear router. As soon as the router was rebooted, the mobile app found the iMac again and sure enough the MBP found the Canon.


    I wouldn't have thought the router was the problem had I not had the mobile app problem before because all this time all my wireless devices had perfect internet connection. But again this is my unique situation. I just want to throw this out in case someone want to give it a shot.

  • JayKayborg Level 1 (0 points)

    Well Shoot!  I thought you were on to something IL mac, but it didn't work for me. I'm having the same problem as above-- upgraded my desktop to Mountain Lion, and now my G4 iBook doesn't even know that there are printers on the network!  It's running 10.4.11--- same issue as a couple other folks. 


    What is interesting is when I go into the System preferences---> Print & Fax, and try to Add a New Printer, their is a flash of the printers that lasts for nanosecond, and then they are gone. . . . not sure why they become invisible, but I've tried downloading new drivers, etc.  It's clearly some sort of networking issue.  But it's beyond me . . .

  • IL mac Level 1 (0 points)

    I was doing a bit more research and found that this might be a bonjour home sharing problem. Not sure if the problem is OS or hardware (router). The behavior seems to be consistent with what others described when they have the bonjour sharing dropped. I found a suggestion on using the discovery bonjour browser on iPhone to monitor the sharing status. At least the one time I noticed the print sharing was gone, the app also showed all the sharing services disappeared. Again, once the router was rebooted, all the sharing services reappeared on the iPhone app and the shared printer was also back.


    My root problem maybe entirely different than yours but they manifest in similar behavior. For now I just keep restarting the router, just not too often hopefully.

  • wyldbill Level 1 (0 points)

    I have posted about similar issues 2x now.....this is the 3rd.  Leopard and Snow Leopard were fine in printing to a Windows networked or Mac networked printer.  Now I cannot print anywhere from Mountain Lion to a printer on my network.  ONLY Direct USB connected printers.


    Apple Really needs to get this FIXED ASAP!!!

  • wyldbill Level 1 (0 points)

    Just got off phone with Apple support in relation to my specific issue.  The mac with Mountain Lion just wont print to the Brother printer on windows it seems.

    Mountain Lion will not print to 10.6.x Snow Leopard.

    Snow Leopard 10.6.x CAN PRINT to 10.8.1 Mt Lion......

    10.8.1 can print to 10.8.1 shared printer as well on a macbook with mountain lion.


    These are all specifically Brother brand laser printers using CUPS and simple printer sharing thru the Print/Scan control panel.


    My life got easier anyway.....Was told as a better solution to have a wireless or wired networkable printer.

  • joekewe Level 1 (0 points)

    Same problem here. Remote printer sharing from my old Tiger 10.4.11 machine stopped working the day I installed Mountain Lion.  I just updated the printer drivers on both machines and the printer's firmware without success.  I also rebooted my Airport as "IL mac" reported working above, but it did not work for me.  Fortunately, I have an Airport Extreme and was able to plug the printer into it.  Now the old G4 laptop running Tiger can see it again.


    As others have mentioned in this thread, my Tiger machine could often "see" the remote printer shared on the Mountain Lion iMac for a split-second before it disappeared from the Add Printer dialog box.  This makes it seem like a bug rather than intentional obsolescence by Apple.  I hope it can be fixed for the sake of all the machines still running the older operating system.  If not, then Apple needs to give a huge warning to people installing Mountain Lion -- "Warning, installing Mountain Lion will prevent any computers running 10.4 or earlier from connecting to a shared printer on this machine."


    iMac running 10.8.2

    Brother HL-2270DW printer, shared

    Airport Extreme


    Powerbook G4 running 10.4.11

    Had been successfully printing to the shared Brother printer before upgrade to Mountain Lion

    Print drivers on both machines and printer firmware up-to-date

  • JayKayborg Level 1 (0 points)

    Awesome! Using the Airport Express created a work around solution that allows all my computers to see at least one of my printers.    Connecting the printer into the Airport Express allowed the G4 to see at least one printer--- I just had to "add printer" on all my computers, including the old G4 . . . they can all use that printer now. 


    There still is a bonjour issue--- this shouldn't have happened in the first place . . . and the use of the Airport Express isn't a perfect answer, because I have two different printers that are used for their own reasons.  Unfortunatley, the G4 only has wireless access to one of those printers. . .


    So, Apple Geniuses--- thanks to joekewe for getting the printer to work with the G4-- now the ball is back in your court to fix this problem and take us back to how things were in the good ol' days!


    Thanks joekewe!

  • joekewe Level 1 (0 points)


    Glad the Airport worked. I forgot the Express also has a USB port like the Airport Extreme.  I have more good news for you. Although it may not officially be supported, there are reports on the web that you can connect multiple printers to the Airport Express using a POWERED USB hub -- connected to the single USB port on your Airport Express.  The Airport Extreme says it supports four printers.  Make sure it is a POWERED USB hub (it has it's own power supply), and not the kind with only a USB plug.  Let us know if it works.


    Another nice benefit to plugging the printer(s) into the Airport -- you don't have to leave your main computer on all the time to share the printer. Unfortunately, you generally cannot access any other multi-function printer features like scanning through an Airport -- only printing.

Previous 1 2 Next