Previous 1 2 Next 22 Replies Latest reply: Dec 17, 2013 12:51 PM by ElaineHaight
David Goodall Level 1 Level 1 (55 points)

Every time I open Calendar, I get the "upgrading calendars" taskbar, and it hangs. I've done the "remove cache" from Library, I've forece quit the app, I've quit and restarted the app, and I've switched Calendar & Reminder off in iCloud Settings. In some of those cases, the problem goes away, but returns the next time the computer is switched on. Also - after a few days of it, my iPhone & iPad stop getting updates from events created in Calendar on the Mac.

 

Any ideas?

 

Hopefully something that will change with the next update.

  • Ferd II Level 7 Level 7 (23,985 points)

    David,

     

    Go to Calendar>Preferences...>Accounts>Account Information, and delete/re-add your iCloud account information.

     

    If not successful, try removing the com.apple.iCal.plist file from your Macintosh HD/Users/yourusername/Library/Preferences Folder. To find that Library folder, use Finder>Go Menu>Depress the "Option" key>Library. Drag the .plist file to your desktop, and log out/in or restart.

     

    Finally, even though you have already accomplished this step, go to your Macintosh HD/Users/yourusername/Library/Calendars Folder and remove any files with "Cache" as a part of the file name. Use the same method as listed above to get to the correct Library Folder. Log out/in, or restart and check Calendars for functionality.

    /___sbsstatic___/migration-images/191/19133057-1.png

  • David Goodall Level 1 Level 1 (55 points)

    Hi Ferd,

    Thanks for that - I shall try these things again. I'll hang fire before letting you know, as each thing I try (even just quitting Calendar and reopening it) solves the problem until the next day. So I'm starting with trashing preferences. I'll tell you what happens tomorrow!

  • David Goodall Level 1 Level 1 (55 points)

    Nope - it's back.

     

    If I do any of the suggested fixes, they work until I switch off and switch back on some time later, then we are back to the same situation.

     

    Hopefully an update will fix it.

  • Ferd II Level 7 Level 7 (23,985 points)

    David,

     

    I would not count on an update to fix your problem.

     

    Try the procedures listed in iCloud: Troubleshooting iCloud Calendar.

    /___sbsstatic___/migration-images/191/19140915-1.png

  • David Goodall Level 1 Level 1 (55 points)

    I'll give them a go.

     

    Thanks.

  • RSER Level 1 Level 1 (0 points)

    David did you have any luck resolving this problem?  I am having the same issues with iCal....

  • ianrob84 Level 1 Level 1 (0 points)

    And me! Completely irregular timing too... No idea what causes it and tried all of the fixes above

  • dave_561 Level 1 Level 1 (0 points)

    is it still no one can solve this error?

  • RSER Level 1 Level 1 (0 points)

    I am still looking for a solution. Nothing has resolved this problem -though I have noticed that it only occurs when I do a shutdown and then start up again. Justing doing a restart doesn't duplicate the problem with iCal. Other than that I have tried every suggestion and nothing has worked yet. At this point I am hoping there is a corruption somewhere and it will eventually work it's self out. 

  • Arc676 Level 1 Level 1 (135 points)

    Excuse me, in your first post, you said "upgrading calendar" did you mean "updating calendar" ??

  • aoitsukinosuke Level 1 Level 1 (0 points)

    Arc - I'm pretty sure he meant upgrading, because I've got the same thing.

     

    David - Anything on your side?

  • Arc676 Level 1 Level 1 (135 points)

    Are you saying that you both still have iCal.app instead of Calendar.app?

  • RSER Level 1 Level 1 (0 points)

    I did mean Upgrading (sorry for the delay to much Holiday Cheer).  Arc, I am using Calendar 6.0 (1645) on a MBP 2.4 GHz Intel COre 2 Duo w/ OSX 10.8.2.  Ithink this is from Mid 2010 if my memory serves correct.

  • aoitsukinosuke Level 1 Level 1 (0 points)

    Arc- Mine is the same except on a mid 2009 MacMini 2.0GHz.

    Funny thing is this "upgrading" is only stuck during "Open at login". If I manually start, there is no problem.

Previous 1 2 Next