Skip navigation

Mountain Lion does not work with my IronKey.  Is there a work around?

6843 Views 18 Replies Latest reply: Feb 22, 2014 12:06 PM by noodle5642 RSS
1 2 Previous Next
bruce991 Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 1, 2012 3:38 PM

I need to be able to access my ironkey periodically.  Do I really have to get a PC to use the IronKey or spend hours trying to get rid of Mountain Lion and return to the prior Lion?

MacBook Pro, OS X Mountain Lion
  • rkaufmann87 Level 8 Level 8 (40,620 points)

    See if ironkey has an update that will work with ML.

  • mohanfromtrivandrum Level 1 Level 1 (5 points)

    Ironkey has an update. But you have to update thru windows platform only. I have updated my IRONKEY  thru my windows desktop. That update states it will support Lion. but when I tried it on my MBP Ironkey still did not work.

  • Templetontherat Level 1 Level 1 (0 points)

    Their support site says that they have a "workaround" but you have to Email them so they can tell you what it is.  So I did and this is what they sent back:

     

    *****************************************************

    "Thank you for contacting Imation Mobile Security Group Technical Support.

     

    This is a known issue as discussed in the Knowledge Base article linked below. I will add your case to the bug and you will be notified of a fix.

     

      https://support.imation.com/app/answers/detail/a_id/498


    Your information has been added to a database of users who are affected by this and we will notify you once a fix is available. This should not prevent you from unlocking your device in Windows or any previous version of OS X. We apologize for this inconvenience."

    *****************************************************

     

    Not much of a solution, but their answer for now is to use Windows or OS X 10.7

  • kaczurzsolt Level 1 Level 1 (0 points)

    This is quick workaround:

    sudo chmod +r /dev/rdisk*

     

    it's needing to this everytime when you plug in the Ironkey.

  • sean_a Level 1 Level 1 (10 points)

    This worked.  You rock.

  • mohanfromtrivandrum Level 1 Level 1 (5 points)

    I am not an expert on Mac. Can you please explain exactly what I have to do.

     

    best regards

    mohan

  • mohanfromtrivandrum Level 1 Level 1 (5 points)

    Hello,

               Its good that it wkd for you. Can u please explain step by step how it wkd for you. It will be really appreciated

     

    Best regards

    Mohan

  • sean_a Level 1 Level 1 (10 points)

    Insert the IronKey first

    Wait till you see the IronKey icon on desktop or in finder

     

    Go to:

    Applications > Utilities

    Open Terminal (looks like DOS box).

     

    At the prompt, type:

    sudo chmod +r /dev/rdisk*

     

    Double click on IronKey and run the app.

  • pyorre Level 1 Level 1 (0 points)

    Thanks for this! It fixed the issue for me. For anyone who wants a quick script to make this change and open the IronKey quickly, follow my instructions. Please pardon my over-explanation. I did that for anyone who might need the extra info and/or context.

     

    I wrote a script to enable the IronKey after entry.

     

    Here's what I did:

    1: Open a terminal

    2: Type (in the terminal): ls -al /dev/rdisk*

         You'll get back a listing that looks similar to this:

     

    crw-r-----  1 root  operator    1,   0 Sep 25 09:38 /dev/rdisk0

    crw-r-----  1 root  operator    1,   1 Sep 25 09:38 /dev/rdisk0s1

    crw-r-----  1 root  operator    1,   3 Sep 25 09:38 /dev/rdisk0s2

    crw-r-----  1 root  operator    1,   2 Sep 25 09:38 /dev/rdisk0s3

     

    3: Insert your IronKey

    4: Repeat step 2 (type ls -al /dev/rdisk*)

         This time, you'll get a listing similar to the one you got last time, only there will be additional entries.

         In my case, I had these additional entries:

    crw-r--r--  1 josh  operator    1,   5 Sep 25 15:41 /dev/rdisk2

    crw-r--r--  1 root  operator    1,   6 Sep 25 15:41 /dev/rdisk2s0

     

    5: Those new entries, rdisk2 and rdisk2s0 represent my IronKey (note, you may have different filenames!). Also, for those of you unfamiliar with linux/Unix, "/dev/" is a folder on your system. The forward slash "/" just before dev means the root of your hard drive. The rdisk files reside in /dev/.

    New rdisk files are created and removed as you insert or remove other hard drives (the Ironkey is a hard drive in this case).

     

    6: Open a text editor and enter the following. Keep in mind that my entry, covering both the new rdisks - rdisk2 and rdisk2s0 are for my system. You may have different rdisk#'s. Change that part to fit your situation. Also, note that the * which follows the rdisk2* in my example means: Match all files named rdisk2*. That means that this will make a change to rdisk2 and rdisk2s0. If I had an rdisk2sblahdeblah, it would also match that.

     

    Enter this text into your text file:

     

         sudo chmod 644 /dev/rdisk2*

         /Volumes/IronKey/IronKey.app/Contents/MacOS/IronKey

     

         NOTE about those two lines:

         The 'sudo' command means: Run the 'chmod' command with administrative priveledges. You can't run it without that. When this command executes, you'll      have to type your OSX login password.

         The 'chmod' command changes the permission of a file. In this case, you're granting read access to the rdisk files in question.

         The '/Volumes/IronKey/IronKey.app/Contents/MacOS/IronKey' tells OSX to open the IronKey control panel.

     

     

    7: Save the text file with any name you want. For this example, it is saved as ironkey.txt to your home folder. Once saved, close the text file.

    8: Back in terminal, type the following commands (each line is a separate command followed by the enter key):

         cd

         mv ./ironkey.txt ./ironkey.sh

         chmod 755 ironkey.sh

     

         NOTE about these commands:

         The 'cd' command will make sure you're in your home directory, where you saved the ironkey.txt file.

         The 'mv ./ironkey.txt ./ironkey.sh' command will rename ironkey.txt to ironkey.sh. .sh means the file is a shell script.

         The 'chmod 755 ironkey.sh' makes the ironkey.sh into an executable file. It'll be easier to run that way.

     

    9: From now on (or until IronKey fixes this correctly), you'll do the following to access your ironkey:

         a: insert your ironkey

         b: open a terminal

         c: type: ./ironkey.sh

         d: type your OSX login password

         e: Ironkey control panel will pop up and you can carry on as normal. Leave the terminal open or it'll lock your ironkey!

         d: when finished with the ironkey, 'lock and quit' and you can close the terminal.

  • kevin_ Level 2 Level 2 (215 points)

    What I did was write a folder action that I applied to /Volumes and it allows the IronKey to work as normal on the Mac that has this folder action installed.

     

    If anyone would like this, I would be more than happy to post it here.

  • Jake006 Level 1 Level 1 (0 points)

    Can you please post the folder action fix?  The Terminal workaround works - but is cumbersome.

  • kevin_ Level 2 Level 2 (215 points)

    Here is the information on creating the folder action. 

     

    I am including step by step instructions for those that are unfamiliar with creating and applying Folder actions.

     

     

    1. Open the Terminal and run the following command: defaults write com.apple.finder AppleShowAllFiles -boolean true;killall Finder

        (Or you can use any utility to show invisible files)

     

    2. Create a Folder Action Scripts folder inside of your Home Folder / Library / Scripts

     

    3. Open AppleScript Editor

     

    4. Copy and paste the script below into the Untitled AppleScript Editor page

     

    ======== Script starts below this line ========  (Do not copy this line)

    on adding folder items to this_folder after receiving these_items

              repeat with VolName in these_items

                        tell application "Finder"

                                  if (local volume of VolName) and (name of VolName is "IronKey") then

                                            set deviceID to (do shell script "diskutil info IronKey | grep Identifier | awk '{print $3}'")

                                            do shell script ("chmod 445 /dev/r" & deviceID) password "Type_Password_Here" with administrator privileges

                                  end if

                        end tell

              end repeat

    end adding folder items to

    ======== Script ended above this line========  (Do not copy this line)

     

    5. Click on Compile in the Applescript editor toolbar

     

    6. On line 6 of the script replace Type_Password_Here with your Admin password

       **Note: You can bypass this step, but I do not recommend it.

                     (If you do decide to skip this step you will be prompted for your password everytime

                     that you insert your IronKey. Also you need to disable the autolaunch for the

                     IronKey otherwise you will get the error that this is an unsupported device.)

     

    7. Under the File menu select Export

     

    8. In the save dialog window that comes up,

              a. Name your script as IronKey Fix Folder Action

              b. Navigate to the Folder that you created in step 2 (~/Library/Scripts/Folder Action Scripts).

              c. Click on Run Only

              d. Click on Save

     

    9. Open the main level of your hard drive and locate the folder titled Volumes

     

    10. Right (Control) click on the Volumes Folder, then under Services select Folder Actions Setup

     

    11. In the dialog window that comes up select the action named IronKey Fix Folder Action and click on Attach.

     

    12. Close the Folder Actions window.

     

    13. Open the Terminal and run the following command: defaults write com.apple.finder AppleShowAllFiles -boolean false;killall Finder

               (Or you can use any utility to hide invisible files)

     

    14. Quit Terminal

     

    Thats it.  Plug in your IronKey and it will work as it should.

  • Jake006 Level 1 Level 1 (0 points)

    Thanks kevin_

     

    Great work around.  Great instructions.  Totally worked.  You should consider consulting Imation

  • shamrocksolutions Level 1 Level 1 (0 points)

    Thanks everyone for the info. on the work-around.

     

    I was big-time bummed when I made the upgrade to Mountain Lion last week and found out it doesn't work with IronKey.

     

    Looking forward to making the changes proposed above to get the disc back on track.

     

    Does anyone understand why it doesn't work in Mountain Lion?  Just curious....

     

    Cheers....

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.