9 Replies Latest reply: Aug 29, 2012 8:33 AM by bbchase
dingosatemybaby05 Level 1 Level 1



I have a brand new MacMini Server.  It shipped with Lion.  First thing I did was get my static IP and DNS information squared away just like any other client (we are on a primarily windows based network with Windows DNS servers upstream).  I can ping the MacMini by FQDN so all is good.


Then I got my upgrade to Mountain Lion and updated the OS.


I then updated the Server app, and launched it.


I turned ON Software Update Services and let it go grab updates.  Not sure how long its supposed to take, but it went out and grabbed a pile of updates from 4/12/2005 - 7/30/12.  Maybe its not done yet, but I have no idea how to tell and this may or may not be relevant.


My Lion based MacBookPro is sitting in my cube, plugged into the same switch as the MacMini Server.  I can ping it successfully by name from my laptop.


I followed this KB article to point my Laptop at the MacMini for updates:



I tried the string shown in the KB article and that didnt work.  Some searching found someone suggesting this:


sudo defaults write /Library/Preferences/com.apple.SoftwareUpdate CatalogURLhttp://myURL:8088/index-mountainlion-lion-snowleopard.merged-1.sucatalog  (myURL = the FQDN of my actual Mac server).


Either way, it doesn't work.  When I check for updates, I immediately get an error stating:


"The Software Update Server (MyURL) is not responding. Check to make sure your network connection is operating normally. If there are no issues with your connection, contact your network administrator for assistance."


I've tried removing com.apple.SoftwareUpdate.plist and com.apple.SoftwareUpdate.plist.lockfile from the /Library/Preferences folder on my Lion machine as other posts elsewhere suggested with no luck also.


Can anyone help point me in the right direction?  First time trying to configure any kind of Mac Server Service, so be kind 


Thanks in advance,


Mac mini, OS X Mountain Lion, Server
  • BeatleMike Level 1 Level 1

    I am having the same problem as well. I also tried the same fixes you did as well. Would be great to get some help on this.


    My network is full of clients that previously recieved updates from my Lion server with no issue, but now under Mountain Lion, its a roadblock.

  • bubba-01 Level 1 Level 1

    I too have been dealing with this issue all day. Called Apple support, no help. I finally found a solution.

    In the MLion server update for SWUP, the aliases for the catalog files are broken, run these commands in terminal:


    sudo mv /Library/Server/Software\ Update/Data/html/index-lion-snowleopard-leopard.merged-1.sucatalog /Library/Server/Software\ Update/Data/html/index-lion-snowleopard-leopard.merged-1.sucatalog.old



    sudo mv /Library/Server/Software\ Update/Data/html/index-leopard.merged-1.sucatalog /Library/Server/Software\ Update/Data/html/index-leopard.merged-1.sucatalog.old



    sudo mv /Library/Server/Software\ Update/Data/html/index-leopard-snowleopard.merged-1.sucatalog /Library/Server/Software\ Update/Data/html/index-leopard-snowleopard.merged-1.sucatalog.old



    sudo ln -s /Library/Server/Software\ Update/Data/html/content/catalogs/others/index-lion-snowleopard-leopard.merged- 1.sucatalog   /Library/Server/Software\ Update/Data/html/index-lion-snowleopard-leopard.merged-1.sucatalog



    sudo ln -s /Library/Server/Software\ Update/Data/html/content/catalogs/others/index-leopard.merged-1.sucatalog   /Library/Server/Software\ Update/Data/html/index-leopard.merged-1.sucatalog



    sudo ln -s /Library/Server/Software\ Update/Data/html/content/catalogs/others/index-leopard-snowleopard.merged-1.suc atalog   /Library/Server/Software\ Update/Data/html/index-leopard-snowleopard.merged-1.sucatalog


    That will link the catalogs to the proper location.


    I tested it with Lion client but not Leopard or Snow Leopard.


    Let me know if it works for you.

  • dingosatemybaby05 Level 1 Level 1

    So today when I got in, I noticed the data folder where it stores all the updates was upwards of 80gb...it was about 7gb yesterday when I left.  I wonder if it will refuse connections until it has a certain percentage of updates loaded?


    I wonder that because today, using this command to point my unmanaged Lion clients worked:


    sudo defaults write /Library/Preferences/com.apple.SoftwareUpdate CatalogURL http://su.example.com:8088/index.sucatalog


    I didnt change anything - I am hoping this "fixed itself".


    Im going to make some CNAME changes in our internal DNS to point the 3 Apple SW Update URLs at my internal server so that when clients go on the road they can get updates from Apple, but when their in the office, they get them from my server.



  • Steven Major Level 1 Level 1

    Tyically, Server's SUS will not respond until all updates have been downloaded. Usually around the 60-70GB mark.  Depending on your internet speed, this can take awhile.


    We ran Apple's SUS right up until Mountain Lion.  We just switched to https://github.com/wdas/reposado


    It works the same except it lets you have multiple branches.  You can have a test branch where you make sure updates work with specific applications for compatibility before deploying them to your entire fleet.


    Just throwing that out there. Apple seems to strip away more and more with each server release, so we're starting to migrate some services away before Apple takes them away.

  • Typo180 Level 1 Level 1

    Thanks, bubba-01. That got it for me and save me from having to move the files, restarting the service, and hoping that the service would reconfigure itself.


    Fair warning: If anyone tried to fix this issue by pointing your clients to index-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.old you will get some of the updates (apparently the ones that are the same across OS versions), but you won't get important things like OS X point releases (e.g. you won't be able to update from 10.6.3 to 10.6.8).


    I'm assuming this is because 10.8 Server create a new catalog link for 10.8 machines, but did not overwrite the existing links with new, correct ones. In 10.7 and earlier, the catalogs and updates were stored in /var/db/swupd which is where the broken links were pointing, but 10.8 has moved them to /Library/Server/Software Update.

  • iToaster Level 3 Level 3

    Steven Major wrote:


    Just throwing that out there. Apple seems to strip away more and more with each server release, so we're starting to migrate some services away before Apple takes them away.

    I used to be exicted about OSX server releases, since SLS I just worry about what's been removed

  • SaxDaddy Level 1 Level 1

    @bubba-01: I was relieved to find this article but that was short lived.  I too am running a 10.8.1 server and clients cannot get updates when pointed to it. Test users see "MtLionServer not responding".  My next test was simple: browse to the URL of the 10.6.8 SUS server and see the contents of the index.sucatalog.  But when I browse to the same URL (http://MtLionServer.my-co.com:8088/index.sucatalog) of my 10.8.1 server, I get "The requested URL /index.sucatalog was not found on this server."  I already installed Java, disabled SUS then re-enabled, multiple reboots, yada yada.  I'm using IP addresses to bypass potential DNS issues and have confirmed that telnet to the 10.8.1 server on ports 80 and 8088 is responding appropriately.  Also, the SUS repository is 99GB today.


    Here is the output of my console when I ran the commands you posted.  Would really appreciate any community input on this.  TIA.

    MtLionServer:~ macadmin$ sudo mv /Library/Server/Software\ Update/Data/html/index-lion-snowleopard-leopard.merged-1.sucatalog /Library/Server/Software\ Update/Data/html/index-lion-snowleopard-leopard.merged-1.sucatalog.old



    MtLionServer:~ macadmin$ sudo mv /Library/Server/Software\ Update/Data/html/index-leopard.merged-1.sucatalog /Library/Server/Software\ Update/Data/html/index-leopard.merged-1.sucatalog.old


    mv: rename /Library/Server/Software Update/Data/html/index-leopard.merged-1.sucatalog to /Library/Server/Software Update/Data/html/index-leopard.merged-1.sucatalog.old: No such file or directory

    MtLionServer:~ macadmin$ sudo mv /Library/Server/Software\ Update/Data/html/index-leopard-snowleopard.merged-1.sucatalog /Library/Server/Software\ Update/Data/html/index-leopard-snowleopard.merged-1.sucatalog.old

    MtLionServer:~ macadmin$ sudo ln -s /Library/Server/Software\ Update/Data/html/content/catalogs/others/index-lion-snowleopard-leopard.merged- 1.sucatalog   /Library/Server/Software\ Update/Data/html/index-lion-snowleopard-leopard.merged-1.sucatalog


    ln: /Library/Server/Software Update/Data/html/index-lion-snowleopard-leopard.merged-1.sucatalog: No such file or directory



    MtLionServer:~ macadmin$ sudo ln -s /Library/Server/Software\ Update/Data/html/content/catalogs/others/index-leopard.merged-1.sucatalog   /Library/Server/Software\ Update/Data/html/index-leopard.merged-1.sucatalog



    MtLionServer:~ macadmin$ sudo ln -s /Library/Server/Software\ Update/Data/html/content/catalogs/others/index-leopard-snowleopard.merged-1.suc atalog   /Library/Server/Software\ Update/Data/html/index-leopard-snowleopard.merged-1.sucatalog


    ln: /Library/Server/Software Update/Data/html/index-leopard-snowleopard.merged-1.sucatalog: No such file or directory

  • SaxDaddy Level 1 Level 1

    I figured out the problem. After tedious comparison of the 10.6/10.8 servers, I noticed that "index.sucatalog" used in previous versions was simply not present in the /Library/Server/Software Update/Data/html/content/ folder.  I chose "index-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.composite" (since it seemed most appros for our environment), created a link in /Library/Server/Software Update/Data/html/content/ and renamed the link to "index.sucatalog".  Now my 10.6 clients can connect and successfully pull down updates from my 10.8 server.


    In hindsight, the answer seems obvious albeit obtuse

    </somewhat wiping egg off of my own face>



    @Apple: it would be lovely if you either decided to stick to a single convention or perhaps, and just crazy thinking here, consider BACKWARD COMPATIBILITY when changing product features?

  • bbchase Level 1 Level 1

    @SaxDaddy, you're going to run into problems with that setup. Probably the same problems I ran into when I pointed my clients to a specific catalog and possibly others. You're potentially breaking a link that some clients are looking for and potentially directing other clients to the wrong place.


    You also shouldn't have an index.sucatalog in Data/html/content and I don't have one in html and my updates are working fine. Can you "ls -la" your html directory and post the results here? The issue you were having may have been different than what the fix was for.


    The issue here is not backwards compatibility, it's that these symlinks were not updated/replaced properly by the installer.