Previous 1 2 3 4 5 6 Next 81 Replies Latest reply: Sep 18, 2014 6:06 PM by Fgrigorio Go to original post
  • dmauch Level 1 (0 points)

    Understood Jensen.  But I'll pass judgement on them!  They're lack of a response or a resolution STINKS!  It's totally UNACCEPTABLE and it wreaks of a company that has grown so large that it's forgotten it bread and butter customers.  Easier for them schlep Chinese-built iPads by the millions to taxpayer funded school districts across the country as they know that if there's a defect, the taxpayers nor the overpaid school administrators will give a hoot.  They'll just buy more and pass along the costs. 

  • jasimon9 Level 1 (0 points)

    I have had a similar problem since converting to the Mac, starting with Leopard in March 2009, but only affecting a sound I have set to play when specific emails are received. Think: "the cash register ka-ching sound when a sale comes in." The sound is set in a rule that also moves the mail into a folder. The move part of the rule always works.

     

    The problem is that the sound is played at some random time after the mail is received. Sometimes it is when the mail is received, sometimes 20 minutes later, but very oftern a couple of hours later. The other day it played about 8 hours after the mail was received.

     

    I have reported the issue to Apple bug reports.

     

    I have read about the workaround of force-quitting coreaudiod and I have tried that. Some preliminary testing seems to indicate that the delay does not occur. If so, overcoming this annoyance would be huge! But it will take some time to see if the workaround really works in practice.

     

    Based on what others have said, it appears that the workaround would have to be done after every sleep of the system, which means each morning at a minimum. So I am wondering if there is an AppleScript or Automator function that can be triggered on wake from sleep.

     

    I do see at http://www.dssw.co.uk/blog/2011/02/01/how-to-run-an-applescript-on-wake-up/ a way to do this, but it requires at $50 utility called Power Manager.

     

    Another alternative would be to shut down the system nightly. Used to be I needed the system to run certain jobs overnight, but I don't require that anymore, so this could also work.

  • Humefan Level 1 (0 points)

    I have discovered a fix for the missing mail sounds that has worked for me for about three weeks.  Try this:

     

    1.  Go to System Preferences and select Energy Saver.

    2.  Now select Power Adapter at the top of the window.

    3.  Uncheck Enable Power Nap.

    4.  You may have to close Mail and then reopen it.

    5.  Send yourself an email---I hope you hear swishing and dinging!

     

    Good look.

     

    (This is for a mid-2012 Macbook Air)

  • Jensen Gelfond Level 2 (285 points)

    Disabling Power Nap has worked for me as well. Since disabling it I'm no longer experiencing the issue on my 2012 MBA. Restarting the computer may also be necessary after making the preference changes.

  • Taoswoman Level 1 (0 points)

    Works for me too .. at least so far. Thank you!

    p.s. I restarted Mail but not the computer (MBR)

  • jasimon9 Level 1 (0 points)

    This is a follow up to my previous post, wherein I had the workaround of restarting coreaudiod. I have created a script-based solution that seems to be working.

     

    Please note: the solutions pertaining to Mac Book Air are not applicable to me, as I am on an iMac, and there is no "Power Nap" feature.

     

    In any case, I have a script which is set to run each time the computer wakes from sleep that quits coreaudiod. Thereafter, sound notifications are played when expected. Here is the script, which has a few "extras" that I need:

     

    #!/bin/bash

    # kills coreaudio (to overcome bug: see https://discussions.apple.com/thread/4170677?start=15&tstart=0 post by jasimon9)

    # script inspired by answer at http://stackoverflow.com/questions/8343989/shell-script-to-kill-a-process

     

    # delay to allow Boom to start

    sleep 15

     

    # restart coreaudio

    pkill 'coreaudio'

     

    # reset the volume

    osascript -e "set Volume 3"

     

    I have found a free program sleepwatcher to run the above script after each wake from sleep, which I run from LaunchDaemon. The details are a bit technical, so I am omitting them for now.

  • jube2013 Level 1 (0 points)

    Thank you Humefan. Your suggestions fixed the mail sounds problem. Any idea how to get the trash sounds back?

  • Humefan Level 1 (0 points)

    Jube2013,

     

    I checked my trash sounds and don't have the problem you mention.  I wish I had some suggestions, but I'm really a babe in the woods when it comes to computers.  The fix I discovered was a result of noticing certain correlations and is not based on any expertise whatsoever.

     

    Good luck with your trash sounds.  Let us know if you find a fix.

  • waugse Level 1 (0 points)

    I massively had this problem a few months ago, then it stopped without me doing anything conciously. Since yesterday it is back though. No new updates or software. I'm clueless.

  • Humefan Level 1 (0 points)

    waugse,

     

    Did you try my suggestion?

  • ValentineLynx Level 1 (0 points)

    Thanks, this fixed it for me. I had "trust" issues with one of my email accounts, too, and when I set it to "Always Trust" I got my email sounds back. I had just gotten a new MBP15" Retina with 10.8.2 and no email sounds from the get go until I fixed the "trust" issue.

  • Paul Level 1 (90 points)

    This fixed my sound issue! Hopefully permanently, so thank you!

  • mach94 Level 1 (0 points)

    fixed mine too......thank you.

     

    c'mon apple, how about 10.8.3?

     

    or 10.9 for that matter !

  • Roginator Level 1 (0 points)

    Disabling Power Nap worked for me too. How weird! Haven't restarted yet so not sure if it's a permanent fix.

  • swazz Level 1 (0 points)

    Thanks Humefan.  I used your suggestion:

     

    1.  Go to System Preferences and select Energy Saver.

    2.  Now select Power Adapter at the top of the window.

    3.  Uncheck Enable Power Nap.

    4.  You may have to close Mail and then reopen it.

    5.  Send yourself an email---I hope you hear swishing and dinging!

     

    Restarted Mail (not the computer) and voila; my mail sounds are back.  We'll see if they stay.

     

                                                                          Thanks