Previous 1 2 3 Next 132 Replies Latest reply: Apr 11, 2013 1:13 PM by Barry Fass-Holmes
maiksd Level 1 Level 1

This happens only on my new MacBook Air 11" and only since I upgraded to Mountain Lion.

 

Whenever my mouse pointer is over a Numbers document (not the window title, but the actual document), CPU usage by Numbers.app goes to 70% and stays there until I move my mouse somewhere else.

 

Did anyone else experience this?

Solved by maiksd on Aug 23, 2012 1:39 PM Solved
Aha! 10.8.1 solved it for me!  Can anyone else confirm this?
Reply by mttl on Aug 4, 2012 12:37 AM Helpful
I have 8 GB memory on my computer and CPU usage is still about 70%. I also tried the following things: 1) Restarted the computer2) Reinstalled Numbers with the latest version from the App Store3) Verified Numbers file permissions4) Checked that I don't have any corrupted fonts on my computer5) Ran opensnoop to see if Numbers has any weird disk activity during the high CPU usage Still no luck.
Reply by mttl on Aug 4, 2012 12:55 AM Helpful
By the way, I sent some days ago a bug report to Apple concerning this issue by using the Numbers/Provide Numbers Feedback menu. This sends you to a web page where you can choose feedback type "bug report". I recommend that you do it too if you have not done it yet.

All replies

  • mttl Level 1 Level 1

    I have the same problem on my Mac Mini with Mountain Lion and Numbers 2.2.

  • HM7 Level 1 Level 1

    I have the same problem on my Macbook Air 13" (2011).

  • Jerrold Green1 Level 7 Level 7

    maiksd,

     

    I get a small burst of Numbers activity when I move the cursor over a table in Numbers, and another burst when I move the cursor back off the table. Haven't seen it go even as high as 10% on this mid-2010 MBP. So, no problem here. I have about 850 MB of free RAM and about 175 GB of free HD. If I find myself in a situation where the free RAM is about gone, I'll try this again and see what difference that makes.

     

    Jerry

  • maiksd Level 1 Level 1

    In my case it's a 2012 MacBook Air, and it doesn't make a difference whether there is RAM free or not, or whether or not the system had just been booted or running for a long time. It always happens when I put my mouse pointer over a Numbers sheet.

  • Barry Level 7 Level 7

    Have you checked for and run the latest updates to Numbers/Pages/Keynote?

     

    Regards,

    Barry

  • maiksd Level 1 Level 1

    Of course. I check updates daily and I'm on the newest releases of everything.

  • maiksd Level 1 Level 1

    Just as an illustration. This is activity monitor in background sorted by CPU descending, and Numbers.app in the foreground. The mouse pointer sits over Number's big gray window title bar.

    numbers_out.png

     

    Now just the same, but moved the mouse pointer downwards onto the document content:

     

    numbers_in.png

     

    And it's really always 70% on my machine. Never 100% or 50% or anything else. Always between 69% and 71%.

  • Jerrold Green1 Level 7 Level 7

    Malksd,

     

    I let my free RAM drop below 800 MB and my Numbers CPU load rose to 70% when hovering mouse over table. I closed unneeded apps and Restarted computer, resulting in over 2 GB Free RAM. Numbers CPU load was less than 5% at all times when mousing over table, same Numbers document in both cases.

     

    Jerry

  • maiksd Level 1 Level 1

    Here's a new screenshot with more than 4 GB of free RAM. As soon as my mouse pointer enters the table content, CPU load goes up.

     

    I noticed that WindowServer goes up as well to it's 23-26% each time.

     

    numbers_in_freeram.png

  • mttl Level 1 Level 1

    I have 8 GB memory on my computer and CPU usage is still about 70%.

     

    I also tried the following things:

     

    1) Restarted the computer

    2) Reinstalled Numbers with the latest version from the App Store

    3) Verified Numbers file permissions

    4) Checked that I don't have any corrupted fonts on my computer

    5) Ran opensnoop to see if Numbers has any weird disk activity during the high CPU usage

     

    Still no luck.

  • mttl Level 1 Level 1

    By the way, I sent some days ago a bug report to Apple concerning this issue by using the Numbers/Provide Numbers Feedback menu. This sends you to a web page where you can choose feedback type "bug report".

     

    I recommend that you do it too if you have not done it yet.

  • maiksd Level 1 Level 1

    Good idea, done. I didn't find that menu at first because I only looked for it in the Help menu.

  • Jerrold Green1 Level 7 Level 7

    mttl wrote:

     

    By the way, I sent some days ago a bug report to Apple concerning this issue by using the Numbers/Provide Numbers Feedback menu. This sends you to a web page where you can choose feedback type "bug report".

     

    I recommend that you do it too if you have not done it yet.

    You guys are doing the right thing in reporting this. I'm not trying to convince you of anything one way or the other, just reporting what is going on in my case. On my side, I'll be upgrading to 8GB.

     

    I'll continue to look for clues as to the cause.

     

    Regards,

     

    Jerry

     

    Edit: Please, if you haven't, test with only Numbers and Activity Monitor running.

  • mttl Level 1 Level 1

    Jerry,

     

    I tested to run Numbers without having any other applications running. Before that I deleted the following preferences / cache files and let Numbers to re-create them.

     

    ~/Library/Caches/com.apple.iWork.Numbers/

    ~/Library/Preferences/com.apple.iWork.Numbers.plist

    ~/Library/Preferences/com.apple.iWork.Numbers.LSSharedFileList.plist

     

    I also tried to run it with another user account (admin) in case there is something wrong with my user profile.

     

    In both cases Numbers CPU usage is still high.

Previous 1 2 3 Next