Previous 1 2 3 4 5 6 Next 77 Replies Latest reply: Feb 5, 2014 12:08 PM by Mortiasd Go to original post Branched to a new discussion.
  • Red Jacket Mike Level 4 Level 4

    I had a copy of 5.6.1 on another Mac, and I was able to copy it to the desktop of my MacBook Air running Mountain Lion.  I was not able to copy it to the utilities folder, where the newer version resides, however.  I tried renaming the older version by adding 5.6.1 to the name, but I still was not allowed to place it in the utilities folder, or remove the newer version.

     

    The simple solution was to place 5.6.1 directly in the applications folder; the newer version is in the utilities folder where it always has been. 

  • alby_williams Level 1 Level 1

    Thanks Doug - this worked brilliantly. Another satisfied customer!

    cheers

    alby

  • La Corte Jester Level 1 Level 1

    Thank you so much, Doug! This is fantastic. Brilliant work!

  • willwinuk Level 1 Level 1

    You can also use the free program The Unarchiver to extract the files.

  • sean.peters Level 1 Level 1

    Instructions fail at step 5 (xar). When I run the command, rather than seeing a directory by the name of "AirportUtility.pkg" with a "Payload" file inside it, I'm getting... another copy of an installer file: what looks like the same package I started with, only with a new creation date, and a smaller file size. So there's nothing to extract with tar (or gzcat). Kinda baffled here.

     

    Any thoughts? I'm on a MacBook Pro, OSX 10.8.2.

  • sean.peters Level 1 Level 1

    Ok, I was ultimately successful. Neither tar nor gzcat was able to open the newly created package file, failing with an error something like "bad CPU type". But Finder gave me the option to look inside the archive, and I found the Payload file within. Dragged Payload into a new folder... but again, neither tar nor gzcat would open it, failing it with the same error. But it gave me the opportunity open it with an archive utility, which solved the problem... providing the three folders discussed. So I'm up and running.

  • Tom Neff Level 1 Level 1

    There is also a free utility called Unpkg ( http://www.timdoug.com/unpkg/ ) that will extract the contents of any install PKG very neatly.  You can skip all the "Termitis" and just go straight to the .app file.

  • Frozo Level 2 Level 2

    Cheers! Right you are. Perfect solution, thank you!

  • malditojake Level 1 Level 1

    Many thanks - just simply awesome!

  • FredTheTech Level 1 Level 1

    Absolutely smackingly perfect!  I'm going to take this solution with me to work so customers coming in with older airport issues can be assisted!!  I just tried it out and was successful.  BTW the contents of the library and system folders that are extracted are NOT necessary and CAN be trashed.

  • Stephen Swindon Level 1 Level 1

    This worked perfectly - many thanks!

  • jbrady Level 1 Level 1

    Thanks that works.  How annoying Apple.

     

    Why doesn't Apple either fix the download that their own software (the current Airport Utility on ML) tells you to go get to point you to a version that installs on the OS that the stupid utility is running on?  It's not like Airport Utility hasn't been updated since ML came out.

  • Sgt X Level 1 Level 1

    Here's the year's "Man!  I Felt JUST Like a Smart Hacker Guy" award for Douglas Urner.

     

    I followed the instructions, and it worked, and *I* felt like a genius.  And that's what it's all about.

     

    Thanks, Douglas.  Have a merry Christmas.

     

    Regards,

    Sgt X

  • Tom Neff Level 1 Level 1

    Or you could use Unpkg and just drag the app to your desktop.  I think nobody reads the last page of these threads.

     

    Unpkg ( http://www.timdoug.com/unpkg/ ) - I have nothing to do with it except as a user

  • Wizzard Prang Level 1 Level 1

    Cheers! Worked for me. Glad to get that version back.