Skip navigation

Calendar - Exchange sync issue

44917 Views 129 Replies Latest reply: Feb 26, 2014 4:58 AM by svencito RSS
  • vicko.arocha Calculating status...
    Currently Being Moderated
    Feb 5, 2013 11:49 AM (in response to acyclone)

    After this fix, I have been using the Calendar for 2 weeks without mayor problems.

     

    The identified issues:

     

    - with a Calendar entry that I made before this fix for testing purposes using a different timezone. I deleted this entry to fix the error.

    - I always use the Create Quick Event function without problems, but if I use the "double-click in the date" method, the problem appears. Just stick to the "+" button to avoid problems.

     

    Regards,

    Victor

  • lnxcuu Calculating status...
    Currently Being Moderated
    Feb 5, 2013 11:56 AM (in response to mcoppock)

    Hello.

     

    Probably this is to late, but I want to say, That I already resolve the problem, changing the date and time zone of my exchange Servers to Mountain standard time, because they was on on my city time zone defined on Windows,

     

    all my  Mac Os X are on this time zone, also I check the option form my Cal Time Zone Support

     

    HTH

  • KendallB Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 5, 2013 1:14 PM (in response to vicko.arocha)

    Cool. I have tried everything else but not this option. I will give it a try. If it works for me, I will do it for my wife also.

  • Randall Blank Level 1 Level 1 (35 points)
    Currently Being Moderated
    Feb 6, 2013 10:27 AM (in response to vicko.arocha)

    Ugh. Now I'm getting hit with the "invitees not recognized by the server bug," and attempting to fix that (as suggested in the linked thread) started me on the "can't save the event" merry-go-round again. Sigh.

     

    Back to the Outlook Web App again.

  • G. Pasarescu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 8, 2013 8:48 AM (in response to vicko.arocha)

    I tested your fix, v.a, but after only two days I am seeing the same error as before (The account "Exchange" currently can't be modified).

     

    The server I am connecting to is undoubtedly on Mountain Standard Time, while I live (and set my calendars) in Pacific Standard Time. I am going to try Inxcuu's suggestion of changing my time zone and will get back to you.

  • G. Pasarescu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 8, 2013 2:56 PM (in response to vicko.arocha)

    Vicko,

     

    I just read your other post (re: the "double-click on the date" method of creating a Calendar item) and I am retracting my comment above. It may be that I double-clicked on the Calendar to creat the event that was throwing the error. I have redone all the steps of your earlier post and will only create new items using the "+" button and let you know how it goes.

     

    Thank you again for sharing. If this works, what might the bug be? A time zone issue? I'm really not interested in setting my calendars to another time zone just so that it will work properly with the server...

  • Sprakula Calculating status...
    Currently Being Moderated
    Feb 19, 2013 10:05 PM (in response to mcoppock)

    +1 for me.

     

    iPad and iPhone can sync to the calendar, but iCal throws the error. Will try all of the solutions above, but I'm sure I'll have the same amount of luck.

  • G. Pasarescu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 20, 2013 9:50 PM (in response to vicko.arocha)

    So here is my update (12 days later):

     

    1. If I open iCal on my Mac, I still get the error "The account 'Exchange' currently can't be modified" for events that were created in Exchange via Outlook 2010 / 2013 on my Windows 7 machine AND THAT HAVE ALREADY OCCURED. However, if I click on the "Revert to Server" button, the dialogue box with the error disappears and I am still able to events to my iCal (via the + sign). These events must be saving properly to Exchange, since they almost immediately show up on my iPhone and iPad, which are also synced to Exchange. They also show up on my Outlook 2013 running on Windows 7.

     

    So, it appears that iCal is working with Exchange (after applying Vicko's suggestion), but I still get "The account 'Exchange' currently can't be modified" errors whenever I open iCal and the event in question had been created in Outlook AND has expired. I just click on "Revert to Server" and the error goes away.

     

    2. However, the same fix does not appear to work for Reminders, whose tasks are not syncing properly between my Mac and my iPhone / iPad. In other words, if I add, delete, or modify a Reminder event (which is set up to sync with Outlook Tasks via Exchange) on my Mac, the addition / deletion / modification does NOT show up in my Outlook Tasks, or on my iPhone / iPad Reminders app. However, making changes to any of these other platforms (Outlook Tasks, iPhone or iPad Reminders) automatically and immediately is applied to the other three - but not to Reminders on my Mac.

     

    In the past, whenever the iCal syncing was working, so did the Reminders sync. Now, iCal seems to be syncing (despite the error), while Reminders is not.

     

    Any other thoughts on this? You cannot add iCal and Reminders sync separately - they are bundled together in System Preferences -> Mail, Contacts, & Calendars.

  • @ntoni Calculating status...
    Currently Being Moderated
    Feb 22, 2013 3:48 PM (in response to vicko.arocha)

     

     

    I found a workaround that works fine for me (the procedure in the other answers didn't worked):

     

    - go to Calendar Preferences and delete de Exchange Account.

    - close (Calendar->Quit Calendar) Calendar

    - go to Terminal and delete "rm -rf *" all the files inside username/Library/Calendars/

    - open Calendar

    - go to Calendar->Preferences->Advanced and Turn on time support (if it is already enabled, disable it, close calendar and then re-enabled it)

    - in the upper-right-corner of calendar, select your Timezone (very important to select your timezone before adding the Exchange account)

    - close (Calendar->Quit Calendar) Calendar

    - open Calendar

    - go to Calendar->Preferences->Accounts

    - add the Exchange Account

     

    Problem solved.

     

     

     

    Thank you, the solution works for me.

     

    OSX 10.8.2 - Exchange Server 2010

  • pendolino Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 4, 2013 2:40 AM (in response to @ntoni)

    hello everyone - i am not sure if this has been mentioned before but as this 'revert to server' nightmare has caused a lot of trouble i am sharing the solution that seems to be working for me:

     

    switch off time zone support in the 'preferences' for apple's calendar application on OSX.

  • 8-andrew-8 Calculating status...
    Currently Being Moderated
    Mar 7, 2013 3:31 PM (in response to mcoppock)

    Same issue MBP-R 10.8.3.

    Bug report submitted.

  • Pascal_Sartoretti Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 9, 2013 4:01 AM (in response to 8-andrew-8)

    8-andrew-8 wrote:

     

    Same issue MBP-R 10.8.3.

    Bug report submitted.

    This is very bad news; I was hoping that 10.8.3 would solve this very annoying bug...

  • lnxcuu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 12, 2013 12:50 PM (in response to Pascal_Sartoretti)

    Hello

     

    I have found that after daily saving time change the error came back on my calendar,  trying to figure it up I detect that my OSX Mountain Lion time zone was on mountain standard time (my city), and the Calendar zone was on Mountain Time.

     

    I have set my OSX time zone to Mointain Stand time (without my city) and also  the Calendar set to this time zone, and its working now.

     

    its all on the time zone setting.

     

    HTH

  • vicko.arocha Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 2, 2013 11:49 AM (in response to @ntoni)

    I have found more details about this error.

     

    If I select "Central Standard Time - Mexico City - Mexico" in Calendar Preferences. The ".. cant be modified.. " problem appears.

     

    If I select "Central Standard Time - Saskatoon - Canada" in Calendar Preferences. The problem disappears....

     

    So. Even that I'm located in Mexico City, I can use CST Saskatoon - Canada in timezone preferences and it will work fine for me...

  • Randall Blank Level 1 Level 1 (35 points)
    Currently Being Moderated
    Apr 2, 2013 12:18 PM (in response to vicko.arocha)

    Interesting. Unlike Mexico City, Saskatoon doesn't observe Daylight Savings Time, so perhaps that has something to do with it.

     

    Which raises the question, will the error come back when DST ends?

     

    I still find this time zone stuff confusing. I don't even know what TZ the Exchange server is in, since Rackspace has data centers in both Central and Eastern…

1 ... 3 4 5 6 7 ... 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (9)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.