Previous 1 2 3 Next 144 Replies Latest reply: Sep 30, 2015 8:01 PM by SmartPenwin
mcoppock Level 1 (0 points)

I'm having a problem with Calendar and Exchange syncing (my company uses Exchange 2010), with the following error:

 

"Calendar can’t save the event “Item title” to the Exchange server.

 

The account "Exchange" currently can’t be modified. To discard your changes and continue using the version of your calendars that’s on the server, click Revert to Server."

 

The options on the dialog box are:

 

Revert to Server

Try Again

Ignore

 

Syncing in general is working, i.e., items added in either system show up as they should. And, I'm not actually changing anything on the items on my MBA. The error pops up apparently randomly--so far, at least, I haven't been able to identify a pattern. I've checked credentials, which seem to be correct, and I've verified that time zone settings are turned on as I think they're supposed to be.

 

Any ideas?


MacBook Air (13-inch, Mid 2012), OS X Mountain Lion
  • Geof Corb Level 1 (5 points)

    I have the same problem on two different Macs, both running Mountain Lion.  I did not have this problem on either machine prior to the upgrade.

     

    In my experience, these errors appear *after* the event has occurred.

  • furyg3 Level 1 (10 points)

    I also experianced this problem after an upgrade to Mountain Lion.

     

    I think it has to do with the fact that in Lion the account settings were managed from iCal, and now they are managed by the OS?

     

    Anyway I finally solved it by:

    • Open Calendar (formerly iCal).
    • Go to the Calendar menu and select Preferences.
    • Select the Accounts tab.
    • Remove the Exchange server account which is giving you the error messages.  This calendar will be removed from the Calendar app.
    • Go to System Preferences and click on the "Mail, Contacts & Calendars" pane, find your Exchange server account, and check the "Calendars & Reminders" option to re-enable your calendar.
    • Your Calendar should now sync properly.


    I had to do this for all of the accounts I had set up in Calander, and haven't had any problems since.

  • mcoppock Level 1 (0 points)

    Okay, I'll give that a shot and report back.

  • mcoppock Level 1 (0 points)

    Okay, knock on wood, that seems to be working so far. It does take a little longer than I'd like for changes to refresh (but they do eventually, so far), but I'm not getting the errors any longer.

     

    A side benefit is that Reminders now sync correctly, where they were a bit wonky before.

     

    Thanks!

  • mcoppock Level 1 (0 points)

    Okay, well, this didn't actually completely solve the problem. The original error is gone, but now I receive an error about improper invites on the MBA (don't have one in front of me at the moment). When I check the calendar item in Outlook, I see that it's now been set up for invitations but the invite line is blank. What I'm doing now is deleting invites in Outlook.

     

    This error kicks off with each new calendar item, as it comes due (i.e., for an 11:00am appointment, the error kicks off precisely at 11:00am). I'm going to check next week to see if perhaps it was old appointments set before the "fix" that have the error.

     

    Bottom line, I think Apple has some work to do still on syncing with Exchange.

  • mcoppock Level 1 (0 points)

    Aaaaand, this morning the problem came back. So, yeah, this didn't quite fix things.

     

    Hopefully it's something Apple is aware of and will fix in an update.

  • robert222 Level 1 (0 points)

    This worked for me. Thank you.

  • mcoppock Level 1 (0 points)

    Give it a couple days, and if it's still working, please report back. Mine reverted to its previous behavior after about a day.

  • Geof Corb Level 1 (5 points)

    Didn't work for me. I have deleted accounts, blown out keychain config, and just about everything else I can think of to try to remedy this.  Something is clearly not right.

  • GeoTowers Level 1 (0 points)

    Didn't work for me too

  • williamsc29 Level 1 (0 points)

    This didn't work for me either.  I completely removed my accounts and it came back.  It's happening on both of my Macs.

  • williamsc29 Level 1 (0 points)

    I was hopeful this would be fixed in 10.8.1, but it's not.

  • mcoppock Level 1 (0 points)

    10.8.1 didn't fix it for me either.

  • Francesco Borraccino Level 1 (5 points)

    10.8.1 didn't fix it and this solution doesn't work unfortunately. This is a serious issue and I am shocked that Apple can't fix this. Can we escalate this? Who do we escalate to?

Previous 1 2 3 Next