Previous 1 2 Next 26 Replies Latest reply: Oct 8, 2012 12:47 PM by FrederickW
rafapecora Level 1 Level 1

Ethernet not working after downloading mountain lion

iMac, OS X Mountain Lion
  • bill33 Level 1 Level 1

    Dear rafapecora,


    As you may already know the issue is as follows:


    The ethernet connections, after changing nothing but the OS, is shown as unplugged, and spontaneously comes on and off about every two hours.


    Unsuccessful solutions are resetting the SMC and some other acronym, rebooting the computer, rebooting the router, deleting and creating a new ethernet connection, talking to your ISP, and talking to Apple.


    Through my experiences on the various threads that have been generated on this topic in this community, no one has come to a conclusion or solution. I am just waiting for Apple to come up with a patch, of sorts.


    People that have time machined back to 10.7 regained their ethernet. Also, understand that when you upgrade all your preferences and settings are transferred over, so I deduce that it is something deeper in the new OS.


    Luckily though, the WiFi should work.

  • danieladarve Level 1 Level 1

    Did you find a solution for this issue? I talked to apple care support and they said my ethernet port somehow went bad while upgrading.


  • bill33 Level 1 Level 1

    What? You cant be serious....

  • bill33 Level 1 Level 1

    get a usb ethernet port to confirm this then...would be my suggestion....

  • danieladarve Level 1 Level 1

    I ran a hardware diagnostics test, and it shows the ethernet card as installed, it should in theory work. Also tried reinstalling Mountain Lion from scratch no upgrade. WiFi works normally, ethernet port is dead, my mac has only 4 total uses since I bought it, this is total bummer. How can I go back to Lion?



  • bill33 Level 1 Level 1

    exactly it is obviously not a hardware issue....your conclusion seems cool....either go back to Lion...I'll just stick with wifi until the release a fix....

  • danieladarve Level 1 Level 1

    Guys, everything got resolved with the new Mountain Lion update that recently came out. I guess the Apple Care Technician who talked to me just thought it was a hardware issue.

  • bill33 Level 1 Level 1

    i still have the same problem nothing has changed. I installed the update....didnt work......

    then i installed a clean install.....again same unplugged ethernet..... the ethernet is not unplugged....that is for sure....i tried the ethernet on another computer (PC) and it works....???? with 0s 10.7 it all worked least the wifi works...

  • pankaj_deep Level 1 Level 1

    i opened the ticket with apple support, he still doesn't claim issue is with upgrade. tried level 1 support item with supposidly expert level 2. i have tried all of following


    - replacing cable

    - restarting routers

    - trying home/office n/w


    waiting for callback now but issue started with Mountain Lion upgrade so there is something wrong there but let's see

  • bill33 Level 1 Level 1

    i have also spoken to support and we went through everything and we have tried everything as you state above. I am also at the stage of installing Mountain Lion for the third time after having done a Backup as recommended. I'm calling back Apple Support today to inform that the cable is still virtually unplugged. It still seems like a software issue.....

  • danieladarve Level 1 Level 1

    Hey Guys,

    Make sure when you are installing Mountain Lion is not an upgrade but a clean install meaning you wipe everything from the Harddisk drive, then after you install it, go ahead and install the update. that worked for me.

  • bill33 Level 1 Level 1



    So I did a clean install as suggested by Apple tech support. When it was all said and done the etherent worked! However, I had to use Migration Assistant to bring all my files back as I have loads of "sh$t" that needed to come back. I'm in the middle of projects and work. I let this run over night as it needed 2 hours to transfer. When I came back to the coomputer this morning. No etherent - cable unplugged. SO, possibly someone who knows the ins and outs of the settings of the OS can isolate the issue so that we dont have to go through a format process....I dont have the time for another format process as I lost an entire day of work!


    Thanks of all suggestions in advance. But Apple should surely be all over this. It seems like a driver issue......

  • WigglyWaggly Level 1 Level 1



    I have read many of the threads.  I upgraded 2 different computers (MacBook Pro and Imac) to Lion.  Neither of them are now working with the Ethernet Connection. 


    Seems strange that neither of them are working.  Of course, they are not under warranty either.


    Can someone please post the steps to solve this issue? 



  • Kevin Neal Level 2 Level 2

    So the ethernet works in Mountain Lion Fresh install but dies as soon as you migrate your user account?


    That would suggest it is a corrupt preference file that is being copied over.


    Make a new user test and log in to that account and see if ethernet is working or not, if it is you need to narrow down which preference is corrupt and delete it

Previous 1 2 Next