Previous 1 2 Next 26 Replies Latest reply: Oct 8, 2012 12:47 PM by FrederickW Go to original post
  • pankaj_deep Level 1 (0 points)

    Early last wk, apple support technician called back but still no luck. He had me create new a/c and still ethernet doesn't work. Still waiing for fix

  • salvatore.defazio Level 1 (0 points)

    Same problem for me.

    After the update to ML the ethernet connection switch continously between the "connected" and the "not connected" status with a 2s frequency.

    Previously all was fine and working.

    I activated wifi, but this problem needs a permanent solution..

  • bill33 Level 1 (40 points)

    Finally works with the update to 10.8.3











  • bill33 Level 1 (40 points)

    I was so excited that I was envisioning the future..sorry....10.8.2 is what I meant...hahahah bottom line is that ethernet works.

  • fcrocetti Level 1 (0 points)

    I'm happy you solved it with 10.8.2 update, but on my iMac (Feb. 2012) I upgraded Lion to Mountain Lion few days ago and unfortunately I came to this ethernet issue. It's a random issue, it didn't work some days ago then it worked (without doing anything) for a couple days and this morning is not working again. This is very frustrating since I use my iMac to work at my business, yes I know that I can use WiFi (which at least works, for now) but I want ethernet for a bunch of reasons!


    Please Apple, find a final fix! I want my ethernet back, never had issues on it until upgrading to Mountain Lion so it's definitely why of the new OS (this experience will definitely keep me away from future OS upgrades until it will be at least 6 month or more old).

  • jdirik Level 1 (0 points)

    I have the same problem.  Running 10.8.2 and the Ethernet connection drops randomly after a period of inactivity.

  • MATTHEWPICCHU Level 1 (0 points)

    My ethernet was on and off ever since I downloaded Mountain Lion. I am running 10.8.2 and now it doesn't work at all.

  • Zak Adelman Level 1 (60 points)

    I had the same issue.  I found that if I turned off bluetooth it worked fine so I got a router that used the 5Ghz spectrum (instead of 2.4) Now I have no issues.  Milage may vary of course.


    It seems Mountain Lion has problems recognizing the WiFi, since wireless phones, Bluetooth devices (mice, keyboards, headsets, etc...), and other devices using the same 2.4 range.  I had no issues with 10.7.x - 10.8 but 10.8.1 and .2 gave me issues.

  • shiretu Level 1 (5 points)

    Same problem here. I have an iMac 27 inch. After 10.8.2 update, ethernet worked fine. After it waking up from sleep, it didn't work anymore. Didn't do a restart yet because I want to investigate the issue further. Now I'm over wifi. This is getting ridicoulous. We all pay the price for apple, and the quality is getting worst by the day/update. Is not the fact that the problems are here, that is fine and is part of a normal software evolution. The bad part is that you have to go through "levels of support" until they admit there is a problem. Try your f**king s**t apple before releasing it. You inpact our productivity. You have billions of dollars at your disposal from our money which clearly bcomes badly spent by the day passing. Get your s**t together. Start reading the posts and do something about it

  • shiretu Level 1 (5 points)

    And I found a sollution without restart:

    sudo kextunload IONetworkingFamily.kext/Contents/PlugIns/AppleBCM5701Ethernet.kext

    sudo kextload IONetworkingFamily.kext/Contents/PlugIns/AppleBCM5701Ethernet.kext

  • FrederickW Level 1 (0 points)

    That is not the case for me. Even though I did a fresh install and did not import any account, it is not working

  • FrederickW Level 1 (0 points)

    I have the very same problem. I have tried everything I can do but still no luck


    I have a 2011 iMac which was working fine with Lion


    When I upgraded to Mountain Lion 10.8.0 ethernet connectivity stopped working

    As other users report, my ethernet status changes from "disconnected" (red) to "missing IP" (yellow) every couple of seconds


    Captura de pantalla 2012-10-08 a la(s) 21.45.25.pngCaptura de pantalla 2012-10-08 a la(s) 21.45.46.png


    From then, I have tried the following:


    • + Clean OS reinstall (without user account or data importing, I just copied my files manually from a network-connected PC)
    • + 10.8.1 upgrade
    • + 10.8.2 upgrade
    • + Moving SystemConfiguration folder to trash, as instructed by apple phone support, then rebooting


    I am using a 4-port router - DSL modem - wifi acces point. I have tried every one of the ports with different cables but it is still not working. So I am forced to connect via wifi


    Also, I can connect using a Windows laptop and I did not have any problem with Lion, so it is clearly an OS issue wich has not been solved in the last two updates.


    About time Apples comes up with a solution to this issue

Previous 1 2 Next