Previous 1 2 3 4 Next 444 Replies Latest reply: Mar 26, 2015 7:24 PM by kahjot Go to original post Branched to a new discussion.
  • nickditoro Level 1 Level 1 (10 points)

    Ditto here. Ever since upgrading to Mountain Lion from Lion, my external USB and Firewire drives (including Time Machine) eject as soon as my early 2008 Mac Pro goes to sleep. I've just installed Caffeine, but obviously this is only a band-aid until Apple can patch this OS.

     

    I haven't noticed anything on my Macbook Pro since Mountain Lion was installed. True, I don't have any external drives permanently attached (I attach Time Machine when prompted), and as a laptop, the machine hibernates anyway.

     

    Nick

  • dynamix1 Level 1 Level 1 (0 points)

    I've decided to take some drastic measures and do an old windows trick, if all else fails reinstall. That is what I did, a fresh install of just ML, all the posts here show upgrade from lion or upgrade from SL, I did the same. Updated lion from SL and upgraded ML from lion. After doing a fresh install all of my issues have been resolved. I have no more disconnects and my systems seems to be running faster now as well.

  • nickditoro Level 1 Level 1 (10 points)

    dynamix1, glad to hear this is working for you. I had thought about doing that as well but wasn't sure how to go about it. I went so far as to click "download" on ML in the App Store, which said I had already downloaded it. At that point, I decided to install Caffeine and watch the forum.

  • ab57 Level 1 Level 1 (0 points)

    I have also been running Hardware Growler and noticed last night that I got the disk eject problem a few hours after I had gone to sleep. (I had turned off Caffeine and left the LaCie 3TB on just to see what happened). In Energy Saver settings I had turned on "Wake for network access" and "Put disks to sleep when possible" and am now going to try with these turned off to see if that makes a difference. Pretty sure it won't as I think I've tried this once before - just double checking.

     

    Dynamix1 - thanks for the info re the full reinstall. I am really really trying to avoid that given the amount of "stuff" I have installed and the time it took to setup things. Also have never done a full reinstall on a Mac and not sure I want to learn just cause of an Apple bug. But thanks anyway and hope your system continues to work properly for you.

     

    Andrew

  • ab57 Level 1 Level 1 (0 points)

    Well surprise surprise - nah not really....

     

    Came home from work and "woke" iMac by tapping the keyboard - this was the day I left "Wake for network access" and "put disks to sleep" both disabled - and discovered the following:

     

    1. When the screen first "woke" it showed the desktop with the external drive mounted.

    2. As it continued the waking process, I suddenly then got the "disk ejected" message basically as the waking process concluded.

     

    Nothing in the above to help anyone really - just some more information for anyone interested and going throught their own testing and "debug" process.

     

    Roll on 10.8.1

     

    Andrew

  • ab57 Level 1 Level 1 (0 points)

    Last night I installed this app

    http://www.macupdate.com/app/mac/31158/keep-drive-spinning

    and set it to "check" every 180 seconds and this morning on wake from sleep the system woke with no issues with the "problem" drive not being ejected on wake. My enery saver settings currently have "put drives to sleep where possible" selected so the main system drive was able to spin down when the system was asleep just not the external one.

     

    Still not an indeal situation but better than running Caffeine which requires the whole system and display to be kept awake.

     

    Keep Drive Spinning is a free app and not on Apple's list of approved install sites so you need to adjust security settings to enable the install. No idea how trusted the developer is sorry however FWIW I have Norton Internet Security installed and it did not complain.

     

    Hope this is of help to others.

     

    Andrew

  • ab57 Level 1 Level 1 (0 points)

    Sorry folks - ignore that suggestion - just had the same problem with the random dismount on waking and whole Finder froze (beachball) so am removing Keep Drive Spinning.

     

    Andrew

  • OsirisIsisSeth Level 1 Level 1 (0 points)

    I have been experiencing the same issue since I installed Mountain Lion on my 27" late 2011 iMac.  I have tried various suggestions listed around the forums, but nothing has worked so far.  The only thing that works is disabling sleep completely, while setting the screen to turn off after a short period of time.  Far from ideal, but at least a temporary fix that won't damage the screen or overheat the computer.

  • mattplowman Level 1 Level 1 (0 points)

    I have been having the same issue since Lion, but it has gotten much worse in ML. In Lion only 1 of the USB drives would regularly eject on sleep. Now all 3 egect, including the backup drive, and this seems to happen during mid backup as well.  I did a fresh install of ML and that had no effect on the problem.

  • IMRAN Level 2 Level 2 (475 points)

    Count me in on this latest frustration in Mountain Lion...

     

    Every time I connect a USB flash drive and try to transfer files, I get the dreaded,

     

    The Finder can’t complete the operation because some data in “.DS_Store” can’t be read or written.

    (Error code -36)

     

    error or the alert stating:

     

    The disk was not ejected properly. If possible, always eject a disk before unplugging it or turning it off.

     

    These are both false claims by OS X Mountain Lion. I did uncheck the put disk drives to sleep options in System Preferences but this bug is additional to that one.

     

    Console also shows:

     

    The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.

     

    as the OS fails to mount back the flash drive or enable it to be reformatted. Very frustrating.

     

    Imran

     

    Message was edited by: IMRAN: Changed an unnecessarily boldfaced error message pasted text to general text for aesthetic reasons.

  • IMRAN Level 2 Level 2 (475 points)

    Here is an example from the logfile showing the series of events from when the USB flash drive is inserted, to when the system fails during a file copy (it can happen with a single 58MB file or with 2.1MB files whether they are dragged as files or in a folder)...

     

    8/11/12 11:27:35.382 PM fseventsd[34]: log dir: /Volumes/C_USB_2GB/.fseventsd getting new uuid: 06CDAC3D-1BEF-4510-ADA7-DC978DDE13A5

    8/11/12 11:28:20.000 PM kernel[0]: USBF:          91820. 35          AppleUSBEHCI[0xffffff80198d3000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)

    8/11/12 11:28:26.000 PM kernel[0]: USBF:          91826. 39          AppleUSBEHCI[0xffffff80198d3000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)

    8/11/12 11:28:26.000 PM kernel[0]: USBF:          91826. 71          [0xffffff80199cdc00] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 4 of Hub at 0xfa100000)

    8/11/12 11:28:32.000 PM kernel[0]: USBF:          91832. 44          AppleUSBEHCI[0xffffff80198d3000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)

     

    This was a drive formatted on the same MacBook Pro Mountain Lion a few minutes prior to this, so the problem is not in how this drive was formatted. It happens with other flash drives also.

     

    Imran

  • spawn5m Level 1 Level 1 (0 points)

    Same error here .

  • Martin Zedig Level 1 Level 1 (15 points)

    I have set up my machine with two diskimages on an external drive. They are encrypted with unsaved passwords in keychain (in case someone should feel like "borrowing" the drive.) The images contains both my movies wich I share in the network for mediaplayers and by confidential business files. I sometimes access them over the internet from work with ssh

    Now with ML they are ejected every night and I cant reach them until I mount them manually with my password.

     

    This ***** bigtime for my kids and their mediaplayers when Im not at home.

     

    I have set the NOsleep on disks without success. I actually is thinking of a refund on this OS.

    This is not the way things are supposed to work. WHO is to tell me when to eject MY stuff...

  • boxallw Level 1 Level 1 (0 points)

    Same problem. My TM backup got corrupted becuase of this. Had to reformat!

     

    So now I just manually eject my two external discs before putting the machine to sleep.

     

    My machine never sleeps (setting in prefs) so it is up to me.

     

    Pain in the.....

  • OsirisIsisSeth Level 1 Level 1 (0 points)

    Has anyone filed a bug report, or heard anything from Apple?

Previous 1 2 3 4 Next