1 9 10 11 12 13 Previous Next 433 Replies Latest reply: Jun 4, 2014 2:58 PM by cair0 Go to original post Branched to a new discussion.
  • 150. Re: External hard drive ejects on sleep
    Mambo_Jedi Level 1 Level 1 (0 points)

    I've followed this thread with interest since I recently purchased a 3TB Seagate Backup Plus drive for Time machine backups.  Much to my surprise, the drive has not been dismounted/ejected when my system goes into sleep mode.  The drive is connected to one of the USB 3.0 ports.

     

    My configuration:

     

    13-inch MBP, Mid 2012

    2.5 GHz Core i5

    OS X 10.8.2  (12C60)

    8GB RAM

     

    "Put Drives to sleep" is checked in Energy Saver settings for both Battery and Adapter.

     

    My Mac has been in sleep mode multiple times including overnight and when awakened - the drive is still shown on the desktop. Mounted and accessible.

     

    Wondering what is different with my system.

  • 151. Re: External hard drive ejects on sleep
    joelw135 Level 1 Level 1 (0 points)

    My NAS drive which I use for Time Machine will not back up unless the machine is awake. It doesn't unmount but it won't backup.  If I have a volume on the NAS drive mounted it disconnects on sleep.

  • 152. Re: External hard drive ejects on sleep
    molarmech Level 1 Level 1 (0 points)

    It seems like both you and Little Nelle are running a Seagate Backup Plus, and are not having any problems, which makes me think the problem may be with the hard drive devise.  Once I got a defective drive and device replaced, I have had no problems either.  It seems like the problems may be associated with the brand or type of drive system being used for the time machine backup.  Most, or all, of these problems seem to have arisen since ML.  I agree that it seems Apple should be able to do something which makes it more compatable with various hard drive systems.  However, it seems to me that the problem lies with various companies products not being compatable with the new OS.  Once I contacted Drobo regarding the problem, they replaced my entire Drobo unit, which solved the problem.

    Try contacting the manufacture of the backup unit to see if they are aware of the problem. They may have a fix on there end.

  • 153. Re: External hard drive ejects on sleep
    Little Nelle Level 1 Level 1 (0 points)

    The Seagate Backup Plus that I bought (and am using without any problems) uses a 3.0 USB cable. My husband, who's an IT Tech, thinks that that cable capacity is the key to the problem — the 2.0 may be indadequate to handle the data flow relating to Mountian Lion and so it shuts down the device.

     

    He is also of the opinion that Apple designs its products for the latest technology, so they're not going to go backwards on this one. With them, it's often "upgrade your stuff to match us or get left behind." Adobe is the same.

  • 154. Re: External hard drive ejects on sleep
    Cynops Level 1 Level 1 (0 points)

    No, my machine is a USB 2.0 Mac Pro with a USB 2.0 hard drive connected by a USB 2.0 cable. I don't understand why this is taking so long to fix. The problem is "stable" on my machine, sleep it for any reason and the drive unmounts incorrectly, every single time. It shouldn't be that hard to track down.

  • 155. Re: External hard drive ejects on sleep
    molarmech Level 1 Level 1 (0 points)

    I agree!  However, I'm using Firewire 800 with my Drobo S unit, and everything is fine.  I was in hopes for everyone still having the problem, that Apple would try to fix the problem even though it is related to some units which are not the latest technology.

  • 156. Re: External hard drive ejects on sleep
    rhjph Level 1 Level 1 (15 points)

    You can only use a USB3 cable with a USB3 drive, since they are different from USB 2 at the drive end. I have any number of USB3 cables - which one I use makes no difference to the problem.

     

    Has anyone actually told Apple about this, rather than sounding off in the forums, which generally they don't read?

  • 157. Re: External hard drive ejects on sleep
    Obsidian Walker Level 1 Level 1 (0 points)

    New to Macs. Can only seem to find a Developer bug reporter. Was gonna get one of our devs at work to report it for me.

  • 158. Re: External hard drive ejects on sleep
    molarmech Level 1 Level 1 (0 points)

    Early on, when ML first came out and I had the problem, I was in contact with an Apple senior advisor.  He had me down load an Apple program which would caputure my data and report it back to him.  He said that there was no problem with OS ML, and the problem was with the external drives (Drobo).

    Thus, Apple was aware of the problem at some level, but seems convienced this isn't their problem.  Perhaps someone, who is still having the problem, should try and contact Apple again!

  • 159. Re: External hard drive ejects on sleep
    eMac Mac Level 1 Level 1 (25 points)

    I have just got a 3TB Seagate Backup Plus connected to the USB 2 port and mine keeps getting ejected when the Mac goes to sleep. Oh its a new iMac with a new Mountain Lion upgrade from Lion that came with it.

  • 160. Re: External hard drive ejects on sleep
    eMac Mac Level 1 Level 1 (25 points)

    Okay I figured out why my Seagate Backup Plus was being ejected when the imac went to sleep. I use a PowerDown plug to shut off power to my peripherals when the computer switches off. This was interferring when the iMac slept. Unplugged it and all seems okay again.

  • 161. Re: External hard drive ejects on sleep
    AHF Level 1 Level 1 (0 points)

    Does anyone have a workaround or a solution to this? I only just upgraded (finally) to Mountain Lion and this problem has only appeared with the new OS. Here are my Energy Saving settings - am I doing something wrong?

     

    001.png

     

    Some people have mentioned the software "caffeine" as a solution, has anyone has success with this? I'd even settle for a temporary solution until Apple fixes this.

     

    I have other hard drives connected via USB but only one of them -- the one I'm using for Time Machine -- is causing a problem. Any help would be really appreciated as this is a frustrating problem.

     

    Thanks.

  • 162. Re: External hard drive ejects on sleep
    JoxyHom Level 1 Level 1 (0 points)

    Hi,

     

    I have the same problem. I have a 15" late 2007 MBP.

    I was able to use a 500 GB Verbatim external hard drive (USB 2.0) wihtout any problem.

    But this drive wasn't mine, so I bought myself a Freecom Classic II 1TB external hard drive (USB 2.0).

     

    It ejects all the time when my MBP goes to sleep for a longer time. Without exception.

    I cannot even find my drive in the /dev folder (only my internal drive). So it's impossible to remount it without physically unplugging and replugging the hard drive.

     

    However I've found an interesting thing:

    I checked the kernel extensions after waking up my MacBook.

    And two of the extensions were missing (unloaded):

     

    com.apple.iokit.IOUSBMassStorageClass

    com.apple.iokit.IOSCSIBlockCommandsDevice

     

    When I plug my hard drive again, they will load again, and everything works fine until the next sleep.

     

    I tried to manually load these kernel extensions after waking up my computer. They loaded but I still wasn't able to mount my external drive.

     

    I guess the only sollution for this is to umount the drive before sleep (for example with Jettsion), and then manually unplug-replug the drive the next time I want to use it...

     

    I hope someone will have an idea what causes these two kernel extensions to unload.

  • 163. Re: External hard drive ejects on sleep
    tallia1 Level 1 Level 1 (0 points)

    after dozens of unproper unmounts OSX managed to corrupt my disk... I had to re-format it because repairing it from DiskUtility was not an option anymore...  It didn't do much damage to me as only the backup partition was corrupted.. nevertheless, be careful!!!!

  • 164. Re: External hard drive ejects on sleep
    JoxyHom Level 1 Level 1 (0 points)

    Jettison might be useful for you. It will always unmount your drive before your computer goes to sleep, so you can prevent this problem.

     

    https://itunes.apple.com/us/app/jettison/id447430809?mt=12

     

    It's not free, if you want a free sollution, you might find some scripts in other forums...

    But Jettison is really convenient and it'll protect your drives.

1 9 10 11 12 13 Previous Next