Previous 1 10 11 12 13 14 Next 446 Replies Latest reply: Feb 2, 2016 11:35 AM by danfratamico Go to original post Branched to a new discussion.
  • ziemaustin Level 1 (0 points)

    Hi all, I just read through the entire post and am just as confounded over this one as most of you. Was hoping to see if you all have seen any issues with other usb devices since the update. I have a 2009 imac 27" and an external Seagate 1TB HD which has the usual unmounting issues when waking from sleep, and the same error message that says it was ejected improperly. What I haven't seen mentioned is corresponding issues with other USB devices aside from hard drives. I have a digital sound recorder I connect via USB that will eject in the middle of transfering files from the micro sd card and the files will error out. I also discovered yesterday that my digital SLR is not even recognized by the system when I connect via usb (worked fine previously). Not trying to lump in other issues here, but it seems like too much of a coincidence to not be related. Anyone else?

  • RolfKrueger Level 1 (0 points)

    Jettison resolves the error message, but doesn't remount the disc on wake. Interestingly, by 1TB Airy (USB2) is doing fine. Only the newly bought 2TB Airy (USB3) makes the problems.

  • RolfKrueger Level 1 (0 points)

    Hey folks!


    I have now returned the hard drive which got ejected on sleep (Airy) and got a Seagate Expander - and everythink works smoothly.


    With the other hard drive, my Mac went to sleep, woke again after 2-3 seconds and then slept after 10-20 more seconds. The log said: "Wake command from USB device." and then "no media present" and then "terminated group "big backup" (thas was the name of the HDD).


    I assume it has todo with how the HDD is going to sleep. It issues a wake command because it is not finished with going to sleep when the mac is switching off. But at that time of rewaking of the mac after a few secs the HDD is sleeping so it doesn't respons to the OS, which "temrinates" the HDD thinking it is away.




  • tago Level 1 (115 points)

    I did a clean reinstall of Mountain Lion and, guess what, now it works perfectly! No more disconnections

  • JoxyHom Level 1 (0 points)

    Hi Guys!


    Tago you're lucky. I did the same, but it didn't solve the problem in my case.


    However!!! Last night I've found a possible solution which works for me!!!

    I've bought a USB HUB with external power supply. I went to sleep last night, so did my MBP.

    And guess what? Jettison was able to remount my external hard drive this morning! I'm really happy.

    I guess it should work now without Jettison, too. But I think I'll still use it for safety reasons.


    Here's what I have:


    - 1 TB Freecom classic II external drive

      - Wiretek 7 port USB HUB



    I think the LaCie drives have the same issue, so this should be a solution for those, too.

    It's really important, that the external power source is strong enough: 2 A at least, but 3 A preferably.


    I hope this will help you, too!


    Good luck!

  • Pisonia Level 1 (0 points)

    Add my name to the list, Apple ...  I have a brand new Mac mini (late 2012) and a 500Gb OWC Mercury Elite Pro external hard drive connected to a Kanex 4 port USB 3.0 hub.  I left the computer to go eat dinner and when I came back, it was asleep.  No surprise there.  But a big surprise when I woke it up:  a "you didn't eject the drive correctly" dialog box.  The problem occurred the second I was able to see the screen - I noticed the few icons that I have on the desktop "jump" when the OWC icon disappeared.  The Kanex is externally powered - 5v/4 amps - and the drive gets its power from the hub, not from the Mac.  I had to turn the drive off and then turn it back on before it appeared in the Finder again.  This is going to play havoc with my backups.  I'm not using Time Machine yet as I prefer to use the program that I've used for years - SuperDuper!  With a backup set for 2 a.m. every Saturday morning, this is not going to work.  Get your act together, Apple!!  Between Apple's crappy implementation of AppleIDs (I'm on my third one, now) and now, this new issue, I'm starting to get really irritated with the company.

  • cybercap Level 1 (5 points)

    Same problem here. New imac late 2012. I have a powered usb 3.0 hub with 4 drives connected. When imac goes to sleep and i wake it later i get the red exclamation ejection problem box and the drives are gone. Then they seem to remount one after the other, takes time, real pain

  • Pisonia Level 1 (0 points)

    An update:  I opened an Apple Care ticket on this issue and I've gotten some good suggestions from them about troubleshooting.  They had me create another user and I have determined that the problem also occurs with the Test User account, which would lead one to believe that there is a hardware issue, not a software issue.  Here is where it gets interesting.  At first, I thought that the problem was with the Kanex 4 port USB 3.0 hub, because when I disconnected the hub (and the OWC Mercury Elite Pro 500 Gb external drive) from the back of the Mac mini, the problem didn't occur.  But then it occurred to me to see if the problem might be with the OWC drive.  It turns out that it does appear to be the drive BUT there is something else I want to try.  When I first had this problem, it was as others say here - the improperly ejected device notice.  But when I connected the external drive directly to the back of the mini, that problem didn't re-occur.  At that point, I thought that the problem was with the hub, but see above - it doesn't appear to be the hub that is causing the problem.  What I'm going to do tonight is to turn the external drive on because the problem has been occurring with the external drive turned OFF.  How is that for a bizarre problem?  If I turn the drive on and the computer dies, like it has been doing with the drive turned off for the last two days, then there is something else going on.  But I don't think that is going to happen, because for a couple of days, I kept the external drive turned on.  I finally turned it off because I wasn't using it and that seems to be when the problem started.  I've tried different USB 3.0 ports on the mini, too.  It boggles my mind that a powered down device could cause a problem with ML that would cause the computer to shut down.  It is so touchy that if I go away for an hour or so and then return, I always look at the power light on the mini - it is usually cycling from bright to dim, as it should.  But if I do so much as to merely turn on the fluorescent lamp on the computer desk (it isn't connected to the same outlet as the UPS is - though it may be on the same branch circuit), the mini light goes out and the computer has to be re-started.  Weird - just totally weird!!!

  • JoxyHom Level 1 (0 points)

    I'm a bit surprised that you have problems even with powered hubs, because this is thing that solved for me the problem. However there are a few more things here that worth mentioning.


    1. As Cybercap wrote, my external drive remount really slowly, too. (But without the powered hub, it didn't remount at all.)

    2. I still use Jettison to prevent the "didn't eject the drive correctly" warning.

    3. I have USB 2.0.


    So my tip is that maybe it's worth trying the external power supply and Jettison together. The drives will hopefully remount, but slowly and without the warning.

    I don't have experience with USB 3.0, though.


    Good luck.

  • cybercap Level 1 (5 points)

    Thanks for the feedback and happy new year :)


    My hub is a SATA to USB3 4-drive bay which has its own power.

    I will try with a self-powered drive, i got a rugged Lacie 500gb 3.0 which i can plug directly in an imac 3.0 port.

    I guess it will be the same problem.

    We have to get ML to keep the drives connected even when it goes to sleep OR to have it eject them properly and remount them without hassle on wakeup.

    As far as i'm concerned i'd rather have ML keep the drive online, remounting takes some time and if you have opened files or if you have downloads in progress and the drive ejects you are in trouble.


    The only solution i have so far is to prevent the mac to sleep (just screen turns off)

  • Pisonia Level 1 (0 points)



    This is getting a little bit off the topic of this post by iamapple, but I wanted to post the latest.  It does indeed appear to be the drive, unless there is something in OSX 10.8.2 that has an issue with USB 3.0 external drives.  I had no problem last overnight with the external drive turned on - the mini was fine this morning.  So I turned it off and the computer went to sleep died.  I re-booted and the next time I woke it up, all was O.K.  I let it go to sleep again and when I returned some hours later, I was looking at the login screen, which means the computer spontaneously rebooted.  I then disconnected the drive and tried to contact OWC.  Good luck with that on New Year's Eve afternoon!  Please do let me know what happens with your LaCie USB 3.0 drive.  I'm really curious to know if I just have a bad drive (??? - a turned-off drive causes a computer shutdown or reboot???) or if the problem is more wide-spread.  I'll call Apple Care and let them know the latest.

  • debaire Level 1 (0 points)

    It might make sense if you had a new computer and/or a new hard drive. However, there are a lot of us who had perfectly working systems before ML and now are experiencing issues after the upgrade.

    To make matters worse, it only happens to me maybe once a month now instead of everytime. No explanation except I had to disconnect all of my cables to move my MacBook Pro from one room to another. Since then it seems to be more agreeable. Is that a reason? Who knows? I wish I had answers. For now, I will follow this thread closely and be thankful for a 97% issue-free experience. Again, just to recap, mid-2010 MacBook Pro now on 10.8.2, plugable 2.0 hub and a LaCie 2TB USB 2.0 drive.

  • Pisonia Level 1 (0 points)



    I agree with you that it might make sense if I had a new computer, which is exactly my situation.  New Mac mini (late 2012) and new hard drive.  I'm glad, in a way, that it is happening to users of other, older machines, because that indicates to me that the issue may be with Apples' implementation of USB 3.0.  Your experience that it happens occasionally is interesting, too, because that happens to me, also.  Though not occasionally - one time today, nothing happened, but three other times, the computer either shut down completely or rebooted.  Late 2012 Mac mini, 10.8.2, pluggable 3.0 hub and OWC Mercury Elite Pro 500 Gb external drive.  I hope others weigh in with their experiences.  Are all of you calling Apple Care to bring this to the attention of the engineers?

  • wclyffe Level 1 (5 points)

    How many people are having this problem (the original post: "External hard drive ejects on sleep") using a Thunderbolt drive powered directly from a new 2012 Mac?  Just curious if this configuration eliminates this problem.


    My combo: 2012 MBP, OS 10.8.2 with an OWC Elite Pro Quad HD connected via the Firewire 800 port for Time Machine.

  • Pisonia Level 1 (0 points)



    Is your configuration working? If it is, then maybe the problem is with Apple's implementation of USB 3.0?  If you aren't having any issues, then maybe, when I get ahold of OWC, I can exchange my USB 3.0 drive for one that has a Firewire 800 connection on it.  Mine doesn't - only ESATA and USB 3.0.

Previous 1 10 11 12 13 14 Next