Previous 1 12 13 14 15 16 Next 447 Replies Latest reply: Mar 14, 2016 9:38 AM by pictureartisan Go to original post Branched to a new discussion.
  • Pisonia Level 1 Level 1

    I'll guess that you don't have a contract with Apple Care?  I think that would be my next step, if I were in your position.  I realize that Apple Care isn't cheap, but I guess it all depends on how much your time (and frustration) is worth ....

  • arsdc Level 1 Level 1

    I have been tracking this subject for quite a while, hoping for a resolution, or even a good explanation of why some have a problem and others do not; and why for some it is intermittent, variable etc. So here is my own experience.

    1. I have a WD hard drive that is only for TimeMachine. It is connected directly to my MacBookPro by USB 2.0.

    2. Never had a problem until I installed Mountain Lion. I got the usual warning about the drive not ejected properly, but it would then not be recognized at all. I had to reformat the drive.

    3. Since then I get intermittent warnings about improper ejection, but the drive continues to operate and be recognzied. I leave my computer on most of the time, and I guess I only have a problem once every few weeks.


    The entire issue is perplexing, and I had hoped common enough to warrant Apple's attention. If there are others like me who  have this problem but have not chimed in yet, please do so. Perhaps there will be power in numbers.


    thx all


  • Obsidian Walker Level 1 Level 1



    Having never owned a Mac before, this first experience is a real pain. I have a Western Digital Green 2TB in a USB 3 caddy that ejects constantly. No damaged files so far, but I can't get a time machine backup sorted. Having to leave the Mac mini turn on 24hrs as I can't let it sleep because of the eject issue.


    Slightly wishing I hadn't bought one now.

  • Pisonia Level 1 Level 1

    Alan, I'm not sure Apple monitors these threads.  Do they?  I think a better couse of action is to call Apple Care, if you have a contract.  I don't, but I have 90 days of free support from the time I bought my mini and I've called them at least 8 times so far.  I had a mini running Tiger (since 2005) so I'm not new to Mac.  But this ML is a real piece of work.  I called three times before I was referred to advanced support.  So far, with an OWC Mercury Elite Pro 500 Gb external drive plugged directly into the computer, I've not had the ejection issue.  I did when it was plugged into a USB hub, though.  Nor, since I did an SMC reset, have I had a turned-off drive kill the computer.  But I only intermittently get a dialog box that asks if I want this to be a Time Machine drive (I've answered "ask me later" because I haven't gotten to the bottom of the issue yet) and, even more puzzling, when the computer is asleep and I return to the desk and turn on the fluorescent lamp above the monitor, the computer wakes up!!  Sometimes, it goes to sleep again in a few minutes and other times, it stays awake.  There is definitely some kind of power issue here and I'll be sure to mention this to Apple when I call on Monday and speak to my dedicated senior technician.  The fluorescent lamp has a capacitor in it so, even though it is not plugged into the UPS, it must still be on the same branch circuit and causing some kind of power surge that is affecting the computer.  How it can do that is beyond me, because I have a true in-line UPS made by Powerware (model 4125) - AC to DC and then DC to AC.  As you said, perplexing.  And bizarre.

  • Pisonia Level 1 Level 1

    I hear you about wishing that you hadn't bought a Mac - I've thought the same.  If I ever get this sorted out, I'm going to install VMware Fusion 5.0 and get a copy of Ubuntu.  I'm not nearly as fond of Apple as I was a few years ago - they are wearing out their welcome with all of these issues.  We pay a premium to be locked into the MacApp store and put up with issues like these??

  • IMRAN Level 2 Level 2

    Here is an example from the logfile showing the series of events from when the USB flash drive is inserted, to when the system fails during a file copy (it can happen with a single 58MB file or with 2.1MB files whether they are dragged as files or in a folder)...


    8/11/12 11:27:35.382 PM fseventsd[34]: log dir: /Volumes/C_USB_2GB/.fseventsd getting new uuid: 06CDAC3D-1BEF-4510-ADA7-DC978DDE13A5

    8/11/12 11:28:20.000 PM kernel[0]: USBF:          91820. 35          AppleUSBEHCI[0xffffff80198d3000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)

    8/11/12 11:28:26.000 PM kernel[0]: USBF:          91826. 39          AppleUSBEHCI[0xffffff80198d3000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)

    8/11/12 11:28:26.000 PM kernel[0]: USBF:          91826. 71          [0xffffff80199cdc00] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 4 of Hub at 0xfa100000)

    8/11/12 11:28:32.000 PM kernel[0]: USBF:          91832. 44          AppleUSBEHCI[0xffffff80198d3000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)


    This was a drive formatted on the same MacBook Pro Mountain Lion a few minutes prior to this, so the problem is not in how this drive was formatted. It happens with other flash drives also.


    A separate problem is unrelated to sleep.. Unexpected ejects during file copies without sleep involved.

    Count me on these increasingly dangerous mid-data-transfer ejects, even of things that do not have fancy drivers (e.g. camera memory cards) since Mountain Lion. The problems are NOT limited to USB. They happen on FireWire 800 on my MacBook Pro as well as on USB with or without a hub.






  • petethesweet Level 1 Level 1

    Controler may be a good candidate. Adding some data points, I have a self-powered USB3 and an externally powered USB2 directly attached to my MBA, both running as time machine disks. The USB2 hasn't been ejected during sleep over the last 2 days, while the USB3 never survives my lunch break. If someone can rule out the power source and USB version (I may have missed something), it is the controler... And an OS bug. The system should be aware of disks it cannot maintain and give at least a warning or refuse to sleep (unless forced). My 2c.

  • joelw135 Level 1 Level 1

    I found another flaw regarding external drives and sleep.  I run SuperDuper for schedualed backups. The backups run at 11:30 PM every day on different external drives.  What I find is that the backup software loads and starts but as soon as the iMac sleeps it stops the backup then when the iMac awakes it restarts. So maybe the problem is with the USB going to sleep when in use. This makes another major flaw with the OS.

  • molarmech Level 1 Level 1

    Last year, I was having a problem with my external hardrive improperly ejecting giving me the dreaded Red notice.  However, once Drobo replaced my external drive unit, I haven't had any problems.  I'm connected via FW800, not USB.

    My reason for jumping back into this thread again is to agree with Pisonia, that I think this is a problem that Apple needs to hear more about.  I was told by a senior Apple advisor, that they don't monitor these sites, so I think the more you contact Apple directly regarding the problem the faster you are likely to get a solution.

    While my problem is now solved, it didn't exsist until I upgraded to ML, therefore, I can't help but believe there must be something with the software which is contributing to this problem!

    If everyone having this sort of a problem would contact Apple, I'll bet we might see a solution.  Give it a try.  Good luck. 

  • Pisonia Level 1 Level 1

    Hmmmm ... I haven't tried running SuperDuper! yet as I'm waiting to see if Apple's solution worked.  But once SuperDuper! wakes your computer up, it should stay awake until the backup is done because the last step for SuperDuper! is to put the computer back to sleep.  Or at least that is the way it worked for me when I was running Tiger.  If it works differently now, I'd like to know ....  Apple's solution for me, by the way, was to do a NV RAM reset and an SMC reset.  SMC is the System Management Controller.  I don't know if one or the other helped, but I've only had one spontaneous reboot since performing those two procedures.

  • EddieONON Level 1 Level 1

    Me too... also got this problem....

    My NAS disk always eject when system woke up.

    10.8.2, iMac 2011

  • petethesweet Level 1 Level 1

    I just had a conversation with Apple support. There is a related, known bug which they are working on, but I did not get more detail. Currently the only workaround is to manually eject the suspect drive before standby mode starts (not good for all scenarios). The final tipp was to check with the disk vendor for any tools/firmware options. I saw some USB disk vendors "advertise" disks for compatibility with Time Machine. Maybe someone has some experiece with those? I would love to see anything like "this particular (USB 3, powered by the USB connector) disks works with a MBA under 10.8.x". :-)


    PS: Anyone who bought his/her Macbook not too long ago can use the initial support to give Apple a call... ;-)

  • bridgwater Level 1 Level 1



    Apologies I started a new thread and then saw this one


    I have the same basic problem as everyone else, though no disk corruption problems as yet


    I have just bought a brand new Imac desktop running Mac OS 10.8.2


    I've connected and formated a WD Elements 500Gb hard drive as my time machine.


    So like many others, when I put the Imac to sleep the external drive undocks and won't redock on boot up of the Mac unless I disconnect the USB 3.00 lead and plug it back in.


    Are there any work arounds available?

  • Pisonia Level 1 Level 1

    My expeience has been that if the drive is plugged into the computer, it is O.K., but if I plug it into a hub, I get the problem that you have.  I "solved" my problem by plugging the drive into the computer.  But I still have the problem of spontaneous re-booting, though not as often as I had it before doing an SMC reset and an NV RAM reset.  You might try doing those two procedures to see if it helps.  Search on the internet for those phrases - this forum doesn't do well with links.  Nor does it do a lot of other things.  Get your act together, Apple, and start using forum software that is user friendly and standard!

  • bridgwater Level 1 Level 1

    Hi Pisonia,


    My WD 500Gb is plugged directly into the Mac and nit via a hub. It simply undocks when I put the mac into sleep but does not get woken up by the Mac when I switch back on. I f I unplug the unti and replug, the Mac recognsies it and starts the backup.


    Some posters have suggested its a problem with my drive but I am not so sure given the number of reports of this problem across a number of different backup drives.

Previous 1 12 13 14 15 16 Next