Previous 1 15 16 17 18 19 Next 444 Replies Latest reply: Mar 26, 2015 7:24 PM by kahjot Go to original post Branched to a new discussion.
  • debaire Level 1 Level 1 (0 points)

    Not true. I have a mid-2010 MBP having the same issue. The hard drive is a Lacie 2TB USB 2.0 external drive. And it is not my TM drive. I have a different external drive that is my TM drive and it doesn't exhibit any problems. The only consistency (maybe) is that the problem drives are Lacie made.

  • jeroenimo Level 1 Level 1 (0 points)

    Is this a USB bus powered drive or a 3.5 inch external powered drive. Because I think that the problem lies in that the USB 3.0 drive get powered down by the Mac, and if the drive has an external supply this would not happen, because the drive does not rely on the Mac powering it.

     

    I still have issues with my USB 3.0 2.5 bus powered drive. Its gotten better, because the drive mounts again after wakeup but still its gets powered off when my rMBP goes to sleep.

  • debaire Level 1 Level 1 (0 points)

    Mine is externally powered. I do have to say it only does it around once a month now, for some reason. It used to do it every day. Nothing has changed.

    Also, I'm now on 10.8.3 so I'll monitor carefully if the issue is solved for me or just not as frequent.

  • Greg Parks Level 1 Level 1 (135 points)

    FWIW, I have the same problem with one of three connected external drives. It used to happen occasionally when I was using 10.7 Lion, but since upgrading to 10.8.2 (and now 10.8.3) it happens consistently, whether I put the computer to sleep from the Apple menu or it goes to sleep due to inactivity. It happens when I wake the computer after only about 30 seconds of sleep, so it's not a time-related event. Here's my setup:

     

    • MacBook Pro Late 2011
    • LaCie Thunderbolt to eSATA hub connected to Thunderbolt port
    • OWC Mercury Elite-AL Pro Qx2 disk array connected to LaCie hub via eSATA
    • OWC Mercury Elite-AL Pro single disk drive in an eSATA/USB 2/Firewire 800/400 housing connected to the LaCie hub via eSATA. This is the drive that gets unmounted/remounted when waking from sleep.
    • OWC Mercury Elite-AL Pro single disk drive in an eSATA/USB 2/Firewire 800/400 housing connected directly to MBP via Firewire 800. This is a Time Machine backup disk and it works fine.

     

    I've tried connecting the drives differently, and the problem only goes away when the drive is connected via Firewire 800.

     

    I also tried an SMC reset, I ran Disk Utility to repair the external disk and my startup disk (also repaired startup disk permissions) and I changed the disk permissions to read/write for Everyone. None of these steps helped.

     

    I have an open support ticket with OWC, but I suspect they're about out of suggestions.

  • FunkyRico Level 1 Level 1 (5 points)

    ****! This issue just appear after installing the update 10.8.3 on my MacPro 3,1 and a WD 3To hard drive connected with eSata (dock enclosure) to my external PCI Rocket dual eSata.

     

    Now mostly each time my computer go to a "long" sleep, the drive eject incorrectlyHD_crash_after_sleep.png

     

    Any tips on this "old" issue ?

    Best,

    Eric

  • Steve Holton Level 4 Level 4 (1,025 points)

    There is indeed something strange about this.

    I have OWC Mercury Elite AL Pro QX2 raid drive attached via eSATA to an OWC eSATA card on my Mac Pro.

    This never has an issue.

    I also have a OWC Mercury Elite AL Pro drive with USB/eSATA/FW drive.

    When this drive is connected via eSATA to the same OWC eSATA card on my Mac Pro, I always get this problem.

    When this same drive is connected via USB or FW I never get this problem.

    Swapping ports and cables to the OWC eSATA card - no change.

    OWC sent a new drive - no change.

    Swapping ports and cables to the OWC eSATA card - no change with new drive.

     

    OWC says that htey couldn't reproduce on the returned drive - though I'm not 1000% sure they had exact same configuration. (And I think it is some precise combination of things that casue this problem)

    They now think it might be the OWC eSATA card - which makes no sense to me. I suspect that there is something quite specific in configuration that exposes something in the the eSATA firmware in the drive that causes the drive and OS X reveal this problem.

     

    I've just defaulted to FW800 on the drive as it only now used for backups and the lack of eSATA doesn't thrill me - I paid for it - but it doesn't impact my current operation.

  • Helpy Helperton Level 1 Level 1 (0 points)

    Turning off "Put hard disks to speed when possible" solved my issue.

  • FunkyRico Level 1 Level 1 (5 points)

    Good but not on my side unfortunately. Sonnet Support inform that:

     

    Some third-party PCIe card and ExpressCard drivers break after installing 10.8.3 for mid-2012 models of the MacBook Pro and MacBook Air. Please contact your card manufacturer for an updated driver.

     

    source:

    http://www.sonnettech.com/support/charts/osxmountainlion/index.html?tab=3

     

    don't know if there is a correlation

     

    I am useing a Rocket dual eSata (http://www.hptmac.com/product.php?_index=67) and it looks like sleep mode "turn off" the sata channel as I have to reboot to see my hard drive again. As HighPoint Tech does have a good support for Mac User I don't expect much from them. Anyway, I never had this issue before on 10.5.8 or 10.8.x

     

    I tried to apply combo udpate again and did a SMC reset, I will test again later...

     

    Message was edited by: FunkyRico

  • Steve Holton Level 4 Level 4 (1,025 points)

    Turning off "Put hard disks to speed when possible" solved my issue.

    I tried this, and it didn't fix the problem for me.

    Further for me it's not 10.8.x.

    The problem is reproducible on 10.7.5 and 10.6.8.

  • FunkyRico Level 1 Level 1 (5 points)

    Okay SMC reset, etc. does not resolve anything. Curiously for me this issue appears only with the latest osx 10.8.3. update.

     

    I've just noticed one difference. If the sleep is "short", there is no issue, if the sleep is "long" (more than 15-30 min), the drive is missing and a popup error message appear (the drive was not ejected correctly...) and i have to reboot to see the hard drive again. is something messing up with the sata controler? or could it be a process issue ? i'm not a specialist...

     

    The only tip I found is to eject the drive before putting the computer to sleep. Then I can mount it again after wake up to avoid rebooting.

     

    Best,

    Eric

  • DaytonaDave Level 1 Level 1 (0 points)

    I have a 27", late 2012 iMac running OS X 10.8.3. It is not a Mountain Lion update. It came installed on the iMac. I just changed my Time Machine external disk from a LaCie D2 (Lightning to Firewire 800 adaptor) to a larger Fantom GForce/3 (USB 3 directly into iMac. Not a hub.) Both drives are externally powered. No problems with the LaCie, it was just too small.  The Fantom drive is working fine as my Time Machine, BUT...every time the iMac sleeps or is shut down, when restarted it shows the incorrectly ejected warning and the drive is gone from my desktop and disk utility app.  The drive is still on, but I have to turn it off and back on to have it reappear.  If I eject the drive before it sleeps or is shut down, it reappers on startup as it should. The LaCie did not have this problem. Maybe it's a USB3 problem, however, I see on some forums that users have been having this problem with some drives since at least 2009. I find it hard to believe that Apple and the hard drive suppliers haven't solved this problem.  I don't think I did anything wrong in reformatting the drive. There was no new driver or software with this drive. I did notice that the format is listed in the drive info as "Mac OS Extended (Case Sensitive, Journaled)". I never noticed the "Case Sensitive" before this and that is not on my system disk format. Is this a problem? Ejecting the drive before the machine sleeps is a pain, hard to remember and shouldn't be neccessary. We could all sure use some help.

  • JoxyHom Level 1 Level 1 (0 points)

    Hi Guys,

     

    I have the same problem. I have a 15" late 2007 MBP (USB 2.0) and I connected a Freecom Classic II 1TB external hard drive (USB 2.0) to use it with Time Machine.

     

    I always got the annoying "improper eject" warning. Then I downloaded Jettison, which always ejects the external drive before the computer goes to sleep. This solved the problem for me, or so I thought...

    After some time, about a week or so, I received the "improper eject" warning while I was working on my MacBook.

    After this, I started to get this warning more frequently.

    All of this resulted in that I had to reformat my Time Machine drive.

     

    Now, that I had to reformat the drive and I had to do the complete backup process several times, I've decided to buy a new hard drive.

     

    *** My question is: ***

     

    Do you have any recommendation which external drive should I buy?

    So, I'd need the exact type of an external hdd (at least 1 TB), that I could use with my rather old MacBook which has only USB 2.0 ports.

    Thank you so much!

  • DaytonaDave Level 1 Level 1 (0 points)

    My LaCie D2 connected from Lightning to the drives Firewire 800 worked with an adaptor. I have seen older forums that talked about this problem for years. I think some of those discussions said Seagate drives worked but WD's didn't. Some said the same drives had the problem on USB2 but they worked OK on Firewire. I'm no help because I'm lost on this one.

  • Ratchit110 Level 1 Level 1 (0 points)

    i have the same problem, USB3.0 4 port hub and 3 external drives plugged in. found the put HDDs to sleep when possible doesnt help.

     

    Also found it only happens with USB3 devices, my USB2 drives connected to the hub stay connected but my USB3 ones eject

     

    My only fix is to use caffeine to just stop my computer from sleeping hen my drives are plugged in.

  • JoxyHom Level 1 Level 1 (0 points)

    Thanks DaytonaDave,

     

    I know these things are tricky. I've had good experience with an 500 GB Verbatim drive, but it's too small for me. I might try a 1 TB one.

     

    Other option is to use two external drives with Time Machine. I use one drive on a daily basis, and I connect the other drive only occasionally. That is a safer setup.

     

    But I'll wait for other recommendations.

Previous 1 15 16 17 18 19 Next